You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
49 lines
2.3 KiB
49 lines
2.3 KiB
--- configure.orig 2007-08-18 09:42:40.000000000 +0200
|
|
+++ configure 2007-08-18 09:44:10.000000000 +0200
|
|
@@ -8525,14 +8525,14 @@
|
|
fi
|
|
|
|
|
|
- as_ac_var=`echo "ac_cv_cflags_-fPIC -Wl,--rpath,\$ORIGIN/../lib" | $as_tr_sh`
|
|
-{ echo "$as_me:$LINENO: checking whether the compiler supports -fPIC -Wl,--rpath,\$ORIGIN/../lib" >&5
|
|
-echo $ECHO_N "checking whether the compiler supports -fPIC -Wl,--rpath,\$ORIGIN/../lib... $ECHO_C" >&6; }
|
|
+ as_ac_var=`echo "ac_cv_cflags_-fPIC" | $as_tr_sh`
|
|
+{ echo "$as_me:$LINENO: checking whether the compiler supports -fPIC" >&5
|
|
+echo $ECHO_N "checking whether the compiler supports -fPIC $ECHO_C" >&6; }
|
|
if { as_var=$as_ac_var; eval "test \"\${$as_var+set}\" = set"; }; then
|
|
echo $ECHO_N "(cached) $ECHO_C" >&6
|
|
else
|
|
ac_wine_try_cflags_saved=$CFLAGS
|
|
-CFLAGS="$CFLAGS -fPIC -Wl,--rpath,\$ORIGIN/../lib"
|
|
+CFLAGS="$CFLAGS -fPIC"
|
|
cat >conftest.$ac_ext <<_ACEOF
|
|
/* confdefs.h. */
|
|
_ACEOF
|
|
@@ -8582,8 +8582,8 @@
|
|
{ echo "$as_me:$LINENO: result: $ac_res" >&5
|
|
echo "${ECHO_T}$ac_res" >&6; }
|
|
if test `eval echo '${'$as_ac_var'}'` = yes; then
|
|
- LDRPATH_INSTALL="-Wl,--rpath,\\\$\$ORIGIN/\`\$(RELPATH) \$(bindir) \$(libdir)\`"
|
|
- LDRPATH_LOCAL="-Wl,--rpath,\\\$\$ORIGIN/\$(TOPOBJDIR)/libs/wine"
|
|
+ LDRPATH_INSTALL=""
|
|
+ LDRPATH_LOCAL=""
|
|
else
|
|
as_ac_var=`echo "ac_cv_cflags_-fPIC -Wl,-R,\$ORIGIN/../lib" | $as_tr_sh`
|
|
{ echo "$as_me:$LINENO: checking whether the compiler supports -fPIC -Wl,-R,\$ORIGIN/../lib" >&5
|
|
--- configure.ac.orig 2007-08-18 09:44:15.000000000 +0200
|
|
+++ configure.ac 2007-08-18 09:44:46.000000000 +0200
|
|
@@ -439,13 +439,6 @@
|
|
WINE_TRY_CFLAGS([-fPIC -Wl,--export-dynamic],
|
|
[AC_SUBST(LDEXECFLAGS,["-Wl,--export-dynamic"])])
|
|
|
|
- WINE_TRY_CFLAGS([-fPIC -Wl,--rpath,\$ORIGIN/../lib],
|
|
- [LDRPATH_INSTALL="-Wl,--rpath,\\\$\$ORIGIN/\`\$(RELPATH) \$(bindir) \$(libdir)\`"
|
|
- LDRPATH_LOCAL="-Wl,--rpath,\\\$\$ORIGIN/\$(TOPOBJDIR)/libs/wine"],
|
|
- [WINE_TRY_CFLAGS([-fPIC -Wl,-R,\$ORIGIN/../lib],
|
|
- [LDRPATH_INSTALL="-Wl,-R,\\\$\$ORIGIN/\`\$(RELPATH) \$(bindir) \$(libdir)\`"
|
|
- LDRPATH_LOCAL="-Wl,-R,\\\$\$ORIGIN/\$(TOPOBJDIR)/libs/wine"])])
|
|
-
|
|
WINE_TRY_CFLAGS([-Wl,--enable-new-dtags],
|
|
[LDRPATH_INSTALL="$LDRPATH_INSTALL -Wl,--enable-new-dtags"])
|
|
|