Andreas Bierfert 15 years ago
parent 0691f0d97c
commit 52f1825ef1

3
.gitignore vendored

@ -1,2 +1 @@
/wine-1.3.2.tar.bz2
/wine-1.3.3.tar.bz2
/wine-1.3.4.tar.bz2

@ -1 +1 @@
36fe53f4db6d5d98b01f5d5f2cd24d11 wine-1.3.3.tar.bz2
dc8e12b39fab35a45d5f5a8e8f3fc8c1 wine-1.3.4.tar.bz2

@ -1,6 +1,6 @@
--- configure.orig 2010-05-25 19:44:56.000000000 +0200
+++ configure 2010-05-25 19:46:11.000000000 +0200
@@ -5132,10 +5132,10 @@
--- configure.orig 2010-10-04 21:40:28.000000000 +0200
+++ configure 2010-10-04 21:41:40.000000000 +0200
@@ -5135,7 +5135,7 @@
then
convert_version_major=`expr "$convert_version" : '.* \([0-9]*\)\.[0-9]*'`
convert_version_minor=`expr "$convert_version" : '.* [0-9]*\.\([0-9]*\)'`
@ -8,14 +8,19 @@
+ if test "$convert_version_major" -eq 6 -a "$convert_version_minor" -lt 5
then
CONVERT=false
- as_fn_append wine_warnings "|imagemagick version 6.6 or newer is needed to rebuild icons."
+ as_fn_append wine_warnings "|imagemagick version 6.5 or newer is needed to rebuild icons."
fi
fi
if test "$CONVERT" = false
--- configure.ac.orig 2010-05-25 19:45:16.000000000 +0200
+++ configure.ac 2010-05-25 19:46:44.000000000 +0200
@@ -303,10 +303,10 @@
@@ -5144,7 +5144,7 @@
then
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: no ($convert_version_major.$convert_version_minor)" >&5
$as_echo "no ($convert_version_major.$convert_version_minor)" >&6; }
- as_fn_error $? "You need imagemagick version 6.6 or newer to rebuild icons in maintainer mode." "$LINENO" 5
+ as_fn_error $? "You need imagemagick version 6.5 or newer to rebuild icons in maintainer mode." "$LINENO" 5
else
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes ($convert_version_major.$convert_version_minor)" >&5
$as_echo "yes ($convert_version_major.$convert_version_minor)" >&6; }
--- configure.ac.orig 2010-10-04 21:42:45.000000000 +0200
+++ configure.ac 2010-10-04 21:43:18.000000000 +0200
@@ -309,7 +309,7 @@
then
convert_version_major=`expr "$convert_version" : '.* \([[0-9]]*\)\.[[0-9]]*'`
convert_version_minor=`expr "$convert_version" : '.* [[0-9]]*\.\([[0-9]]*\)'`
@ -23,8 +28,13 @@
+ if test "$convert_version_major" -eq 6 -a "$convert_version_minor" -lt 5
then
CONVERT=false
- WINE_WARNING([imagemagick version 6.6 or newer is needed to rebuild icons.])
+ WINE_WARNING([imagemagick version 6.5 or newer is needed to rebuild icons.])
fi
fi
@@ -317,7 +317,7 @@
if test "$CONVERT" = false
then
AC_MSG_RESULT([no ($convert_version_major.$convert_version_minor)])
- AC_MSG_ERROR([You need imagemagick version 6.6 or newer to rebuild icons in maintainer mode.])
+ AC_MSG_ERROR([You need imagemagick version 6.5 or newer to rebuild icons in maintainer mode.])
else
AC_MSG_RESULT([yes ($convert_version_major.$convert_version_minor)])
fi

@ -1,6 +1,6 @@
--- configure.old 2010-04-02 20:43:45.000000000 +0300
+++ configure 2010-04-03 23:26:57.365947610 +0300
@@ -6727,14 +6727,14 @@
--- configure.orig 2010-10-04 21:35:31.000000000 +0200
+++ configure 2010-10-04 21:37:48.000000000 +0200
@@ -6775,14 +6775,14 @@
fi
@ -9,8 +9,8 @@
-$as_echo_n "checking whether the compiler supports -fPIC -Wl,--rpath,\$ORIGIN/../lib... " >&6; }
+ as_ac_var=`$as_echo "ac_cv_cflags_-fPIC" | $as_tr_sh`
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -fPIC" >&5
+$as_echo_n "checking whether the compiler supports -fPIC" >&6; }
if { as_var=$as_ac_var; eval "test \"\${$as_var+set}\" = set"; }; then :
+$as_echo_n "checking whether the compiler supports -fPIC " >&6; }
if eval "test \"\${$as_ac_var+set}\"" = set; then :
$as_echo_n "(cached) " >&6
else
ac_wine_try_cflags_saved=$CFLAGS
@ -19,22 +19,22 @@
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
int main(int argc, char **argv) { return 0; }
@@ -6752,17 +6752,17 @@
@@ -6800,17 +6800,17 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_res" >&5
$as_echo "$ac_res" >&6; }
if test `eval 'as_val=${'$as_ac_var'};$as_echo "$as_val"'` = yes; then :
- LDRPATH_INSTALL="-Wl,--rpath,\\\$\$ORIGIN/\`\$(RELPATH) \$(bindir) \$(libdir)\`"
- LDRPATH_LOCAL="-Wl,--rpath,\\\$\$ORIGIN/\$(TOPOBJDIR)/libs/wine"
- LDRPATH_LOCAL="-Wl,--rpath,\\\$\$ORIGIN/\$(top_builddir)/libs/wine"
+ LDRPATH_INSTALL=""
+ LDRPATH_LOCAL=""
+ LDRPATH_LOCAL=""
else
- as_ac_var=`$as_echo "ac_cv_cflags_-fPIC -Wl,-R,\\$ORIGIN/../lib" | $as_tr_sh`
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -fPIC -Wl,-R,\$ORIGIN/../lib" >&5
-$as_echo_n "checking whether the compiler supports -fPIC -Wl,-R,\$ORIGIN/../lib... " >&6; }
+ as_ac_var=`$as_echo "ac_cv_cflags_-fPIC" | $as_tr_sh`
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler supports -fPIC" >&5
+$as_echo_n "checking whether the compiler supports -fPIC" >&6; }
if { as_var=$as_ac_var; eval "test \"\${$as_var+set}\" = set"; }; then :
+$as_echo_n "checking whether the compiler supports -fPIC " >&6; }
if eval "test \"\${$as_ac_var+set}\"" = set; then :
$as_echo_n "(cached) " >&6
else
ac_wine_try_cflags_saved=$CFLAGS

@ -1,6 +1,6 @@
%define no64bit 0
Name: wine
Version: 1.3.3
Version: 1.3.4
Release: 1%{?dist}
Summary: A Windows 16/32/64 bit emulator
@ -43,8 +43,8 @@ Patch200: wine-imagemagick-6.5.patch
# explain how to use wine with pulseaudio
# see http://bugs.winehq.org/show_bug.cgi?id=10495
# and http://art.ified.ca/?page_id=40
Patch400: http://art.ified.ca/downloads/winepulse/winepulse-0.38-configure.ac.patch
Patch401: http://art.ified.ca/downloads/winepulse/winepulse-0.38.patch
Patch400: http://art.ified.ca/downloads/winepulse/winepulse-0.39-configure.ac.patch
Patch401: http://art.ified.ca/downloads/winepulse/winepulse-0.39.patch
Patch402: http://art.ified.ca/downloads/winepulse/winepulse-0.38-winecfg.patch
Source402: README-FEDORA-PULSEAUDIO
@ -424,7 +424,7 @@ This package adds an openal driver for wine.
%patch1
%patch100
#%patch200
%patch200
%patch400 -p1
%patch401 -p1
%patch402 -p1
@ -689,6 +689,14 @@ update-desktop-database &>/dev/null || :
%defattr(-,root,root,-)
# meta package
%files wow
%defattr(-,root,root,-)
%ifarch %{ix86}
%{_bindir}/wine
%endif
%{_bindir}/wineserver
%{_libdir}/wine/wineboot.exe.so
%files core
%defattr(-,root,root,-)
%doc ANNOUNCE
@ -701,7 +709,6 @@ update-desktop-database &>/dev/null || :
%doc VERSION
# do not include huge changelogs .OLD .ALPHA .BETA (#204302)
%doc documentation/README.*
%{_bindir}/winedump
%{_libdir}/wine/explorer.exe.so
%{_libdir}/wine/control.exe.so
@ -718,7 +725,6 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/write.exe.so
%{_libdir}/wine/dxdiag.exe.so
%ifarch %{ix86}
%{_bindir}/wine
%{_bindir}/wine-preloader
@ -861,6 +867,7 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/imagehlp.dll.so
%{_libdir}/wine/imm32.dll.so
%{_libdir}/wine/inetcomm.dll.so
%{_libdir}/wine/inetcpl.cpl.so
%{_libdir}/wine/inetmib1.dll.so
%{_libdir}/wine/infosoft.dll.so
%{_libdir}/wine/initpki.dll.so
@ -871,6 +878,7 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/itss.dll.so
%{_libdir}/wine/jscript.dll.so
%{_libdir}/wine/kernel32.dll.so
%{_libdir}/wine/ktmw32.dll.so
%{_libdir}/wine/loadperf.dll.so
%{_libdir}/wine/localspl.dll.so
%{_libdir}/wine/localui.dll.so
@ -885,6 +893,7 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/midimap.dll.so
%{_libdir}/wine/mlang.dll.so
%{_libdir}/wine/mmdevapi.dll.so
%{_libdir}/wine/mofcomp.exe.so
%{_libdir}/wine/mountmgr.sys.so
%{_libdir}/wine/mpr.dll.so
%{_libdir}/wine/mprapi.dll.so
@ -929,7 +938,7 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/mswsock.dll.so
%{_libdir}/wine/msxml3.dll.so
%{_libdir}/wine/msxml4.dll.so
%{_libdir]/wine/msxml6.dll.so
%{_libdir}/wine/msxml6.dll.so
%{_libdir}/wine/nddeapi.dll.so
%{_libdir}/wine/netapi32.dll.so
%{_libdir}/wine/newdev.dll.so
@ -998,6 +1007,7 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/sxs.dll.so
%{_libdir}/wine/t2embed.dll.so
%{_libdir}/wine/tapi32.dll.so
%{_libdir}/wine/taskkill.exe.so
%{_libdir}/wine/traffic.dll.so
%{_libdir}/wine/unicows.dll.so
%{_libdir}/wine/unlodctr.exe.so
@ -1053,8 +1063,9 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/xinput1_3.dll.so
%{_libdir}/wine/xinput9_1_0.dll.so
%{_libdir}/wine/xmllite.dll.so
%ifnarch x86_64
# 16 bit and other non 64bit stuff
%ifnarch x86_64
%{_libdir}/wine/winevdm.exe.so
%{_libdir}/wine/ifsmgr.vxd.so
%{_libdir}/wine/mmdevldr.vxd.so
@ -1068,7 +1079,6 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/vtdapi.vxd.so
%{_libdir}/wine/vwin32.vxd.so
%{_libdir}/wine/w32skrnl.dll.so
%{_libdir}/wine/avifile.dll16.so
%{_libdir}/wine/comm.drv16.so
%{_libdir}/wine/commdlg.dll16.so
@ -1121,14 +1131,6 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/wow32.dll.so
%endif
%files wow
%defattr(-,root,root,-)
%ifarch %{ix86}
%{_bindir}/wine
%endif
%{_bindir}/wineserver
%{_libdir}/wine/wineboot.exe.so
%files common
%defattr(-,root,root,-)
%{_bindir}/notepad
@ -1301,6 +1303,14 @@ update-desktop-database &>/dev/null || :
%endif
%changelog
* Sun Oct 03 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.3.4-1
- version upgrade
* Wed Sep 29 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.3.3-2
- winepulse upgrade (0.39)
* Mon Sep 20 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.3.3-1
- version upgrade

Loading…
Cancel
Save