- version upgrade
- rebase winepulse configure patch
- add gstreamer BR for new gstreamer support
- add libtiff BR for new tiff support
f38
Andreas Bierfert 14 years ago
parent 1b96525afc
commit 410d7e8eab

1
.gitignore vendored

@ -1 +1,2 @@
/wine-1.3.5.tar.bz2
/wine-1.3.6.tar.bz2

@ -1 +1 @@
c1d9a9040637296ea6cfc7f11cf6cee3 wine-1.3.5.tar.bz2
3db0941aafa23e4fd340326a104e2762 wine-1.3.6.tar.bz2

@ -1,6 +1,6 @@
%define no64bit 0
Name: wine
Version: 1.3.5
Version: 1.3.6
Release: 1%{?dist}
Summary: A Windows 16/32/64 bit emulator
@ -110,6 +110,8 @@ BuildRequires: gsm-devel
BuildRequires: libv4l-devel
BuildRequires: fontpackages-devel
BuildRequires: ImageMagick-devel
BuildRequires: gstreamer-devel
BuildRequires: libtiff-devel
%if 0%{?fedora} >= 10 || 0%{?rhel} >= 6
BuildRequires: openal-soft-devel
@ -425,7 +427,7 @@ This package adds an openal driver for wine.
%patch1
%patch100
%patch200
%patch400 -p1
%patch400
%patch401 -p1
%patch402 -p1
#%patch1000
@ -444,6 +446,7 @@ export CFLAGS="$RPM_OPT_FLAGS -Wno-error"
%endif
--enable-maintainer-mode \
--disable-tests
%{__make} TARGETFLAGS="" %{?_smp_mflags}
%install
@ -1027,6 +1030,7 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/windowscodecs.dll.so
%{_libdir}/wine/wineaudioio.drv.so
%{_libdir}/wine/winecoreaudio.drv.so
%{_libdir}/wine/winegstreamer.dll.so
%{_libdir}/wine/winejoystick.drv.so
%{_libdir}/wine/winemapi.dll.so
%{_libdir}/wine/winex11.drv.so
@ -1042,6 +1046,7 @@ update-desktop-database &>/dev/null || :
%{_libdir}/wine/winscard.dll.so
%{_libdir}/wine/wintab32.dll.so
%{_libdir}/wine/wintrust.dll.so
%{_libdir}/wine/wlanapi.dll.so
%{_libdir}/wine/wnaspi32.dll.so
%{_libdir}/wine/ws2_32.dll.so
%{_libdir}/wine/wsock32.dll.so
@ -1303,6 +1308,13 @@ update-desktop-database &>/dev/null || :
%endif
%changelog
* Fri Oct 29 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.3.6-1
- version upgrade
- rebase winepulse configure patch
- add gstreamer BR for new gstreamer support
- add libtiff BR for new tiff support
* Mon Oct 18 2010 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- 1.3.5-1
- version upgrade

@ -1,8 +1,6 @@
diff --git a/configure.ac b/configure.ac
index 341ba181..998e063 100644
--- a/configure.ac
+++ b/configure.ac
@@ -78,6 +78,7 @@ AC_ARG_WITH(png, AS_HELP_STRING([--without-png],[do not use PNG]),
--- configure.ac.orig 2010-10-29 21:01:38.000000000 +0200
+++ configure.ac 2010-10-29 21:05:28.000000000 +0200
@@ -79,6 +79,7 @@
[if test "x$withval" = "xno"; then ac_cv_header_png_h=no; fi])
AC_ARG_WITH(pthread, AS_HELP_STRING([--without-pthread],[do not use the pthread library]),
[if test "x$withval" = "xno"; then ac_cv_header_pthread_h=no; fi])
@ -10,9 +8,9 @@ index 341ba181..998e063 100644
AC_ARG_WITH(sane, AS_HELP_STRING([--without-sane],[do not use SANE (scanner support)]))
AC_ARG_WITH(tiff, AS_HELP_STRING([--without-tiff],[do not use TIFF]),
[if test "x$withval" = "xno"; then ac_cv_header_tiffio_h=no; fi])
@@ -1402,6 +1403,30 @@ then
CFLAGS="$save_CFLAGS"
fi
@@ -1431,6 +1432,30 @@
[gstreamer-0.10 ${notice_platform}development files not found, gstreamer support disabled])
test "x$ac_cv_lib_gstapp_0_10_gst_app_buffer_new" = xyes || enable_winegstreamer=${enable_winegstreamer:-no}
+dnl **** Check for PulseAudio ****
+AC_SUBST(PULSELIBS,"")
@ -41,7 +39,7 @@ index 341ba181..998e063 100644
dnl **** Check for ALSA 1.x ****
AC_SUBST(ALSALIBS,"")
if test "$ac_cv_header_sys_asoundlib_h" = "yes" -o "$ac_cv_header_alsa_asoundlib_h" = "yes"
@@ -1580,7 +1605,7 @@ dnl **** Check for libodbc ****
@@ -1609,7 +1634,7 @@
WINE_CHECK_SONAME(odbc,SQLConnect,,[AC_DEFINE_UNQUOTED(SONAME_LIBODBC,["libodbc.$LIBEXT"])])
dnl **** Check for any sound system ****
@ -50,7 +48,7 @@ index 341ba181..998e063 100644
"$ac_cv_header_sys_soundcard_h" != "yes" -a \
"$ac_cv_header_machine_soundcard_h" != "yes" -a \
"$ac_cv_header_soundcard_h" != "yes" -a \
@@ -2724,6 +2749,7 @@ WINE_CONFIG_DLL(winenas.drv)
@@ -2760,6 +2785,7 @@
WINE_CONFIG_DLL(wineoss.drv)
WINE_CONFIG_DLL(wineps.drv)
WINE_CONFIG_DLL(wineps16.drv16,enable_win16)

Loading…
Cancel
Save