diff --git a/.cvsignore b/.cvsignore
index b388d46..1ce67a0 100644
--- a/.cvsignore
+++ b/.cvsignore
@@ -1 +1 @@
-waf-1.5.2.tar.bz2
+waf-1.5.2.stripped.tar.bz2
diff --git a/import.log b/import.log
index ad8bc63..2c3d890 100644
--- a/import.log
+++ b/import.log
@@ -1,3 +1,4 @@
waf-1_4_3-1_fc9:HEAD:waf-1.4.3-1.fc9.src.rpm:1214694119
waf-1_4_4-1_fc9:HEAD:waf-1.4.4-1.fc9.src.rpm:1220215604
waf-1_5_2-1_fc10:HEAD:waf-1.5.2-1.fc10.src.rpm:1232126058
+waf-1_5_2-2_fc10:HEAD:waf-1.5.2-2.fc10.src.rpm:1232128440
diff --git a/sources b/sources
index ef3174b..80c160c 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-7b84bb61b447ec13021b883cf86e4770 waf-1.5.2.tar.bz2
+f389fe7cb4ac72f4bbc2248aa130dbb6 waf-1.5.2.stripped.tar.bz2
diff --git a/waf-1.5.2-book.patch b/waf-1.5.2-book.patch
deleted file mode 100644
index 6d3ffdd..0000000
--- a/waf-1.5.2-book.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Index: doc/book/c_builds.xml
-===================================================================
---- doc/book/c_builds.xml (revision 5461)
-+++ doc/book/c_builds.xml (revision 5462)
-@@ -67,20 +67,20 @@
- main.source = 'main.c'
- main.target = 'test_c_program'
- main.includes = '.'
-- main.uselib_local = 'teststaticlib'
-+ main.uselib_local = 'teststaticlib'
-
-
-
-
- A static library
-
--
-+
- Include paths to export for use with uselib_local (include paths are not added automatically). These folders are taken relatively to the current target.
-
-
- A program using the static library declared previously
-
--
-+
- A list of references to existing libraries declared in the project (either a python list or a string containing the names space-separated)
-
-
diff --git a/waf-1.5.2-stylesheet.patch b/waf-1.5.2-stylesheet.patch
deleted file mode 100644
index ccd475c..0000000
--- a/waf-1.5.2-stylesheet.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -up waf-1.5.2/doc/book/wscript.orig waf-1.5.2/doc/book/wscript
---- waf-1.5.2/doc/book/wscript.orig 2008-12-22 00:30:46.000000000 +0100
-+++ waf-1.5.2/doc/book/wscript 2009-01-16 17:35:02.000000000 +0100
-@@ -87,8 +87,8 @@ def build(bld):
- obj.source = 'waf.xml'
-
- obj.type = 'html'
-- obj.stylesheet='/usr/share/xml/docbook/stylesheet/nwalsh/current/html/chunk.xsl'
-- #obj.stylesheet='/usr/share/sgml/docbook/xsl-stylesheets/html/chunk.xsl'
-+ #obj.stylesheet='/usr/share/xml/docbook/stylesheet/nwalsh/current/html/chunk.xsl'
-+ obj.stylesheet='/usr/share/sgml/docbook/xsl-stylesheets/html/chunk.xsl'
- #obj.stylesheet = '/home/tnagy/docbook-xsl-snapshot/html/chunk.xsl'
-
- #obj.type = 'pdf'
diff --git a/waf.spec b/waf.spec
index 4faa540..b767cc3 100644
--- a/waf.spec
+++ b/waf.spec
@@ -1,23 +1,21 @@
Name: waf
Version: 1.5.2
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: A Python-based build system
Group: Development/Tools
# The entire source code is BSD apart from pproc.py (taken from Python 2.5)
License: BSD and Python
URL: http://code.google.com/p/waf/
-Source: http://waf.googlecode.com/files/waf-%{version}.tar.bz2
+# Original tarfile can be found at
+# http://waf.googlecode.com/files/waf-%{version}.tar.bz2
+# We remove doc/book, as this is under CC-BY-NC-ND, which is not
+# allowed in Fedora.
+Source: waf-%{version}.stripped.tar.bz2
# use _datadir instead of /usr/lib
Patch0: waf-1.5.2-libdir.patch
-Patch1: waf-1.5.2-stylesheet.patch
-# r5462 from trunk
-Patch2: waf-1.5.2-book.patch
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
BuildArch: noarch
BuildRequires: python-devel
-# for building the documentation
-BuildRequires: /usr/bin/xsltproc
-BuildRequires: docbook-style-xsl
# Seems like automatic ABI dependency is not detected since the files are
# going to a non-standard location
Requires: python-abi %(%{__python} -c "import sys ; print \"=\", sys.version[:3]")
@@ -38,16 +36,12 @@ Autotools, Scons, CMake or Ant.
%prep
%setup -q
%patch0 -p1 -b .libdir
-%patch1 -p1 -b .stylesheet
-%patch2 -p0 -b .book
%build
./waf-light configure --prefix=%{_prefix}
./waf-light --make-waf --strip
-(cd doc/book ; ../../waf configure && ../../waf)
-
%install
%{__rm} -rf %{buildroot}
@@ -70,15 +64,11 @@ find demos utils -type f -exec %{__chmod} 0644 {} \;
# remove zero-length files
%{__rm} demos/gnome/src/hello.h
%{__rm} demos/simple_scenarios/local_tool/uh.coin
-%{__rm} doc/book/build/default/waf.html
# bash completion
%{__install} -D -p -m 0644 utils/waf-completion.bash \
%{buildroot}%{_sysconfdir}/bash_completion.d//waf-completion.bash
-# basically giving it a better name
-%{__mv} doc/book/build/default doc/html
-
%clean
%{__rm} -rf %{buildroot}
@@ -87,13 +77,16 @@ find demos utils -type f -exec %{__chmod} 0644 {} \;
%files
%defattr(-,root,root,-)
%doc README TODO ChangeLog demos utils
-%doc doc/html
%{_bindir}/waf
%{_datadir}/waf
%{_sysconfdir}/bash_completion.d
%changelog
+* Fri Jan 16 2009 Thomas Moschny - 1.5.2-2
+- Remove the documentation again, as it is under CC-BY-NC-ND. Also
+ remove it from the tarfile.
+
* Fri Jan 16 2009 Thomas Moschny - 1.5.2-1
- Update to 1.5.2.
- Generate html documentation (though without highlighting).