You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
vmaf/0002-Unbundle-pugixml.patch

59 lines
1.6 KiB

From 79d6313628216f9c5d6e758d8d113c97df152ad9 Mon Sep 17 00:00:00 2001
From: Leigh Scott <leigh123linux@gmail.com>
Date: Wed, 4 Mar 2020 21:49:48 +0000
Subject: [PATCH 2/4] Unbundle pugixml
---
libvmaf/src/meson.build | 7 +++++--
libvmaf/src/vmaf.cpp | 2 +-
2 files changed, 6 insertions(+), 3 deletions(-)
diff --git a/libvmaf/src/meson.build b/libvmaf/src/meson.build
index 74047d2..9f723d8 100644
--- a/libvmaf/src/meson.build
+++ b/libvmaf/src/meson.build
@@ -31,6 +31,7 @@ ptools_sources = [
]
thread_lib = dependency('threads')
+pugixml_lib = dependency('pugixml')
math_lib = cc.find_library('m', required : false)
libptools = shared_library(
@@ -115,7 +116,6 @@ libvmaf_feature_static_lib = static_library(
)
vmaf_sources = [
- third_party_dir + 'pugixml/pugixml.cpp',
src_dir + 'mem.c',
src_dir + 'combo.c',
src_dir + 'cpu_info.c',
@@ -131,7 +131,10 @@ libvmaf = both_libraries(
include_directories : vmaf_include,
c_args : vmaf_cflags_common,
cpp_args : vmaf_cflags_common,
- dependencies : thread_lib,
+ dependencies : [
+ thread_lib,
+ pugixml_lib,
+ ],
objects : [
convolution_and_psnr_avx_static_lib.extract_all_objects(),
libptools.extract_all_objects(),
diff --git a/libvmaf/src/vmaf.cpp b/libvmaf/src/vmaf.cpp
index 64bcf5f..c9cab57 100644
--- a/libvmaf/src/vmaf.cpp
+++ b/libvmaf/src/vmaf.cpp
@@ -28,7 +28,7 @@
#include "vmaf.h"
#include "combo.h"
-#include "third_party/pugixml/pugixml.hpp"
+#include <pugixml.hpp>
#include "timer.h"
#include "jsonprint.h"
#include "debug.h"
--
2.24.1