You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
36 lines
1.5 KiB
36 lines
1.5 KiB
From 4adfd8064dbaad0e7d48e6668de322213ed621c8 Mon Sep 17 00:00:00 2001
|
|
From: Leigh Scott <leigh123linux@gmail.com>
|
|
Date: Wed, 4 Mar 2020 21:43:41 +0000
|
|
Subject: [PATCH 1/4] Use better FLAGS for ptools
|
|
|
|
---
|
|
libvmaf/src/third_party/ptools/Makefile.Linux | 5 +++--
|
|
1 file changed, 3 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/libvmaf/src/third_party/ptools/Makefile.Linux b/libvmaf/src/third_party/ptools/Makefile.Linux
|
|
index 73d8241..99d4e83 100644
|
|
--- a/libvmaf/src/third_party/ptools/Makefile.Linux
|
|
+++ b/libvmaf/src/third_party/ptools/Makefile.Linux
|
|
@@ -10,7 +10,8 @@ CC = g++
|
|
OC = ./opencontainers_1_8_4
|
|
OCINC = $(OC)/include
|
|
|
|
-CFLAGS = -Wall -Wextra -fpic -O -fno-strict-aliasing -DLINUX_ -DOC_NEW_STYLE_INCLUDES -Wno-deprecated -I$(OCINC) -pthread -D_REENTRANT
|
|
+CFLAGS_COMMON = -Wall -Wextra -fpic -O
|
|
+CFLAGS = $(CFLAGS) -fno-strict-aliasing -DLINUX_ -DOC_NEW_STYLE_INCLUDES -Wno-deprecated -I$(OCINC) -pthread -D_REENTRANT
|
|
|
|
## How to build with OCString
|
|
##CFLAGS = -Wall -O4 -DLINUX_ -DOC_USE_OC_STRING -DOC_USE_OC_EXCEPTIONS -DOC_ONLY_NEEDED_STL -DOC_NEW_STYLE_INCLUDES -Wno-deprecated -I$(OCINC)
|
|
@@ -30,7 +31,7 @@ all: midasyeller_ex midastalker_ex midastalker_ex2 httpclient_ex midasserver_ex
|
|
$(CC) $(CFLAGS) -c $<
|
|
|
|
libptools.so : $(COM_OBJS)
|
|
- $(CC) $(CCFLAGS) $(COM_OBJS) -shared -o libptools.so
|
|
+ $(CC) $(CCFLAGS) $(COM_OBJS) $(LDFLAGS) -shared -Wl,-soname,libptools.so.0 -o libptools.so
|
|
|
|
midasserver_ex : $(COM_OBJS) midasserver_ex.o
|
|
$(CC) $(CCFLAGS) $(COM_OBJS) midasserver_ex.o -pthread -o midasserver_ex
|
|
--
|
|
2.24.1
|
|
|