You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
39 lines
961 B
39 lines
961 B
From a6765396684ddd62fe660cb914e495e61a4dcab9 Mon Sep 17 00:00:00 2001
|
|
From: Nicolas Chauvet <kwizart@gmail.com>
|
|
Date: Sat, 7 Apr 2018 13:43:48 +0200
|
|
Subject: [PATCH] Unbundle pugixml
|
|
|
|
---
|
|
wrapper/Makefile | 7 ++-----
|
|
1 file changed, 2 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/wrapper/Makefile b/wrapper/Makefile
|
|
index 868b13f..4a891e1 100644
|
|
--- a/wrapper/Makefile
|
|
+++ b/wrapper/Makefile
|
|
@@ -43,9 +43,9 @@ OBJS = \
|
|
$(OBJDIR)/vmaf.o \
|
|
$(OBJDIR)/darray.o \
|
|
$(OBJDIR)/libvmaf.o \
|
|
- $(OBJDIR)/pugixml.o \
|
|
$(OBJDIR)/blur_array.o \
|
|
- $(OBJDIR)/cpu_info.o
|
|
+ $(OBJDIR)/cpu_info.o \
|
|
+ $(NULL)
|
|
|
|
AVX_OBJS := \
|
|
$(OBJDIR)/convolution_avx.o \
|
|
@@ -158,9 +158,6 @@ $(OBJDIR)/vmaf.o: $(SRCDIR)/vmaf.cpp
|
|
$(OBJDIR)/%.o: $(SRCDIR)/%.c
|
|
$(CC) -c -o $@ $(CFLAGS) $(CPPFLAGS) -I $(FEATURESRCDIR) $<
|
|
|
|
-$(OBJDIR)/%.o: $(SRCDIR)/pugixml/%.cpp
|
|
- $(CXX) -c -o $@ $(CXXFLAGS) $(CPPFLAGS) $<
|
|
-
|
|
$(LIBVMAF): $(OBJS) $(wildcard ../ptools/*.o)
|
|
ar rcs $@ $^
|
|
|
|
--
|
|
2.17.2
|
|
|