You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
39 lines
967 B
39 lines
967 B
From 524c2dea1569cef1aaeb26c2afd9a64e11c06254 Mon Sep 17 00:00:00 2001
|
|
From: Nicolas Chauvet <kwizart@gmail.com>
|
|
Date: Sat, 7 Apr 2018 13:43:48 +0200
|
|
Subject: [PATCH 02/11] Unbundle pugixml
|
|
|
|
---
|
|
wrapper/Makefile | 7 ++-----
|
|
1 file changed, 2 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/wrapper/Makefile b/wrapper/Makefile
|
|
index 6b02083..985a30f 100644
|
|
--- a/wrapper/Makefile
|
|
+++ b/wrapper/Makefile
|
|
@@ -42,9 +42,9 @@ OBJS = \
|
|
$(OBJDIR)/vmaf.o \
|
|
$(OBJDIR)/darray.o \
|
|
$(OBJDIR)/libvmaf.o \
|
|
- $(OBJDIR)/pugixml.o \
|
|
$(OBJDIR)/blur_array.o \
|
|
- $(OBJDIR)/cpu_info.o
|
|
+ $(OBJDIR)/cpu_info.o \
|
|
+ $(NULL)
|
|
|
|
AVX_OBJS := \
|
|
$(OBJDIR)/convolution_avx.o \
|
|
@@ -160,9 +160,6 @@ $(OBJDIR)/vmaf.o: $(SRCDIR)/vmaf.cpp
|
|
$(OBJDIR)/%.o: $(SRCDIR)/%.c
|
|
$(CC) -c -o $@ $(CFLAGS) $(CPPFLAGS) -I $(FEATURESRCDIR) $<
|
|
|
|
-$(OBJDIR)/%.o: $(SRCDIR)/pugixml/%.cpp
|
|
- $(CXX) -c -o $@ $(CXXFLAGS) $(CPPFLAGS) $<
|
|
-
|
|
$(LIBVMAF): $(OBJS) $(wildcard ../ptools/*.o)
|
|
ar rcs $@ $^
|
|
|
|
--
|
|
2.17.1
|
|
|