You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
vmaf/0008-Add-pugixml-LIBS.patch

26 lines
785 B

From b0fbd280173737102f1814e59452545c6d116cb1 Mon Sep 17 00:00:00 2001
From: Nicolas Chauvet <kwizart@gmail.com>
Date: Sat, 7 Apr 2018 14:43:21 +0200
Subject: [PATCH] Add pugixml LIBS
---
wrapper/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/wrapper/Makefile b/wrapper/Makefile
index 2aeaf66..ac6decc 100644
--- a/wrapper/Makefile
+++ b/wrapper/Makefile
@@ -159,7 +159,7 @@ $(OBJDIR)/%.o: $(SRCDIR)/%.c
$(CC) -c -o $@ $(CFLAGS) $(CPPFLAGS) -I $(FEATURESRCDIR) $<
$(LIBVMAF): $(OBJS) $(wildcard ../ptools/*.o)
- $(CC) $(LDFLAGS) $^ -shared -Wl,-soname,libvmaf.so.0 -o $@
+ $(CC) $(LDFLAGS) $^ -shared -Wl,-soname,libvmaf.so.0 -lpugixml -pthread -o $@
vmafossexec: $(OBJDIR)/main.o $(LIBVMAF)
$(CXX) -s -o $@ $(LDFLAGS) $^ -pthread
--
2.17.2