You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
vmaf/0004-Use-better-FLAGS-for-p...

36 lines
1.4 KiB

From 1f85e97f791709405d5b38981d1786727c229bc0 Mon Sep 17 00:00:00 2001
From: Nicolas Chauvet <kwizart@gmail.com>
Date: Sat, 7 Apr 2018 13:54:40 +0200
Subject: [PATCH 04/11] Use better FLAGS for ptools
---
ptools/Makefile.Linux | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/ptools/Makefile.Linux b/ptools/Makefile.Linux
index 73d8241..890141b 100644
--- a/ptools/Makefile.Linux
+++ b/ptools/Makefile.Linux
@@ -10,7 +10,8 @@ CC = g++
OC = ./opencontainers_1_8_4
OCINC = $(OC)/include
-CFLAGS = -Wall -Wextra -fpic -O -fno-strict-aliasing -DLINUX_ -DOC_NEW_STYLE_INCLUDES -Wno-deprecated -I$(OCINC) -pthread -D_REENTRANT
+CFLAGS_COMMON = -Wall -Wextra -fpic -O
+CFLAGS = $(CFLAGS_COMMON) -fno-strict-aliasing -DLINUX_ -DOC_NEW_STYLE_INCLUDES -Wno-deprecated -I$(OCINC) -pthread -D_REENTRANT
## How to build with OCString
##CFLAGS = -Wall -O4 -DLINUX_ -DOC_USE_OC_STRING -DOC_USE_OC_EXCEPTIONS -DOC_ONLY_NEEDED_STL -DOC_NEW_STYLE_INCLUDES -Wno-deprecated -I$(OCINC)
@@ -30,7 +31,7 @@ all: midasyeller_ex midastalker_ex midastalker_ex2 httpclient_ex midasserver_ex
$(CC) $(CFLAGS) -c $<
libptools.so : $(COM_OBJS)
- $(CC) $(CCFLAGS) $(COM_OBJS) -shared -o libptools.so
+ $(CC) $(CCFLAGS) $(COM_OBJS) $(LDFLAGS) -shared -Wl,-soname,libptools.so.0 -o libptools.so
midasserver_ex : $(COM_OBJS) midasserver_ex.o
$(CC) $(CCFLAGS) $(COM_OBJS) midasserver_ex.o -pthread -o midasserver_ex
--
2.17.1