- Prevent the needs to re-run autotools

el8
Nicolas Chauvet 16 years ago
parent 6c914e05c2
commit 2339bbc4d3

@ -9,6 +9,23 @@ diff -up vlc-0.9.3/configure.ac.libv4l2 vlc-0.9.3/configure.ac
CPPFLAGS="${CPPFLAGS_save} ${CPPFLAGS_v4l2}"
AC_CHECK_HEADERS(linux/videodev2.h, [
VLC_ADD_PLUGIN([v4l2])
diff -up vlc-0.9.3/configure.libv4l2 vlc-0.9.3/configure
--- vlc-0.9.3/configure.libv4l2 2008-09-29 15:00:35.000000000 +0200
+++ vlc-0.9.3/configure 2008-09-29 15:00:51.000000000 +0200
@@ -45416,6 +45416,12 @@ _ACEOF
fi
+
+ for element in v4l2; do
+ eval "LDFLAGS_${element}="'"'"-lv4l2 "'$'"{LDFLAGS_${element}} "'"'
+ am_modules_with_ldflags="${am_modules_with_ldflags} ${element}"
+ done
+
CPPFLAGS="${CPPFLAGS_save} ${CPPFLAGS_v4l2}"
for ac_header in linux/videodev2.h
diff -up vlc-0.9.3/modules/access/v4l2/v4l2.c.libv4l2 vlc-0.9.3/modules/access/v4l2/v4l2.c
--- vlc-0.9.3/modules/access/v4l2/v4l2.c.libv4l2 2008-09-18 23:03:35.000000000 +0200
+++ vlc-0.9.3/modules/access/v4l2/v4l2.c 2008-09-27 19:45:58.000000000 +0200

@ -20,7 +20,7 @@ Version: 1.0.0
%else
Version: 0.9.3
%define _version %{version}
%define release_tag 2
%define release_tag 3
%endif
Release: %{release_tag}%{?dist}
License: GPLv2+
@ -91,7 +91,9 @@ BuildRequires: libtar-devel
BuildRequires: libtheora-devel
BuildRequires: libtiff-devel
BuildRequires: libupnp-devel
%if 0%{?fedora} > 8
BuildRequires: libv4l-devel
%endif
BuildRequires: libvorbis-devel
BuildRequires: libxml2-devel
BuildRequires: lirc-devel
@ -248,6 +250,8 @@ VLC plugins for libdc1394
%patch1 -p1 -b .pulse_default
%if 0%{?fedora} > 8
%patch2 -p1 -b .libv4l2
touch -r configure.ac.libv4l2 configure.ac
touch -r configure.libv4l2 configure
%endif
@ -505,6 +509,9 @@ fi || :
%changelog
* Mon Sep 29 2008 kwizart < kwizart at gmail.com > - 0.9.3-3
- Prevent the needs to re-run autotools
* Mon Sep 29 2008 kwizart < kwizart at gmail.com > - 0.9.3-2
- Add libv4l2 patch from Hans de Goede

Loading…
Cancel
Save