import vapoursynth-51-1.el8

i8ce changed/i8ce/vapoursynth-51-1.el8
Sergey Cherevko 10 months ago
commit 01255d4faa
Signed by: scherevko
GPG Key ID: D87CBBC16D2E4A72

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/vapoursynth-R51.tar.gz

@ -0,0 +1 @@
2d80e8032b7d0ef7d3996536350a1bc6b893210b SOURCES/vapoursynth-R51.tar.gz

@ -0,0 +1,55 @@
diff -Naur vapoursynth-R51.old/src/core/exprfilter.cpp vapoursynth-R51/src/core/exprfilter.cpp
--- vapoursynth-R51.old/src/core/exprfilter.cpp 2021-03-23 14:34:50.273555518 +0100
+++ vapoursynth-R51/src/core/exprfilter.cpp 2021-03-23 14:36:17.148054372 +0100
@@ -32,6 +32,7 @@
#include <unordered_map>
#include <unordered_set>
#include <vector>
+#include <limits>
#include "VapourSynth.h"
#include "VSHelper.h"
#include "cpufeatures.h"
diff -Naur vapoursynth-R51.old/src/core/genericfilters.cpp vapoursynth-R51/src/core/genericfilters.cpp
--- vapoursynth-R51.old/src/core/genericfilters.cpp 2021-03-23 14:34:50.273555518 +0100
+++ vapoursynth-R51/src/core/genericfilters.cpp 2021-03-23 14:36:17.149054389 +0100
@@ -28,6 +28,7 @@
#include <array>
#include <memory>
#include <vector>
+#include <limits>
#include <VapourSynth.h>
#include <VSHelper.h>
#include "cpufeatures.h"
diff -Naur vapoursynth-R51.old/src/core/kernel/generic.cpp vapoursynth-R51/src/core/kernel/generic.cpp
--- vapoursynth-R51.old/src/core/kernel/generic.cpp 2021-03-23 14:34:50.273555518 +0100
+++ vapoursynth-R51/src/core/kernel/generic.cpp 2021-03-23 14:36:17.149054389 +0100
@@ -22,6 +22,7 @@
#include <array>
#include <cmath>
#include <cstdint>
+#include <limits>
#include <type_traits>
#include "generic.h"
diff -Naur vapoursynth-R51.old/src/filters/misc/miscfilters.cpp vapoursynth-R51/src/filters/misc/miscfilters.cpp
--- vapoursynth-R51.old/src/filters/misc/miscfilters.cpp 2021-03-23 14:34:50.276555570 +0100
+++ vapoursynth-R51/src/filters/misc/miscfilters.cpp 2021-03-23 14:36:17.150054407 +0100
@@ -26,6 +26,7 @@
#include <memory>
#include <stdexcept>
#include <vector>
+#include <limits>
#include <VapourSynth.h>
#include <VSHelper.h>
#include "../src/core/filtersharedcpp.h"
diff -Naur vapoursynth-R51.old/src/filters/removegrain/clense.cpp vapoursynth-R51/src/filters/removegrain/clense.cpp
--- vapoursynth-R51.old/src/filters/removegrain/clense.cpp 2021-03-23 14:34:50.276555570 +0100
+++ vapoursynth-R51/src/filters/removegrain/clense.cpp 2021-03-23 14:36:17.150054407 +0100
@@ -26,6 +26,7 @@
*/
#include "shared.h"
+#include <limits>
#define CLENSE_RETERROR(x) do { vsapi->setError(out, (x)); vsapi->freeNode(d.cnode); vsapi->freeNode(d.pnode); vsapi->freeNode(d.nnode); return; } while (0)
#define CLAMP(value, lower, upper) do { if (value < lower) value = lower; else if (value > upper) value = upper; } while(0)

@ -0,0 +1,12 @@
diff -Naur vapoursynth-R51.old/Makefile.am vapoursynth-R51/Makefile.am
--- vapoursynth-R51.old/Makefile.am 2021-03-23 14:27:12.519657875 +0100
+++ vapoursynth-R51/Makefile.am 2021-03-23 14:27:19.806783602 +0100
@@ -79,7 +79,7 @@
pkgconfig_DATA += pc/vapoursynth.pc
-libvapoursynth_la_LDFLAGS = -no-undefined -avoid-version
+libvapoursynth_la_LDFLAGS = -no-undefined -version-info $(PACKAGE_VERSION)
libvapoursynth_la_CPPFLAGS = $(ZIMG_CFLAGS) -DVS_PATH_PLUGINDIR='"$(PLUGINDIR)"'
libvapoursynth_la_LIBADD = $(ZIMG_LIBS) $(DLOPENLIB) libexprfilter.la

@ -0,0 +1,202 @@
#global _with_tests 1
#global _with_subtitles 1
#global _with_ImageMagick 1
Name: vapoursynth
Version: 51
Release: 1%{?dist}
Summary: Video processing framework with simplicity in mind
License: LGPLv2
URL: http://www.vapoursynth.com
Source0: https://github.com/%{name}/%{name}/archive/R%{version}/%{name}-R%{version}.tar.gz
Patch0: %{name}-version-info.patch
Patch1: %{name}-gcc11.patch
BuildRequires: make
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: gcc-c++
BuildRequires: libtool
BuildRequires: nasm
BuildRequires: pkgconfig(python3)
BuildRequires: pkgconfig(tesseract)
BuildRequires: pkgconfig(zimg)
BuildRequires: python3
BuildRequires: python3-Cython
BuildRequires: python3-setuptools
%{?_with_tests:
BuildRequires: %{name}-devel
BuildRequires: python3dist(pytest)
}
%{?_with_ImageMagick:
BuildRequires: pkgconfig(Magick++) >= 7.0
}
%{?_with_subtitles:
BuildRequires: pkgconfig(libass)
BuildRequires: pkgconfig(libavcodec)
BuildRequires: pkgconfig(libavformat)
BuildRequires: pkgconfig(libavutil)
}
%description
VapourSynth is an application for video manipulation. Or a plugin. Or a library.
Its hard to tell because it has a core library written in C++ and a Python
module to allow video scripts to be created.
%package libs
Summary: VapourSynth's core library with a C++ API
Obsoletes: lib%{name} < %{version}-%{release}
Provides: lib%{name} == %{version}-%{release}
%description libs
VapourSynth's core library with a C++ API.
%package -n python3-%{name}
Summary: Python interface for VapourSynth
%description -n python3-%{name}
Python interface for VapourSynth/VSSCript.
%package devel
Summary: Development files for %{name}
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
%description devel
Development files for %{name}.
%package tools
Summary: Extra tools for VapourSynth
%description tools
This package contains the vspipe tool for interfacing with VapourSynth.
%package plugins
Summary: VapourSynth plugins
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
%description plugins
VapourSynth plugins.
%prep
%autosetup -p1 -n %{name}-R%{version}
%build
autoreconf -vif
%configure \
--disable-static \
--enable-x86-asm \
--enable-core \
--enable-vsscript \
--enable-vspipe \
--enable-python-module \
--enable-eedi3 \
--%{?_with_ImageMagick:enable}%{!?_with_ImageMagick:disable}-imwri \
--enable-miscfilters \
--enable-morpho \
--enable-ocr \
--enable-removegrain \
--%{?_with_subtitles:enable}%{!?_with_subtitles:disable}-subtext \
--enable-vinverse \
--enable-vivtc \
%make_build
%install
%py3_install
%make_install
find %{buildroot} -type f -name "*.la" -delete
# Let RPM pick up docs in the files section
rm -fr %{buildroot}%{_docdir}/%{name}
%ldconfig_scriptlets libs
%ldconfig_scriptlets -n python3-%{name}
%{?_with_tests:
%check
%{python3} -m pytest -v
}
%files libs
%doc ChangeLog
%license COPYING.LESSER
%dir %{_libdir}/%{name}
%{_libdir}/lib%{name}.so.*
%{_libdir}/lib%{name}-script.so.*
%files -n python3-%{name}
%{python3_sitearch}/%{name}.so
%{python3_sitearch}/VapourSynth-*.egg-info
%files devel
%{_includedir}/%{name}/
%{_libdir}/lib%{name}.so
%{_libdir}/lib%{name}-script.so
%{_libdir}/pkgconfig/%{name}.pc
%{_libdir}/pkgconfig/%{name}-script.pc
%files tools
%{_bindir}/vspipe
%files plugins
%{_libdir}/%{name}/lib*.so
%changelog
* Tue Feb 27 2024 Sergey Cherevko <s.cherevko@msvsphere-os.ru> - 51-1
- Rebuilt for MSVSphere 8.9
* Tue Mar 23 2021 Simone Caronni <negativo17@gmail.com> - 51-1
- Update to R51.
- Allow building for other archs beside x86.
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 48-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Sat Oct 17 2020 Jeff Law <law@redhat.com> - 48-10
- Fix missing #include for gcc-11
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 48-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 48-8
- Rebuilt for Python 3.9
* Sat Mar 07 2020 Simone Caronni <negativo17@gmail.com> - 48-7
- Fix broken dependency.
* Sat Feb 29 2020 Simone Caronni <negativo17@gmail.com> - 48-6
- Make it exclusive for i686/x86_64.
- Fix build on RHEL/CentOS 8.
* Tue Feb 25 2020 Artem Polishchuk <ego.cordatus@gmail.com> - 48-5
- Add tests
- Cosmetic spec file improvements
* Thu Feb 20 2020 Simone Caronni <negativo17@gmail.com> - 48-4
- More review fixes.
- Use upstream patch for Python 3.8.
* Fri Feb 07 2020 Simone Caronni <negativo17@gmail.com> - 48-3
- Review fixes.
* Sun Jan 26 2020 Simone Caronni <negativo17@gmail.com> - 48-2
- Move script library into main library package.
- Fix build with Python 3.8.
* Thu Jan 16 2020 Simone Caronni <negativo17@gmail.com> - 48-1
- First build.
Loading…
Cancel
Save