Add #includes needed to compile with gcc-4.3

epel8
Michel Alexandre Salim 17 years ago
parent a63d19293d
commit 220dea135f

@ -0,0 +1,33 @@
--- vamp-plugin-sdk-v1.1b/vamp-sdk/PluginAdapter.h.gcc43 2007-10-19 08:52:33.000000000 -0400
+++ vamp-plugin-sdk-v1.1b/vamp-sdk/PluginAdapter.h 2008-01-31 11:26:58.000000000 -0500
@@ -41,8 +41,6 @@
#include "Plugin.h"
-#include <map>
-
namespace Vamp {
/**
--- vamp-plugin-sdk-v1.1b/vamp-sdk/Plugin.h.gcc43 2007-10-19 08:52:33.000000000 -0400
+++ vamp-plugin-sdk-v1.1b/vamp-sdk/Plugin.h 2008-01-31 11:20:46.000000000 -0500
@@ -40,6 +40,8 @@
#include "PluginBase.h"
#include "RealTime.h"
+#include <cstdlib>
+#include <cstring>
#include <string>
#include <vector>
#include <map>
--- vamp-plugin-sdk-v1.1b/vamp-sdk/PluginHostAdapter.h.gcc43 2007-10-19 08:52:33.000000000 -0400
+++ vamp-plugin-sdk-v1.1b/vamp-sdk/PluginHostAdapter.h 2008-01-31 11:17:59.000000000 -0500
@@ -40,8 +40,6 @@
#include <vamp/vamp.h>
#include <vamp-sdk/Plugin.h>
-#include <vector>
-
namespace Vamp {
/**

@ -1,6 +1,6 @@
Name: vamp-plugin-sdk
Version: 1.1b
Release: 3%{?dist}
Release: 4%{?dist}
Summary: An API for audio analysis and feature extraction plugins
Group: System Environment/Libraries
@ -8,6 +8,7 @@ License: BSD
URL: http://www.vamp-plugins.org/
Source0: http://downloads.sourceforge.net/vamp/vamp-plugin-sdk-%{version}.tar.gz
Patch0: %{name}-1.1b-Makefile.patch
Patch1: %{name}-1.1b-gcc43.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: libsndfile-devel
@ -40,6 +41,7 @@ developing static applications that use %{name}.
%prep
%setup -q -n %{name}-v%{version}
%patch0 -p1 -b .mk
%patch1 -p1 -b .gcc43
%build
@ -96,6 +98,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Thu Jan 31 2008 Michel Salim <michel.sylvan@gmail.com> - 1.1b-4
- Add some #includes, needed due to GCC 4.3's header dependency cleanup
* Mon Jan 28 2008 Michel Salim <michel.sylvan@gmail.com> - 1.1b-3
- Add examples to -devel subpackage
- Fix .pc files

Loading…
Cancel
Save