You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
34 lines
1.0 KiB
34 lines
1.0 KiB
From b1cabcfde670c82aff0ef07c21095d63c29cbf3e Mon Sep 17 00:00:00 2001
|
|
From: Jonathan Dieter <jdieter@lesbg.com>
|
|
Date: Mon, 27 Feb 2017 10:13:01 +0200
|
|
Subject: [PATCH v4 2/2] usbip: Fix implicit fallthrough warning
|
|
|
|
GCC 7 now warns when switch statements fall through implicitly, and with
|
|
-Werror enabled in configure.ac, that makes these tools unbuildable.
|
|
|
|
We fix this by notifying the compiler that this particular case statement
|
|
is meant to fall through.
|
|
|
|
Reviewed-by: Peter Senna Tschudin <peter.senna@gmail.com>
|
|
Signed-off-by: Jonathan Dieter <jdieter@lesbg.com>
|
|
---
|
|
tools/usb/usbip/src/usbip.c | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git a/tools/usb/usbip/src/usbip.c b/tools/usb/usbip/src/usbip.c
|
|
index d7599d9..73d8eee 100644
|
|
--- a/tools/usb/usbip/src/usbip.c
|
|
+++ b/tools/usb/usbip/src/usbip.c
|
|
@@ -176,6 +176,8 @@ int main(int argc, char *argv[])
|
|
break;
|
|
case '?':
|
|
printf("usbip: invalid option\n");
|
|
+ /* Terminate after printing error */
|
|
+ /* FALLTHRU */
|
|
default:
|
|
usbip_usage();
|
|
goto out;
|
|
--
|
|
2.9.3
|
|
|