You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
25 lines
1.0 KiB
25 lines
1.0 KiB
diff -ur trousers-0.3.9.orig/configure trousers-0.3.9/configure
|
|
--- trousers-0.3.9.orig/configure 2012-05-30 11:16:40.000000000 -0400
|
|
+++ trousers-0.3.9/configure 2012-08-30 14:14:18.569347485 -0400
|
|
@@ -13503,7 +13503,7 @@
|
|
|
|
|
|
if test "x${GCC}" = "xyes"; then
|
|
- CFLAGS="$CFLAGS -W -Wall -Werror -Wno-unused-parameter -Wsign-compare"
|
|
+ CFLAGS="$CFLAGS -W -Wall -Wno-unused-parameter -Wsign-compare"
|
|
fi
|
|
|
|
CFLAGS="$CFLAGS -I../include \
|
|
diff -ur trousers-0.3.9.orig/src/tcsd/Makefile.in trousers-0.3.9/src/tcsd/Makefile.in
|
|
--- trousers-0.3.9.orig/src/tcsd/Makefile.in 2012-05-30 11:16:41.000000000 -0400
|
|
+++ trousers-0.3.9/src/tcsd/Makefile.in 2012-08-30 14:14:18.570347484 -0400
|
|
@@ -56,7 +56,7 @@
|
|
${top_builddir}/src/tddl/libtddl.a
|
|
tcsd_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
|
|
--mode=link $(CCLD) $(tcsd_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) \
|
|
- $(LDFLAGS) -o $@
|
|
+ -Wl,-z,relro -Wl,-z,now $(LDFLAGS) -o $@
|
|
DEFAULT_INCLUDES = -I.@am__isrc@
|
|
depcomp = $(SHELL) $(top_srcdir)/depcomp
|
|
am__depfiles_maybe = depfiles
|