diff --git a/.gitignore b/.gitignore
index 7508dd8..07d5270 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,5 +2,5 @@ SOURCES/cbindgen-vendor.tar.xz
SOURCES/nspr-4.35.0-1.el8_1.src.rpm
SOURCES/nss-3.90.0-2.el8_1.src.rpm
SOURCES/nss-3.90.0-3.el9_0.src.rpm
-SOURCES/thunderbird-115.5.0.processed-source.tar.xz
-SOURCES/thunderbird-langpacks-115.5.0-20231121.tar.xz
+SOURCES/thunderbird-115.6.0.processed-source.tar.xz
+SOURCES/thunderbird-langpacks-115.6.0-20231218.tar.xz
diff --git a/.thunderbird.metadata b/.thunderbird.metadata
index 2ff9781..2ad3c61 100644
--- a/.thunderbird.metadata
+++ b/.thunderbird.metadata
@@ -2,5 +2,5 @@ b963b16f6879c5dbe6e33a3a3da058b494453922 SOURCES/cbindgen-vendor.tar.xz
d744f92e874688cc4b5376477dfdd639a97a6cd4 SOURCES/nspr-4.35.0-1.el8_1.src.rpm
39d1004f8948186cdaa33bbb90423f6f994bdf6c SOURCES/nss-3.90.0-2.el8_1.src.rpm
df0dd588680f6ade6728a1fd3ff2d71e7a46255d SOURCES/nss-3.90.0-3.el9_0.src.rpm
-5a7ac4a9bd48e160ad1fcac18f4bb2660f5672e1 SOURCES/thunderbird-115.5.0.processed-source.tar.xz
-659e4bde9e34477277c3a7e6d09457cbe9340b44 SOURCES/thunderbird-langpacks-115.5.0-20231121.tar.xz
+9bae1ff495719abed7db2d12735431aad655e436 SOURCES/thunderbird-115.6.0.processed-source.tar.xz
+42ee128db6384decdc7980c22e2df8792868ca7d SOURCES/thunderbird-langpacks-115.6.0-20231218.tar.xz
diff --git a/SPECS/thunderbird.spec b/SPECS/thunderbird.spec
index 109f304..eae186f 100644
--- a/SPECS/thunderbird.spec
+++ b/SPECS/thunderbird.spec
@@ -23,7 +23,7 @@ function dist_to_rhel_minor(str, start)
end
match = string.match(str, ".el8")
if match then
- return 9
+ return 10
end
match = string.match(str, ".module%+el9.%d+")
if match then
@@ -35,7 +35,7 @@ function dist_to_rhel_minor(str, start)
end
match = string.match(str, ".el9")
if match then
- return 3
+ return 4
end
return -1
end}
@@ -134,7 +134,7 @@ end}
Summary: Mozilla Thunderbird mail/newsgroup client
Name: thunderbird
-Version: 115.5.0
+Version: 115.6.0
Release: 1%{?dist}
URL: http://www.mozilla.org/projects/thunderbird/
License: MPLv1.1 or GPLv2+ or LGPLv2+
@@ -165,7 +165,7 @@ ExcludeArch: aarch64 s390 ppc ppc64
#Source0: https://archive.mozilla.org/pub/thunderbird/releases/%%{version}%%{?pre_version}/source/thunderbird-%%{version}%%{?pre_version}.processed-source.tar.xz
Source0: thunderbird-%{version}%{?pre_version}%{?buildnum}.processed-source.tar.xz
%if %{with langpacks}
-Source1: thunderbird-langpacks-%{version}-20231121.tar.xz
+Source1: thunderbird-langpacks-%{version}-20231218.tar.xz
%endif
Source2: cbindgen-vendor.tar.xz
Source3: process-official-tarball
@@ -293,7 +293,7 @@ BuildRequires: rust >= %{rust_version}
%if 0%{?rhel} == 9
BuildRequires: cargo
-BuildRequires: clang clang-libs llvm
+BuildRequires: clang clang-libs llvm llvm-devel
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: python3-devel
@@ -1020,8 +1020,8 @@ echo "ac_add_options --with-google-location-service-api-keyfile=`pwd`/google-loc
echo "ac_add_options --with-google-safebrowsing-api-keyfile=`pwd`/google-api-key" >> .mozconfig
# May result in empty --with-libclang-path= in earlier versions.
-# So far this is needed only for c8s.
-%if 0%{?rhel} == 8 && %{rhel_minor_version} >= 10
+# So far this is needed only for c8s/c9s.
+%if (0%{?rhel} == 8 && %{rhel_minor_version} >= 10) || (0%{?rhel} == 9 && %{rhel_minor_version} >= 4)
# Clang 17 upstream's detection fails, tell it where to look.
echo "ac_add_options --with-libclang-path=`llvm-config --libdir`" >> .mozconfig
%endif
@@ -1419,9 +1419,7 @@ mkdir -p $RPM_BUILD_ROOT%{_datadir}/metainfo
%{__cp} -p comm/mail/branding/%{name}/net.thunderbird.Thunderbird.appdata.xml $RPM_BUILD_ROOT%{_datadir}/metainfo/thunderbird.appdata.xml
sed -i -e 's|thunderbird|' "$RPM_BUILD_ROOT%{_datadir}/metainfo/thunderbird.appdata.xml"
-#===============================================================================
-
-%clean
+# Clean the created bundled rpms.
rm -rf %{_srcrpmdir}/libffi*.src.rpm
find %{_rpmdir} -name "libffi*.rpm" -delete
rm -rf %{_srcrpmdir}/openssl*.src.rpm
@@ -1431,6 +1429,8 @@ find %{_rpmdir} -name "nss*.rpm" -delete
rm -rf %{_srcrpmdir}/nspr*.src.rpm
find %{_rpmdir} -name "nspr*.rpm" -delete
+#===============================================================================
+
%post
update-desktop-database &> /dev/null || :
touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
@@ -1514,6 +1514,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#===============================================================================
%changelog
+* Mon Dec 18 2023 Eike Rathke - 115.6.0-1
+- Update to 115.6.0 build2
+
* Tue Nov 21 2023 Eike Rathke - 115.5.0-1
- Update to 115.5.0 build1