You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
43 lines
1.7 KiB
43 lines
1.7 KiB
From 9c1b72de44e68ad80be7c0b98df110e7b127072d Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
|
Date: Sun, 19 Aug 2018 19:11:30 +0200
|
|
Subject: [PATCH] meson: rename -Ddebug to -Ddebug-extra
|
|
|
|
Meson added -Doptimization and -Ddebug options, which obviously causes
|
|
a conflict with our -Ddebug options. Let's rename it.
|
|
|
|
Fixes #9883.
|
|
|
|
Cherry-picked from: 8f6b442a78d0b485f044742ad90b2e8271b4e68e
|
|
---
|
|
meson.build | 2 +-
|
|
meson_options.txt | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index f308db2631..ebc55872c9 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -769,7 +769,7 @@ substs.set('DEBUGTTY', get_option('debug-tty'))
|
|
|
|
enable_debug_hashmap = false
|
|
enable_debug_mmap_cache = false
|
|
-foreach name : get_option('debug')
|
|
+foreach name : get_option('debug-extra')
|
|
if name == 'hashmap'
|
|
enable_debug_hashmap = true
|
|
elif name == 'mmap-cache'
|
|
diff --git a/meson_options.txt b/meson_options.txt
|
|
index ab2a658713..5716f45ccf 100644
|
|
--- a/meson_options.txt
|
|
+++ b/meson_options.txt
|
|
@@ -46,7 +46,7 @@ option('debug-shell', type : 'string', value : '/bin/sh',
|
|
description : 'path to debug shell binary')
|
|
option('debug-tty', type : 'string', value : '/dev/tty9',
|
|
description : 'specify the tty device for debug shell')
|
|
-option('debug', type : 'array', choices : ['hashmap', 'mmap-cache'], value : [],
|
|
+option('debug-extra', type : 'array', choices : ['hashmap', 'mmap-cache'], value : [],
|
|
description : 'enable extra debugging')
|
|
option('memory-accounting-default', type : 'boolean',
|
|
description : 'enable MemoryAccounting= by default')
|