You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
82 lines
3.5 KiB
82 lines
3.5 KiB
From 2eca34cfa911fa7c1aafef5d60b7a2e752ae5b3b Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
|
Date: Fri, 10 Aug 2018 16:50:07 +0200
|
|
Subject: [PATCH] meson: use .source_root() in more places
|
|
|
|
In the main meson.build file, .source_root() and .current_source_dir() are
|
|
equivalent, but it seems more appropriate to use .source_root() when we are appending
|
|
a path which is by design relative to repo root.
|
|
|
|
(cherry picked from commit 243e5cecc3a211519544ccba01c44edc827ac517)
|
|
|
|
Resolves: #1696224
|
|
---
|
|
meson.build | 16 ++++++++--------
|
|
1 file changed, 8 insertions(+), 8 deletions(-)
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index f623bcf37d..fe161e5ec5 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -1453,7 +1453,7 @@ foreach tuple : [['myhostname', 'ENABLE_NSS_MYHOSTNAME'],
|
|
module = tuple[0]
|
|
|
|
sym = 'src/nss-@0@/nss-@0@.sym'.format(module)
|
|
- version_script_arg = join_paths(meson.current_source_dir(), sym)
|
|
+ version_script_arg = join_paths(meson.source_root(), sym)
|
|
|
|
nss = shared_library(
|
|
'nss_' + module,
|
|
@@ -1704,7 +1704,7 @@ if conf.get('ENABLE_LOGIND') == 1
|
|
public_programs += [exe]
|
|
|
|
if conf.get('HAVE_PAM') == 1
|
|
- version_script_arg = join_paths(meson.current_source_dir(), pam_systemd_sym)
|
|
+ version_script_arg = join_paths(meson.source_root(), pam_systemd_sym)
|
|
pam_systemd = shared_library(
|
|
'pam_systemd',
|
|
pam_systemd_c,
|
|
@@ -2816,7 +2816,7 @@ endforeach
|
|
if git.found()
|
|
all_files = run_command(
|
|
git,
|
|
- ['--git-dir=@0@/.git'.format(meson.current_source_dir()),
|
|
+ ['--git-dir=@0@/.git'.format(meson.source_root()),
|
|
'ls-files',
|
|
':/*.[ch]'])
|
|
all_files = files(all_files.stdout().split())
|
|
@@ -2824,10 +2824,10 @@ if git.found()
|
|
custom_target(
|
|
'tags',
|
|
output : 'tags',
|
|
- command : [env, 'etags', '-o', '@0@/TAGS'.format(meson.current_source_dir())] + all_files)
|
|
+ command : [env, 'etags', '-o', '@0@/TAGS'.format(meson.source_root())] + all_files)
|
|
run_target(
|
|
'ctags',
|
|
- command : [env, 'ctags', '-o', '@0@/tags'.format(meson.current_source_dir())] + all_files)
|
|
+ command : [env, 'ctags', '-o', '@0@/tags'.format(meson.source_root())] + all_files)
|
|
endif
|
|
|
|
if git.found()
|
|
@@ -2840,17 +2840,17 @@ endif
|
|
if git.found()
|
|
git_head = run_command(
|
|
git,
|
|
- ['--git-dir=@0@/.git'.format(meson.current_source_dir()),
|
|
+ ['--git-dir=@0@/.git'.format(meson.source_root()),
|
|
'rev-parse', 'HEAD']).stdout().strip()
|
|
git_head_short = run_command(
|
|
git,
|
|
- ['--git-dir=@0@/.git'.format(meson.current_source_dir()),
|
|
+ ['--git-dir=@0@/.git'.format(meson.source_root()),
|
|
'rev-parse', '--short=7', 'HEAD']).stdout().strip()
|
|
|
|
run_target(
|
|
'git-snapshot',
|
|
command : ['git', 'archive',
|
|
- '-o', '@0@/systemd-@1@.tar.gz'.format(meson.current_source_dir(),
|
|
+ '-o', '@0@/systemd-@1@.tar.gz'.format(meson.source_root(),
|
|
git_head_short),
|
|
'--prefix', 'systemd-@0@/'.format(git_head),
|
|
'HEAD'])
|