You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
39 lines
1.3 KiB
39 lines
1.3 KiB
From b6943446f8ffde53ce059b5e869c22bed8926827 Mon Sep 17 00:00:00 2001
|
|
From: Yu Watanabe <watanabe.yu+github@gmail.com>
|
|
Date: Mon, 25 Jun 2018 22:40:40 +0900
|
|
Subject: [PATCH] meson: check whether gnutls supports TCP fast open
|
|
|
|
Fixes #9403
|
|
|
|
Cherry-picked from: f02582f69fe1e7663a87ba80bd4f90d5d23ee75f
|
|
---
|
|
README | 1 +
|
|
meson.build | 2 +-
|
|
2 files changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/README b/README
|
|
index 2cde08c37e..7d06e04800 100644
|
|
--- a/README
|
|
+++ b/README
|
|
@@ -154,6 +154,7 @@ REQUIREMENTS:
|
|
libmicrohttpd (optional)
|
|
libpython (optional)
|
|
libidn2 or libidn (optional)
|
|
+ gnutls >= 3.1.4 (optional, >= 3.5.3 is necessary to support DNS-over-TLS)
|
|
elfutils >= 158 (optional)
|
|
polkit (optional)
|
|
pkg-config
|
|
diff --git a/meson.build b/meson.build
|
|
index ebc55872c9..d58926c981 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -1148,7 +1148,7 @@ substs.set('DEFAULT_DNSSEC_MODE', default_dnssec)
|
|
|
|
dns_over_tls = get_option('dns-over-tls')
|
|
if dns_over_tls != 'false'
|
|
- have = conf.get('HAVE_GNUTLS') == 1
|
|
+ have = libgnutls != [] and libgnutls.version().version_compare('>=3.5.3')
|
|
if dns_over_tls == 'true' and not have
|
|
error('DNS-over-TLS support was requested, but dependencies are not available')
|
|
endif
|