You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
svt-hevc/svt-hevc-build.patch

35 lines
1.2 KiB

diff -uNdr SVT-HEVC-1.4.3_orig/CMakeLists.txt SVT-HEVC-1.4.3/CMakeLists.txt
--- SVT-HEVC-1.4.3_orig/CMakeLists.txt 2019-12-14 23:28:40.000000000 +0300
+++ SVT-HEVC-1.4.3/CMakeLists.txt 2019-12-30 11:09:01.437899907 +0300
@@ -119,8 +119,7 @@
endif()
endif()
set(release_flags_to_test
- -O2
- -O3)
+ -O2)
set(debug_flags_to_test
-O0)
diff -uNdr SVT-HEVC-1.4.3_orig/gstreamer-plugin/meson.build SVT-HEVC-1.4.3/gstreamer-plugin/meson.build
--- SVT-HEVC-1.4.3_orig/gstreamer-plugin/meson.build 2019-12-14 23:28:40.000000000 +0300
+++ SVT-HEVC-1.4.3/gstreamer-plugin/meson.build 2019-12-30 11:09:01.446899587 +0300
@@ -17,7 +17,6 @@
plugins_install_dir = '@0@/gstreamer-1.0'.format(get_option('libdir'))
# common meson configuration
-svthevcenc_dep = dependency('SvtHevcEnc')
cc = meson.get_compiler('c')
cc_flags = [
@@ -47,7 +46,7 @@
gstSvtHevcEnc = library('gstsvthevcenc',
'gstsvthevcenc.c',
- dependencies: [gstbase_dep, gstpbutils_dep , gstvideo_dep, svthevcenc_dep],
- install: true,
+ dependencies: [gstbase_dep, gstpbutils_dep , gstvideo_dep],
+ install: true, include_directories : include_directories('../Source/API'), link_args : '-lSvtHevcEnc',
install_dir: plugins_install_dir
)