Fix build with GCC 11. Remove gstreamer plugin since it is now in gstreamer1-plugins-bad-freeworld package.
parent
68de037d53
commit
e432195a3c
@ -0,0 +1,27 @@
|
||||
diff -uNdr SVT-HEVC-1.5.0_old/CMakeLists.txt SVT-HEVC-1.5.0_new/CMakeLists.txt
|
||||
--- SVT-HEVC-1.5.0_old/CMakeLists.txt 2020-08-04 00:57:25.000000000 +0300
|
||||
+++ SVT-HEVC-1.5.0_new/CMakeLists.txt 2021-02-07 10:58:15.333859295 +0300
|
||||
@@ -100,11 +100,9 @@
|
||||
-Wformat-security
|
||||
-fPIE
|
||||
-fPIC
|
||||
- -D_FORTIFY_SOURCE=2
|
||||
- /GS
|
||||
- /sdl)
|
||||
+ -D_FORTIFY_SOURCE=2)
|
||||
if(MSVC)
|
||||
- list(APPEND flags_to_test /MP)
|
||||
+ list(APPEND flags_to_test /MP /GS /sdl)
|
||||
else()
|
||||
option(NATIVE "Build for native performance (march=native)")
|
||||
list(INSERT flags_to_test 0 -Wall)
|
||||
@@ -119,8 +117,7 @@
|
||||
endif()
|
||||
endif()
|
||||
set(release_flags_to_test
|
||||
- -O2
|
||||
- -O3)
|
||||
+ -O2)
|
||||
set(debug_flags_to_test
|
||||
-O0)
|
||||
|
@ -1,34 +0,0 @@
|
||||
diff -uNdr SVT-HEVC-1.4.3_orig/CMakeLists.txt SVT-HEVC-1.4.3/CMakeLists.txt
|
||||
--- SVT-HEVC-1.4.3_orig/CMakeLists.txt 2019-12-14 23:28:40.000000000 +0300
|
||||
+++ SVT-HEVC-1.4.3/CMakeLists.txt 2019-12-30 11:09:01.437899907 +0300
|
||||
@@ -119,8 +119,7 @@
|
||||
endif()
|
||||
endif()
|
||||
set(release_flags_to_test
|
||||
- -O2
|
||||
- -O3)
|
||||
+ -O2)
|
||||
set(debug_flags_to_test
|
||||
-O0)
|
||||
|
||||
diff -uNdr SVT-HEVC-1.4.3_orig/gstreamer-plugin/meson.build SVT-HEVC-1.4.3/gstreamer-plugin/meson.build
|
||||
--- SVT-HEVC-1.4.3_orig/gstreamer-plugin/meson.build 2019-12-14 23:28:40.000000000 +0300
|
||||
+++ SVT-HEVC-1.4.3/gstreamer-plugin/meson.build 2019-12-30 11:09:01.446899587 +0300
|
||||
@@ -17,7 +17,6 @@
|
||||
plugins_install_dir = '@0@/gstreamer-1.0'.format(get_option('libdir'))
|
||||
|
||||
# common meson configuration
|
||||
-svthevcenc_dep = dependency('SvtHevcEnc')
|
||||
|
||||
cc = meson.get_compiler('c')
|
||||
cc_flags = [
|
||||
@@ -47,7 +46,7 @@
|
||||
|
||||
gstSvtHevcEnc = library('gstsvthevcenc',
|
||||
'gstsvthevcenc.c',
|
||||
- dependencies: [gstbase_dep, gstpbutils_dep , gstvideo_dep, svthevcenc_dep],
|
||||
- install: true,
|
||||
+ dependencies: [gstbase_dep, gstpbutils_dep , gstvideo_dep],
|
||||
+ install: true, include_directories : include_directories('../Source/API'), link_args : '-lSvtHevcEnc',
|
||||
install_dir: plugins_install_dir
|
||||
)
|
Loading…
Reference in new issue