commit
c2e679b7b6
@ -0,0 +1,2 @@
|
||||
SOURCES/jrope-7FDAB9AF.keyring
|
||||
SOURCES/spice-vdagent-0.21.0.tar.bz2
|
@ -0,0 +1,2 @@
|
||||
86a182f7da5e6d6da9b4fac5dacbcb5d6a8afe5f SOURCES/jrope-7FDAB9AF.keyring
|
||||
1e55469fc20efc705b084a7b2a8e2de59bf4d197 SOURCES/spice-vdagent-0.21.0.tar.bz2
|
@ -0,0 +1,112 @@
|
||||
From 8348ef3c6121247e2b8be0641bbf3df3d55d9bff Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Marc-Andr=C3=A9=20Lureau?= <marcandre.lureau@redhat.com>
|
||||
Date: Tue, 4 May 2021 13:20:47 +0400
|
||||
Subject: [PATCH] Fix g_memdup deprecation warning with glib >= 2.68
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Related to:
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1943059
|
||||
|
||||
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
|
||||
---
|
||||
configure.ac | 4 ++++
|
||||
src/vdagent/vdagent.c | 4 ++--
|
||||
src/vdagent/x11-randr.c | 2 +-
|
||||
src/vdagentd/vdagentd.c | 8 ++++----
|
||||
4 files changed, 11 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 7b2a99c..3de9b9b 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -124,6 +124,10 @@ PKG_CHECK_MODULES(ALSA, [alsa >= 1.0.22])
|
||||
PKG_CHECK_MODULES([DBUS], [dbus-1])
|
||||
PKG_CHECK_MODULES([DRM], [libdrm])
|
||||
|
||||
+PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.68], [], [
|
||||
+ AC_DEFINE(g_memdup2, g_memdup, [GLib2 < 2.68 compatibility])
|
||||
+])
|
||||
+
|
||||
if test "$with_session_info" = "auto" || test "$with_session_info" = "systemd"; then
|
||||
PKG_CHECK_MODULES([LIBSYSTEMD_LOGIN],
|
||||
[libsystemd >= 209],
|
||||
diff --git a/src/vdagent/vdagent.c b/src/vdagent/vdagent.c
|
||||
index 0c69907..fd08522 100644
|
||||
--- a/src/vdagent/vdagent.c
|
||||
+++ b/src/vdagent/vdagent.c
|
||||
@@ -228,7 +228,7 @@ static void daemon_read_complete(UdscsConnection *conn,
|
||||
break;
|
||||
case VDAGENTD_AUDIO_VOLUME_SYNC: {
|
||||
VDAgentAudioVolumeSync *avs = (VDAgentAudioVolumeSync *)data;
|
||||
- uint16_t *volume = g_memdup(avs->volume, sizeof(uint16_t) * avs->nchannels);
|
||||
+ uint16_t *volume = g_memdup2(avs->volume, sizeof(uint16_t) * avs->nchannels);
|
||||
|
||||
if (avs->is_playback) {
|
||||
vdagent_audio_playback_sync(avs->mute, avs->nchannels, volume);
|
||||
@@ -414,7 +414,7 @@ int main(int argc, char *argv[])
|
||||
GOptionContext *context;
|
||||
GError *error = NULL;
|
||||
VDAgent *agent;
|
||||
- char **orig_argv = g_memdup(argv, sizeof(char*) * (argc+1));
|
||||
+ char **orig_argv = g_memdup2(argv, sizeof(char*) * (argc+1));
|
||||
orig_argv[argc] = NULL; /* To avoid clang analyzer false-positive */
|
||||
|
||||
context = g_option_context_new(NULL);
|
||||
diff --git a/src/vdagent/x11-randr.c b/src/vdagent/x11-randr.c
|
||||
index 27404a1..037aded 100644
|
||||
--- a/src/vdagent/x11-randr.c
|
||||
+++ b/src/vdagent/x11-randr.c
|
||||
@@ -982,7 +982,7 @@ void vdagent_x11_set_monitor_config(struct vdagent_x11 *x11,
|
||||
fullscreen it will keep sending the failing config. */
|
||||
g_free(x11->randr.failed_conf);
|
||||
x11->randr.failed_conf =
|
||||
- g_memdup(mon_config, config_size(mon_config->num_of_monitors));
|
||||
+ g_memdup2(mon_config, config_size(mon_config->num_of_monitors));
|
||||
return;
|
||||
}
|
||||
}
|
||||
diff --git a/src/vdagentd/vdagentd.c b/src/vdagentd/vdagentd.c
|
||||
index 78378aa..3e59331 100644
|
||||
--- a/src/vdagentd/vdagentd.c
|
||||
+++ b/src/vdagentd/vdagentd.c
|
||||
@@ -216,7 +216,7 @@ static void do_client_monitors(VirtioPort *vport, int port_nr,
|
||||
vdagentd_write_xorg_conf(new_monitors);
|
||||
|
||||
g_free(mon_config);
|
||||
- mon_config = g_memdup(new_monitors, size);
|
||||
+ mon_config = g_memdup2(new_monitors, size);
|
||||
|
||||
/* Send monitor config to currently active agent */
|
||||
if (active_session_conn)
|
||||
@@ -249,7 +249,7 @@ static void do_client_capabilities(VirtioPort *vport,
|
||||
{
|
||||
capabilities_size = VD_AGENT_CAPS_SIZE_FROM_MSG_SIZE(message_header->size);
|
||||
g_free(capabilities);
|
||||
- capabilities = g_memdup(caps->caps, capabilities_size * sizeof(uint32_t));
|
||||
+ capabilities = g_memdup2(caps->caps, capabilities_size * sizeof(uint32_t));
|
||||
|
||||
if (caps->request) {
|
||||
/* Report the previous client has disconnected. */
|
||||
@@ -647,7 +647,7 @@ static void virtio_port_read_complete(
|
||||
case VD_AGENT_GRAPHICS_DEVICE_INFO: {
|
||||
// store device info for re-sending when a session agent reconnects
|
||||
g_free(device_info);
|
||||
- device_info = g_memdup(data, message_header->size);
|
||||
+ device_info = g_memdup2(data, message_header->size);
|
||||
device_info_size = message_header->size;
|
||||
forward_data_to_session_agent(VDAGENTD_GRAPHICS_DEVICE_INFO, data, message_header->size);
|
||||
break;
|
||||
@@ -1090,7 +1090,7 @@ static void do_agent_xorg_resolution(UdscsConnection *conn,
|
||||
}
|
||||
|
||||
g_free(agent_data->screen_info);
|
||||
- agent_data->screen_info = g_memdup(data, header->size);
|
||||
+ agent_data->screen_info = g_memdup2(data, header->size);
|
||||
agent_data->width = header->arg1;
|
||||
agent_data->height = header->arg2;
|
||||
agent_data->screen_count = n;
|
||||
--
|
||||
2.31.1
|
||||
|
@ -0,0 +1,62 @@
|
||||
From 1aa2c06015e15f707ba9f874d5a5ea49fd450745 Mon Sep 17 00:00:00 2001
|
||||
From: Victor Toso <victortoso@redhat.com>
|
||||
Date: Wed, 1 Dec 2021 20:07:22 +0100
|
||||
Subject: [PATCH 2/3] vdagent: udscs: limit retry to connect to vdagentd
|
||||
|
||||
Related: https://bugzilla.redhat.com/show_bug.cgi?id=2005802
|
||||
Related: https://bugzilla.redhat.com/show_bug.cgi?id=2028013
|
||||
Signed-off-by: Victor Toso <victortoso@redhat.com>
|
||||
---
|
||||
src/vdagent/vdagent.c | 21 +++++++++++++++++++++
|
||||
1 file changed, 21 insertions(+)
|
||||
|
||||
diff --git a/src/vdagent/vdagent.c b/src/vdagent/vdagent.c
|
||||
index fd08522..0d3945e 100644
|
||||
--- a/src/vdagent/vdagent.c
|
||||
+++ b/src/vdagent/vdagent.c
|
||||
@@ -42,11 +42,14 @@
|
||||
#include "clipboard.h"
|
||||
#include "display.h"
|
||||
|
||||
+#define MAX_RETRY_CONNECT_SYSTEM_AGENT 60
|
||||
+
|
||||
typedef struct VDAgent {
|
||||
VDAgentClipboards *clipboards;
|
||||
VDAgentDisplay *display;
|
||||
struct vdagent_file_xfers *xfers;
|
||||
UdscsConnection *conn;
|
||||
+ gint udscs_num_retry;
|
||||
|
||||
GMainLoop *loop;
|
||||
} VDAgent;
|
||||
@@ -378,9 +381,27 @@ static gboolean vdagent_init_async_cb(gpointer user_data)
|
||||
daemon_read_complete, daemon_error_cb,
|
||||
debug);
|
||||
if (agent->conn == NULL) {
|
||||
+ if (agent->udscs_num_retry == MAX_RETRY_CONNECT_SYSTEM_AGENT) {
|
||||
+ syslog(LOG_WARNING,
|
||||
+ "Failed to connect to spice-vdagentd at %s (tried %d times)",
|
||||
+ vdagentd_socket, agent->udscs_num_retry);
|
||||
+ goto err_init;
|
||||
+ }
|
||||
+ if (agent->udscs_num_retry == 0) {
|
||||
+ /* Log only when it fails and at the end */
|
||||
+ syslog(LOG_DEBUG,
|
||||
+ "Failed to connect with spice-vdagentd. Trying again in 1s");
|
||||
+ }
|
||||
+ agent->udscs_num_retry++;
|
||||
g_timeout_add_seconds(1, vdagent_init_async_cb, agent);
|
||||
return G_SOURCE_REMOVE;
|
||||
}
|
||||
+ if (agent->udscs_num_retry != 0) {
|
||||
+ syslog(LOG_DEBUG,
|
||||
+ "Connected with spice-vdagentd after %d attempts",
|
||||
+ agent->udscs_num_retry);
|
||||
+ }
|
||||
+ agent->udscs_num_retry = 0;
|
||||
g_object_set_data(G_OBJECT(agent->conn), "agent", agent);
|
||||
|
||||
agent->display = vdagent_display_create(agent->conn, debug, x11_sync);
|
||||
--
|
||||
2.33.1
|
||||
|
@ -0,0 +1,98 @@
|
||||
From 09de02fd5cb12fcda3326e243981750c5358b7b6 Mon Sep 17 00:00:00 2001
|
||||
From: Victor Toso <victortoso@redhat.com>
|
||||
Date: Mon, 20 Dec 2021 19:09:37 +0100
|
||||
Subject: [PATCH 3/3] udscs: udscs_connect: return error to caller
|
||||
|
||||
This way we can have the log in one place and avoid flooding the journal.
|
||||
|
||||
Signed-off-by: Victor Toso <victortoso@redhat.com>
|
||||
---
|
||||
src/udscs.c | 10 ++++------
|
||||
src/udscs.h | 5 ++++-
|
||||
src/vdagent/vdagent.c | 12 +++++++++---
|
||||
3 files changed, 17 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/src/udscs.c b/src/udscs.c
|
||||
index 3df67b3..6c50f76 100644
|
||||
--- a/src/udscs.c
|
||||
+++ b/src/udscs.c
|
||||
@@ -107,16 +107,14 @@ static void udscs_connection_class_init(UdscsConnectionClass *klass)
|
||||
UdscsConnection *udscs_connect(const char *socketname,
|
||||
udscs_read_callback read_callback,
|
||||
VDAgentConnErrorCb error_cb,
|
||||
- int debug)
|
||||
+ int debug,
|
||||
+ GError **err)
|
||||
{
|
||||
GIOStream *io_stream;
|
||||
UdscsConnection *conn;
|
||||
- GError *err = NULL;
|
||||
|
||||
- io_stream = vdagent_socket_connect(socketname, &err);
|
||||
- if (err) {
|
||||
- syslog(LOG_ERR, "%s: %s", __func__, err->message);
|
||||
- g_error_free(err);
|
||||
+ io_stream = vdagent_socket_connect(socketname, err);
|
||||
+ if (*err) {
|
||||
return NULL;
|
||||
}
|
||||
|
||||
diff --git a/src/udscs.h b/src/udscs.h
|
||||
index 4f7ea36..0d4197b 100644
|
||||
--- a/src/udscs.h
|
||||
+++ b/src/udscs.h
|
||||
@@ -53,11 +53,14 @@ typedef void (*udscs_read_callback)(UdscsConnection *conn,
|
||||
*
|
||||
* If debug is true then the events on this connection will be traced.
|
||||
* This includes the incoming and outgoing message names.
|
||||
+ *
|
||||
+ * In case of failure, returns NULL and set @err with reason.
|
||||
*/
|
||||
UdscsConnection *udscs_connect(const char *socketname,
|
||||
udscs_read_callback read_callback,
|
||||
VDAgentConnErrorCb error_cb,
|
||||
- int debug);
|
||||
+ int debug,
|
||||
+ GError **err);
|
||||
|
||||
/* Queue a message for delivery to the client connected through conn.
|
||||
*/
|
||||
diff --git a/src/vdagent/vdagent.c b/src/vdagent/vdagent.c
|
||||
index 0d3945e..05d1a8f 100644
|
||||
--- a/src/vdagent/vdagent.c
|
||||
+++ b/src/vdagent/vdagent.c
|
||||
@@ -376,22 +376,28 @@ static void vdagent_destroy(VDAgent *agent)
|
||||
static gboolean vdagent_init_async_cb(gpointer user_data)
|
||||
{
|
||||
VDAgent *agent = user_data;
|
||||
+ GError *err = NULL;
|
||||
|
||||
agent->conn = udscs_connect(vdagentd_socket,
|
||||
- daemon_read_complete, daemon_error_cb,
|
||||
- debug);
|
||||
+ daemon_read_complete,
|
||||
+ daemon_error_cb,
|
||||
+ debug,
|
||||
+ &err);
|
||||
if (agent->conn == NULL) {
|
||||
if (agent->udscs_num_retry == MAX_RETRY_CONNECT_SYSTEM_AGENT) {
|
||||
syslog(LOG_WARNING,
|
||||
"Failed to connect to spice-vdagentd at %s (tried %d times)",
|
||||
vdagentd_socket, agent->udscs_num_retry);
|
||||
+ g_error_free(err);
|
||||
goto err_init;
|
||||
}
|
||||
if (agent->udscs_num_retry == 0) {
|
||||
/* Log only when it fails and at the end */
|
||||
syslog(LOG_DEBUG,
|
||||
- "Failed to connect with spice-vdagentd. Trying again in 1s");
|
||||
+ "Failed to connect with spice-vdagentd due '%s'. Trying again in 1s",
|
||||
+ err->message);
|
||||
}
|
||||
+ g_error_free(err);
|
||||
agent->udscs_num_retry++;
|
||||
g_timeout_add_seconds(1, vdagent_init_async_cb, agent);
|
||||
return G_SOURCE_REMOVE;
|
||||
--
|
||||
2.33.1
|
||||
|
Binary file not shown.
@ -0,0 +1,264 @@
|
||||
Name: spice-vdagent
|
||||
Version: 0.21.0
|
||||
Release: 4%{?dist}
|
||||
Summary: Agent for Spice guests
|
||||
License: GPLv3+
|
||||
URL: https://spice-space.org/
|
||||
Source0: https://spice-space.org/download/releases/%{name}-%{version}.tar.bz2
|
||||
Source1: https://spice-space.org/download/releases/%{name}-%{version}.tar.bz2.sig
|
||||
Source2: jrope-7FDAB9AF.keyring
|
||||
|
||||
Patch0001: 0001-Fix-g_memdup-deprecation-warning-with-glib-2.68.patch
|
||||
Patch0002: 0002-vdagent-udscs-limit-retry-to-connect-to-vdagentd.patch
|
||||
Patch0003: 0003-udscs-udscs_connect-return-error-to-caller.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: systemd-devel
|
||||
BuildRequires: glib2-devel >= 2.50
|
||||
BuildRequires: spice-protocol >= 0.14.3
|
||||
BuildRequires: libXrandr-devel libXinerama-devel
|
||||
BuildRequires: libXfixes-devel systemd desktop-file-utils libtool
|
||||
BuildRequires: alsa-lib-devel dbus-devel libdrm-devel
|
||||
# For autoreconf, needed after clipboard patch series
|
||||
BuildRequires: automake autoconf
|
||||
BuildRequires: gnupg2
|
||||
%{?systemd_requires}
|
||||
|
||||
%description
|
||||
Spice agent for Linux guests offering the following features:
|
||||
|
||||
Features:
|
||||
* Client mouse mode (no need to grab mouse by client, no mouse lag)
|
||||
this is handled by the daemon by feeding mouse events into the kernel
|
||||
via uinput. This will only work if the active X-session is running a
|
||||
spice-vdagent process so that its resolution can be determined.
|
||||
* Automatic adjustment of the X-session resolution to the client resolution
|
||||
* Support of copy and paste (text and images) between the active X-session
|
||||
and the client
|
||||
|
||||
|
||||
%prep
|
||||
gpgv2 --quiet --keyring %{SOURCE2} %{SOURCE1} %{SOURCE0}
|
||||
%autosetup -p1
|
||||
autoreconf -fi
|
||||
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--with-session-info=systemd \
|
||||
--with-init-script=systemd \
|
||||
--disable-pciaccess
|
||||
|
||||
make %{?_smp_mflags} V=2
|
||||
|
||||
|
||||
%install
|
||||
make install DESTDIR=$RPM_BUILD_ROOT V=2
|
||||
|
||||
|
||||
%post
|
||||
%systemd_post spice-vdagentd.service spice-vdagentd.socket
|
||||
|
||||
%preun
|
||||
%systemd_preun spice-vdagentd.service spice-vdagentd.socket
|
||||
|
||||
%postun
|
||||
%systemd_postun_with_restart spice-vdagentd.service spice-vdagentd.socket
|
||||
|
||||
|
||||
%files
|
||||
%doc COPYING CHANGELOG.md README.md
|
||||
/usr/lib/udev/rules.d/70-spice-vdagentd.rules
|
||||
%{_unitdir}/spice-vdagentd.service
|
||||
%{_unitdir}/spice-vdagentd.socket
|
||||
%{_prefix}/lib/tmpfiles.d/spice-vdagentd.conf
|
||||
%{_bindir}/spice-vdagent
|
||||
%{_sbindir}/spice-vdagentd
|
||||
%{_var}/run/spice-vdagentd
|
||||
%{_sysconfdir}/xdg/autostart/spice-vdagent.desktop
|
||||
# For /usr/share/gdm/autostart/LoginWindow/spice-vdagent.desktop
|
||||
# We own the dir too, otherwise we must Require gdm
|
||||
%{_datadir}/gdm
|
||||
%{_mandir}/man1/%{name}*.1*
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Mar 15 2023 MSVSphere Packaging Team <packager@msvsphere.ru> - 0.21.0-4
|
||||
- Rebuilt for MSVSphere 9.1.
|
||||
|
||||
* Tue Dec 21 2021 Victor Toso <victortoso@redhat.com> 0.21.0-4
|
||||
- Limit session agent to (re)connect to system agent to a minute
|
||||
Related: rhbz#2028013
|
||||
|
||||
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 0.21.0-3
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Tue Jun 01 2021 Uri Lublin <uril@redhat.com> - 0.21.0-2
|
||||
- Build without pciaccess
|
||||
Resolves: rhbz#1964922
|
||||
- Fix g_memdup deprecation warning with glib >= 2.68
|
||||
|
||||
* Mon Feb 8 2021 Victor Toso <victortoso@redhat.com> 0.21.0-1
|
||||
- Update to spice-vdagent 0.21.0
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.20.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.20.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Thu Mar 26 2020 Victor Toso <victortoso@redhat.com> 0.20.0-2
|
||||
- Fix agent shutdown
|
||||
Resolves: rhbz#1813667
|
||||
|
||||
* Tue Mar 10 2020 Victor Toso <victortoso@redhat.com> 0.20.0-1
|
||||
- Update to spice-vdagent 0.20.0
|
||||
|
||||
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.19.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Fri Oct 04 2019 Adam Williamson <awilliam@redhat.com> - 0.19.0-4
|
||||
- Backport clipboard-race patches for #1755038
|
||||
|
||||
* Fri Sep 13 2019 Benjamin Berg <bberg@redhat.com> - 0.19.0-3
|
||||
- Add patch to lookup graphical session
|
||||
https://gitlab.freedesktop.org/spice/linux/vd_agent/merge_requests/2
|
||||
- Resolves: #1750120
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.19.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri Apr 12 2019 Victor Toso <victortoso@redhat.com> 0.19.0-1
|
||||
- Update to spice-vdagent 0.19.0
|
||||
|
||||
* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.18.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.18.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Tue Jun 12 2018 Victor Toso <victortoso@redhat.com> 0.18.0-1
|
||||
- Update to spice-vdagent 0.18.0
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.17.0-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Jan 25 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.17.0-5
|
||||
- Fix systemd executions/requirements
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.17.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.17.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.17.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Tue Nov 22 2016 Christophe Fergeau <cfergeau@redhat.com> 0.17.0-1
|
||||
- Update to spice-vdagent 0.17.0
|
||||
|
||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.16.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Mon Oct 05 2015 Christophe Fergeau <cfergeau@redhat.com> 0.16.0-2
|
||||
- Add upstream patch fixing a memory corruption bug (double free)
|
||||
Resolves: rhbz#1268666
|
||||
Exit with a non-0 exit code when the virtio device cannot be opened by the
|
||||
agent
|
||||
|
||||
* Tue Jun 30 2015 Christophe Fergeau <cfergeau@redhat.com> 0.16.0-1
|
||||
- Update to 0.16.0 release
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 0.15.0-4
|
||||
- Rebuilt for Fedora 23 Change
|
||||
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
|
||||
|
||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon Oct 14 2013 Alon Levy <alevy@redhat.com> - 0.15.0-1
|
||||
- New upstream release 0.15.0
|
||||
|
||||
* Tue Sep 10 2013 Hans de Goede <hdegoede@redhat.com> - 0.14.0-5
|
||||
- Silence session agent error logging when not running in a vm (rhbz#999804)
|
||||
- Release guest clipboard ownership on client disconnect (rhbz#1003977)
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.14.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Wed Jul 3 2013 Hans de Goede <hdegoede@redhat.com> - 0.14.0-3
|
||||
- Advertise clipboard line-endings for copy and paste line-ending conversion
|
||||
- Build spice-vdagentd as pie + relro
|
||||
|
||||
* Mon May 20 2013 Hans de Goede <hdegoede@redhat.com> - 0.14.0-2
|
||||
- Drop the no longer needed /etc/modules-load.d/spice-vdagentd.conf (#963201)
|
||||
|
||||
* Fri Apr 12 2013 Hans de Goede <hdegoede@redhat.com> - 0.14.0-1
|
||||
- New upstream release 0.14.0
|
||||
- Adds support for file transfers from client to guest
|
||||
- Adds manpages for spice-vdagent and spice-vdagentd
|
||||
|
||||
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Tue Jan 8 2013 Hans de Goede <hdegoede@redhat.com> - 0.12.1-1
|
||||
- New upstream release 0.12.1
|
||||
- Fixes various issues with dynamic monitor / resolution support
|
||||
|
||||
* Mon Nov 12 2012 Hans de Goede <hdegoede@redhat.com> - 0.12.0-2
|
||||
- Fix setting of mode on non arbitrary resolution capable X driver
|
||||
- Fix wrong mouse coordinates on vms with multiple qxl devices
|
||||
|
||||
* Sat Sep 1 2012 Hans de Goede <hdegoede@redhat.com> - 0.12.0-1
|
||||
- New upstream release 0.12.0
|
||||
- This moves the tmpfiles.d to /usr/lib/tmpfiles.d (rhbz#840194)
|
||||
- This adds a systemd .service file (rhbz#848102)
|
||||
|
||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Tue Mar 27 2012 Hans de Goede <hdegoede@redhat.com> - 0.10.1-1
|
||||
- New upstream release 0.10.1
|
||||
|
||||
* Thu Mar 22 2012 Hans de Goede <hdegoede@redhat.com> - 0.10.0-1
|
||||
- New upstream release 0.10.0
|
||||
- This supports using systemd-logind instead of console-kit (rhbz#756398)
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Mon Jul 18 2011 Hans de Goede <hdegoede@redhat.com> 0.8.1-1
|
||||
- New upstream release 0.8.1
|
||||
|
||||
* Fri Jul 15 2011 Hans de Goede <hdegoede@redhat.com> 0.8.0-2
|
||||
- Make the per session agent process automatically reconnect to the system
|
||||
spice-vdagentd when the system daemon gets restarted
|
||||
|
||||
* Tue Apr 19 2011 Hans de Goede <hdegoede@redhat.com> 0.8.0-1
|
||||
- New upstream release 0.8.0
|
||||
|
||||
* Mon Mar 07 2011 Hans de Goede <hdegoede@redhat.com> 0.6.3-6
|
||||
- Fix setting of the guest resolution from a multi monitor client
|
||||
|
||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Mon Jan 10 2011 Hans de Goede <hdegoede@redhat.com> 0.6.3-4
|
||||
- Make sysvinit script exit cleanly when not running on a spice enabled vm
|
||||
|
||||
* Fri Nov 19 2010 Hans de Goede <hdegoede@redhat.com> 0.6.3-3
|
||||
- Put the pid and log files into their own subdir (#648553)
|
||||
|
||||
* Mon Nov 8 2010 Hans de Goede <hdegoede@redhat.com> 0.6.3-2
|
||||
- Fix broken multiline description in initscript lsb header (#648549)
|
||||
|
||||
* Sat Oct 30 2010 Hans de Goede <hdegoede@redhat.com> 0.6.3-1
|
||||
- Initial Fedora package
|
Loading…
Reference in new issue