diff --git a/spacewalk-backend.spec b/spacewalk-backend.spec
index 5612230..ca8f1a8 100644
--- a/spacewalk-backend.spec
+++ b/spacewalk-backend.spec
@@ -7,15 +7,13 @@
 %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
 %endif
 
-%if 0%{?fedora} >= 23 || 0%{?suse_version} > 1320
+%if 0%{?fedora} >= 23 || 0%{?suse_version} > 1320 || 0%{?rhel} >= 8
 %{!?python3_sitelib: %global python3_sitelib %(%{__python3} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
 %global python3rhnroot %{python3_sitelib}/spacewalk
 %global build_py3 1
 %endif
 
-%if 0%{?fedora} || 0%{?rhel} >= 7
-%{!?pylint_check: %global pylint_check 1}
-%endif
+%{!?pylint_check: %global pylint_check 0}
 
 %if 0%{?fedora} || 0%{?rhel}
 %global apacheconfd %{_sysconfdir}/httpd/conf.d
@@ -39,7 +37,7 @@ Name: spacewalk-backend
 Summary: Common programs needed to be installed on the Spacewalk servers/proxies
 License: GPLv2
 Version: 2.8.48
-Release: 1%{?dist}
+Release: 2%{?dist}
 URL:       https://github.com/spacewalkproject/spacewalk
 Source0: https://github.com/spacewalkproject/spacewalk/archive/%{name}-%{version}.tar.gz
 BuildArch: noarch
@@ -64,10 +62,6 @@ BuildRequires: spacewalk-usix
 BuildRequires: rhnlib >= 2.5.74
 BuildRequires: python2-rhn-client-tools
 BuildRequires: rpm-python
-BuildRequires: python-crypto
-BuildRequires: python-debian
-BuildRequires: python2-gzipstream
-BuildRequires: yum
 BuildRequires: %{m2crypto}
 %endif
 Requires(pre): %{apache_pkg}
@@ -236,6 +230,7 @@ Libraries required by both Spacewalk server and Spacewalk client tools.
 Summary: Spacewalk client tools libraries for Fedora 23
 BuildRequires: python2-devel
 BuildRequires: python3-devel
+BuildRequires: python2-spacewalk-usix
 Conflicts: %{name} < 1.7.0
 %if 0%{?suse_version}
 Requires:       python3-base
@@ -788,6 +783,10 @@ rm -f %{rhnconf}/rhnSecret.py*
 %endif
 
 %changelog
+* Wed Mar 07 2018 Tomas Kasparek <tkasparek@redhat.com> 2.8.48-2
+- don't run pyling when building spacewalk backend + other build fixes
+  (tkasparek@redhat.com)
+
 * Tue Feb 13 2018 Eric Herget <eherget@redhat.com> 2.8.48-1
 - Update to use newly separated spacewalk-python[2|3]-pylint packages