You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
shapelib/shapelib-1.2.10-Makefile2.p...

30 lines
910 B

diff -Naur shapelib-1.2.10/contrib/Makefile shapelib-1.2.10-mod/contrib/Makefile
--- shapelib-1.2.10/contrib/Makefile 2010-01-04 06:08:02.000000000 +0200
+++ shapelib-1.2.10-mod/contrib/Makefile 2010-02-16 10:18:48.000000000 +0200
@@ -3,7 +3,7 @@
#CFLAGS = -g
# Endian: define either _LITTLE_ENDIAN or _BIG_ENDIAN
-ENDIAN = -D_LITTLE_ENDIAN
+#ENDIAN = -D_LITTLE_ENDIAN
CFLAGS = -g -I.. -I$(HOME)/bld/include -DPROJ4 $(ENDIAN) -DDEBUG -DDEBUG2
@@ -32,7 +32,7 @@
shpdata: shpdata.c $(SHPGOBJ)
$(CC) $(CFLAGS) shpdata.c ${SHPOBJ} $(LINKOPT) $(GEOOBJ) -o shpdata
-shpinfo: shpinfo.c $(SHPOBJ)
+shpinfo: shpinfo.c $(SHPGOBJ)
$(CC) $(CFLAGS) shpinfo.c ${SHPOBJ} $(LINKOPT) $(GEOOBJ) -o shpinfo
shpfix: shpfix.c $(SHPOBJ)
@@ -64,3 +64,7 @@
testproj:
tests/shpproj.sh
+
+install: all
+ install dbfcat dbfinfo shpcat shpcentrd shpdata shpdxf shpfix shpinfo shpwkb shpproj \
+ $(bindir)