You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
20 lines
843 B
20 lines
843 B
diff -up shapelib-1.2.10/Makefile.old shapelib-1.2.10/Makefile
|
|
--- shapelib-1.2.10/Makefile.old 2007-10-19 07:30:30.000000000 -0400
|
|
+++ shapelib-1.2.10/Makefile 2007-10-19 07:30:55.000000000 -0400
|
|
@@ -1,5 +1,6 @@
|
|
INSTALL = /usr/bin/install
|
|
LD = /usr/bin/ld
|
|
+LDFLAGS = --build-id
|
|
|
|
bindir = /usr/local/bin
|
|
libdir = /usr/local/lib
|
|
@@ -123,7 +124,7 @@ lib:
|
|
rm -fr .libs/libshp.la .libs/libshp.* .libs/libshp.*
|
|
rm -fr .libs/libshp.lax
|
|
mkdir .libs/libshp.lax
|
|
- $(LD) -G -h libshp.so.1 -o .libs/libshp.so.$(LIBSHP_VERSION) shpopen.lo shptree.lo dbfopen.lo -lc
|
|
+ $(LD) $(LDFLAGS) -G -h libshp.so.1 -o .libs/libshp.so.$(LIBSHP_VERSION) shpopen.lo shptree.lo dbfopen.lo -lc
|
|
|
|
(cd .libs && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
|
|
(cd .libs && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)
|