You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
shapelib/shapelib-1.3.0b1-Makefile2....

34 lines
948 B

--- shapelib-1.3.0b1/contrib/Makefile 2004-06-24 03:55:52.000000000 +0300
+++ shapelib-1.3.0b1.mod/contrib/Makefile 2010-03-09 10:09:54.000000000 +0200
@@ -3,11 +3,11 @@
#CFLAGS = -g
# Endian: define either _LITTLE_ENDIAN or _BIG_ENDIAN
-ENDIAN = -D_LITTLE_ENDIAN
+#ENDIAN = -D_LITTLE_ENDIAN
CFLAGS = -g -I.. -DPROJ4 $(ENDIAN) -DDEBUG -DDEBUG2
-SHPOBJ = ../shpopen.o ../dbfopen.o
+SHPOBJ = ../shpopen.o ../dbfopen.o ../safileio.o
SHPGOBJ = ../shpopen.o ../dbfopen.o shpgeo.o
@@ -32,7 +32,7 @@
shpdata: shpdata.c $(SHPGOBJ)
$(CC) $(CFLAGS) shpdata.c ${SHPOBJ} $(LINKOPT) $(GEOOBJ) -o shpdata
-shpinfo: shpinfo.c $(SHPOBJ)
+shpinfo: shpinfo.c $(SHPGOBJ)
$(CC) $(CFLAGS) shpinfo.c ${SHPOBJ} $(LINKOPT) $(GEOOBJ) -o shpinfo
shpfix: shpfix.c $(SHPOBJ)
@@ -64,3 +64,7 @@
testproj:
tests/shpproj.sh
+
+install: all
+ install dbfcat dbfinfo shpcat shpcentrd shpdata shpdxf shpfix shpinfo shpwkb shpproj \
+ $(bindir)