You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
shapelib/shapelib-1.2.10-buildid.patch

21 lines
793 B

diff -Naur shapelib-1.2.10/Makefile shapelib-1.2.10-mod/Makefile
--- shapelib-1.2.10/Makefile 2010-02-16 09:43:03.000000000 +0200
+++ shapelib-1.2.10-mod/Makefile 2010-02-16 09:43:43.000000000 +0200
@@ -13,6 +13,7 @@
CC = gcc
CFLAGS = -g
+LDFLAGS = --build-id
default: all
@@ -134,7 +135,7 @@
rm -fr .libs/libshp.la .libs/libshp.* .libs/libshp.*
rm -fr .libs/libshp.lax
mkdir .libs/libshp.lax
- $(LD) -G -h libshp.so.1 -o .libs/libshp.so.$(LIBSHP_VERSION) shpopen.lo shptree.lo dbfopen.lo -lc
+ $(LD) $(LDFLAGS) -G -h libshp.so.1 -o .libs/libshp.so.$(LIBSHP_VERSION) shpopen.lo shptree.lo dbfopen.lo -lc
(cd .libs && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
(cd .libs && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)