You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
shapelib/shapelib-1.3.0b1-buildid.patch

20 lines
752 B

--- shapelib-1.3.0b1/Makefile 2010-03-09 08:41:01.000000000 +0200
+++ shapelib-1.3.0b1.mod/Makefile 2010-03-09 08:41:29.000000000 +0200
@@ -12,6 +12,7 @@
CC = gcc
CFLAGS = -g
+LDFLAGS = --build-id
default: all
@@ -137,7 +138,7 @@
rm -fr .libs/libshp.la .libs/libshp.* .libs/libshp.*
rm -fr .libs/libshp.lax
mkdir .libs/libshp.lax
- $(LD) -G -h libshp.so.1 -o .libs/libshp.so.$(LIBSHP_VERSION) shpopen.lo shptree.lo dbfopen.lo safileio.lo -lc
+ $(LD) $(LDFLAGS) -G -h libshp.so.1 -o .libs/libshp.so.$(LIBSHP_VERSION) shpopen.lo shptree.lo dbfopen.lo safileio.lo -lc
(cd .libs && rm -f libshp.so.1 && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so.1)
(cd .libs && rm -f libshp.so && ln -s libshp.so.$(LIBSHP_VERSION) libshp.so)