commit
8cbad10a6a
@ -0,0 +1 @@
|
||||
SOURCES/setserial-2.17.tar.gz
|
@ -0,0 +1 @@
|
||||
68824494a0b5700f7e999564a59358bf34f79eb1 SOURCES/setserial-2.17.tar.gz
|
@ -0,0 +1,23 @@
|
||||
--- setserial-2.17/Makefile.in.fhs Wed Jun 14 15:42:39 2000
|
||||
+++ setserial-2.17/Makefile.in Wed Jun 14 15:44:25 2000
|
||||
@@ -3,6 +3,8 @@
|
||||
|
||||
srcdir = @srcdir@
|
||||
VPATH = @srcdir@
|
||||
+bindir = @bindir@
|
||||
+mandir = @mandir@
|
||||
|
||||
VERSION = @RELEASE_VERSION@
|
||||
INSTALL = @INSTALL@
|
||||
@@ -26,9 +28,8 @@
|
||||
nroff -man setserial.8 > setserial.cat
|
||||
|
||||
install: setserial setserial.8
|
||||
- $(INSTALL_PROGRAM) setserial $(DESTDIR)/bin
|
||||
- $(STRIP) $(DESTDIR)/bin/setserial
|
||||
- $(INSTALL_DATA) setserial.8 $(DESTDIR)/usr/man/man8
|
||||
+ $(INSTALL_PROGRAM) setserial $(DESTDIR)$(bindir)
|
||||
+ $(INSTALL_DATA) setserial.8 $(DESTDIR)$(mandir)/man8
|
||||
|
||||
clean:
|
||||
$(RM) setserial setserial.o setserial.cat *~
|
@ -0,0 +1,65 @@
|
||||
--- setserial-2.17/rc.serial.rc Thu Jan 27 15:47:30 2000
|
||||
+++ setserial-2.17/rc.serial Tue Sep 11 17:54:26 2001
|
||||
@@ -19,7 +19,7 @@
|
||||
#
|
||||
|
||||
RCLOCKFILE=/var/lock/subsys/serial
|
||||
-DIRS="/lib/modules/`uname -r`/misc /lib/modules /usr/lib/modules ."
|
||||
+DIRS="/lib/modules/`uname -r`/kernel/drivers/char /lib/modules/`uname -r`/misc /lib/modules /usr/lib/modules ."
|
||||
PATH=/bin:/sbin:/usr/bin
|
||||
DRIVER=serial
|
||||
DRIVER_NAME=serial
|
||||
@@ -79,10 +79,11 @@
|
||||
|
||||
if test $action = stop ; then
|
||||
if test -n ${SETSERIAL} -a "$LOADED" != "no" -a \
|
||||
- `head -1 /etc/serial.conf`X = "###AUTOSAVE###X" ; then
|
||||
+ "$(head -1 /etc/serial.conf 2>/dev/null)" = "###AUTOSAVE###" ; then
|
||||
echo -n "Saving state of serial devices... "
|
||||
grep "^#" /etc/serial.conf > /etc/.serial.conf.new
|
||||
- ${SETSERIAL} -G -g ${ALLDEVS} >> /etc/.serial.conf.new
|
||||
+ ${SETSERIAL} -G -g ${ALLDEVS} \
|
||||
+ 2>/dev/null >> /etc/.serial.conf.new
|
||||
mv /etc/serial.conf /etc/.serial.conf.old
|
||||
mv /etc/.serial.conf.new /etc/serial.conf
|
||||
echo "done."
|
||||
@@ -108,22 +109,26 @@
|
||||
# If not stop, it must be a start....
|
||||
#
|
||||
|
||||
-if test -n $MODULE -a "$LOADED" != "yes" ; then
|
||||
+if test -n "$MODULE" -a "$LOADED" != "yes" ; then
|
||||
+ MAPFILE=$(mktemp /tmp/$DRIVER.map.XXXXXX) \
|
||||
+ || { echo "Couldn't create secure temporary file"; exit 1; }
|
||||
+ ERRORS=$(mktemp /tmp/$DRIVER.XXXXXX) \
|
||||
+ || { echo "Couldn't create secure temporary file"; exit 1; }
|
||||
if insmod -fm $MODULE $DRIVER_ARG \
|
||||
- > /tmp/$DRIVER.map 2> /tmp/$DRIVER.$$; then :;
|
||||
+ > "${MAPFILE}" 2> "${ERRORS}"; then :;
|
||||
else
|
||||
echo "Couldn't load $DRIVER_NAME driver."
|
||||
- echo "See error logs in /tmp/$DRIVER.$$"
|
||||
+ echo "See error logs in ${ERRORS}"
|
||||
exit 1
|
||||
fi
|
||||
- /bin/rm -f /tmp/$DRIVER.$$
|
||||
+ /bin/rm -f "${ERRORS}"
|
||||
fi
|
||||
|
||||
-if test -f /etc/serial.conf ; then
|
||||
- if test -n ${SETSERIAL} ; then
|
||||
+if test -f "/etc/serial.conf" ; then
|
||||
+ if test -n "${SETSERIAL}" ; then
|
||||
grep -v ^# < /etc/serial.conf | while read device args
|
||||
do
|
||||
- ${SETSERIAL} -z $device $args
|
||||
+ ${SETSERIAL} -z $device $args 2>/dev/null
|
||||
done
|
||||
fi
|
||||
else
|
||||
@@ -131,4 +136,4 @@
|
||||
fi
|
||||
|
||||
touch ${RCLOCKFILE}
|
||||
-${SETSERIAL} -bg ${ALLDEVS}
|
||||
+${SETSERIAL} -bg ${ALLDEVS} 2>/dev/null
|
@ -0,0 +1,11 @@
|
||||
--- setserial-2.17/README.readme Tue Sep 11 17:59:52 2001
|
||||
+++ setserial-2.17/README Tue Sep 11 18:00:27 2001
|
||||
@@ -13,6 +13,6 @@
|
||||
|
||||
The simplest way to configure the serial ports is to copy the provided
|
||||
rc.serial file to the appropriate /etc/rc.d directory. For example,
|
||||
-to install rc.serial on a RedHat system, copy rc.serial to
|
||||
-/etc/rc.d/init.d/serial, and then run the command "chkconfig -add serial".
|
||||
+to install rc.serial on a Fedora system, copy rc.serial to
|
||||
+/etc/rc.d/init.d/serial, and then run the command "chkconfig --add serial".
|
||||
|
@ -0,0 +1,11 @@
|
||||
--- setserial-2.17/setserial.c.spelling 2003-01-10 17:21:24.000000000 +0000
|
||||
+++ setserial-2.17/setserial.c 2003-01-10 17:21:39.000000000 +0000
|
||||
@@ -707,7 +707,7 @@
|
||||
fprintf(stderr, "\t spd_warp\tuse 460kb instead of 38.4kb\n");
|
||||
fprintf(stderr, "\t spd_cust\tuse the custom divisor to set the speed at 38.4kb\n");
|
||||
fprintf(stderr, "\t\t\t\t(baud rate = baud_base / custom_divisor)\n");
|
||||
- fprintf(stderr, "\t spd_normal\tuse 38.4kb when a buad rate of 38.4kb is selected\n");
|
||||
+ fprintf(stderr, "\t spd_normal\tuse 38.4kb when a baud rate of 38.4kb is selected\n");
|
||||
fprintf(stderr, "\n");
|
||||
fprintf(stderr, "Use a leading '0x' for hex numbers.\n");
|
||||
fprintf(stderr, "CAUTION: Using an invalid port can lock up your machine!\n");
|
File diff suppressed because it is too large
Load Diff
@ -0,0 +1,28 @@
|
||||
Avoid implicit int and implicit function declarations.
|
||||
|
||||
A mostly equivalent patch has been posted upstream:
|
||||
|
||||
<https://sourceforge.net/p/setserial/discussion/7060/thread/95d874c12c/?limit=25#1643>
|
||||
|
||||
diff --git a/setserial.c b/setserial.c
|
||||
index f184e98db07ceb59..d181327fc568ede4 100644
|
||||
--- a/setserial.c
|
||||
+++ b/setserial.c
|
||||
@@ -15,6 +15,9 @@
|
||||
#include <termios.h>
|
||||
#include <string.h>
|
||||
#include <errno.h>
|
||||
+#include <sys/ioctl.h>
|
||||
+#include <unistd.h>
|
||||
+#include <stdlib.h>
|
||||
|
||||
#ifdef HAVE_ASM_IOCTLS_H
|
||||
#include <asm/ioctls.h>
|
||||
@@ -714,6 +717,7 @@ fprintf(stderr, "\t* port\t\tset the I/O port\n");
|
||||
exit(1);
|
||||
}
|
||||
|
||||
+int
|
||||
main(int argc, char **argv)
|
||||
{
|
||||
int get_flag = 0, wild_intr_flag = 0;
|
@ -0,0 +1,17 @@
|
||||
This fixes a generic C99 compatibility issue in autoconf-generated
|
||||
code. No need to upstream this because the issue goes away if
|
||||
autoconf is re-run.
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index 9d6084aa38e5d6e8..4d948816e1112d13 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -689,7 +689,7 @@ cat > conftest.$ac_ext << EOF
|
||||
#line 690 "configure"
|
||||
#include "confdefs.h"
|
||||
|
||||
-main(){return(0);}
|
||||
+int main(){return(0);}
|
||||
EOF
|
||||
if { (eval echo configure:695: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
ac_cv_prog_cc_works=yes
|
@ -0,0 +1,30 @@
|
||||
diff -up setserial-2.17/setserial.c.hayesesp setserial-2.17/setserial.c
|
||||
--- setserial-2.17/setserial.c.hayesesp 2010-02-15 12:20:59.104048442 +0000
|
||||
+++ setserial-2.17/setserial.c 2010-02-15 12:21:42.368924088 +0000
|
||||
@@ -356,7 +356,7 @@ void set_multiport(char *device, int fd,
|
||||
}
|
||||
#endif
|
||||
|
||||
-#ifdef TIOCGHAYESESP
|
||||
+#if defined(TIOCGHAYESESP) && defined(HAVE_LINUX_HAYESESP_H)
|
||||
void print_hayesesp(int fd)
|
||||
{
|
||||
struct hayes_esp_config esp;
|
||||
@@ -453,7 +453,7 @@ void get_serial(char *device)
|
||||
print_flags(&serinfo, "\tFlags: ", "");
|
||||
printf("\n\n");
|
||||
|
||||
-#ifdef TIOCGHAYESESP
|
||||
+#if defined(TIOCGHAYESESP) && defined(HAVE_LINUX_HAYESESP_H)
|
||||
print_hayesesp(fd);
|
||||
#endif
|
||||
} else if (verbosity==0) {
|
||||
@@ -593,7 +593,7 @@ void set_serial(char *device, char ** ar
|
||||
}
|
||||
set_multiport(device, fd, &arg);
|
||||
break;
|
||||
-#ifdef TIOCGHAYESESP
|
||||
+#if defined(TIOCGHAYESESP) && defined(HAVE_LINUX_HAYESESP_H)
|
||||
case CMD_RX_TRIG:
|
||||
case CMD_TX_TRIG:
|
||||
case CMD_FLOW_OFF:
|
@ -0,0 +1,300 @@
|
||||
Summary: A utility for configuring serial ports
|
||||
Name: setserial
|
||||
Version: 2.17
|
||||
Release: 62%{?dist}
|
||||
Source: https://sourceforge.net/projects/setserial/files/setserial/%{version}/%{name}-%{version}.tar.gz
|
||||
Patch0: setserial-2.17-fhs.patch
|
||||
Patch1: setserial-2.17-rc.patch
|
||||
Patch2: setserial-2.17-readme.patch
|
||||
Patch3: setserial-2.17-spelling.patch
|
||||
Patch4: setserial-hayesesp.patch
|
||||
Patch5: setserial-aarch64.patch
|
||||
Patch6: setserial-configure-c99.patch
|
||||
Patch7: setserial-c99.patch
|
||||
License: GPL-1.0-or-later
|
||||
URL: http://setserial.sourceforge.net/
|
||||
ExcludeArch: s390 s390x
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc
|
||||
BuildRequires: groff
|
||||
|
||||
%description
|
||||
Setserial is a basic system utility for displaying or setting serial
|
||||
port information. Setserial can reveal and allow you to alter the I/O
|
||||
port and IRQ that a particular serial device is using, and more.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
# Use FHS directory layout.
|
||||
%patch0 -p1 -b .fhs
|
||||
|
||||
# Fixed initscript.
|
||||
%patch1 -p1 -b .rc
|
||||
|
||||
# Corrected readme file.
|
||||
%patch2 -p1 -b .readme
|
||||
|
||||
# Fixed spelling in help output.
|
||||
%patch3 -p1 -b .spelling
|
||||
|
||||
# Don't require hayesesp.h (bug #564947).
|
||||
%patch4 -p1 -b .hayesesp
|
||||
rm -f config.cache
|
||||
|
||||
# Support aarch64 (bug #926522).
|
||||
%patch5 -p1 -b .aarch64
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
|
||||
%build
|
||||
%set_build_flags
|
||||
# Makefile expects CFLAGS to contain linker flags.
|
||||
CFLAGS="$CFLAGS $LDFLAGS"
|
||||
%configure
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf ${RPM_BUILD_ROOT}
|
||||
mkdir -p ${RPM_BUILD_ROOT}/%{_bindir}
|
||||
mkdir -p ${RPM_BUILD_ROOT}/%{_mandir}/man8
|
||||
make install DESTDIR=${RPM_BUILD_ROOT}
|
||||
|
||||
%files
|
||||
%doc README rc.serial
|
||||
%{_bindir}/setserial
|
||||
%{_mandir}/man*/*
|
||||
|
||||
%changelog
|
||||
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 2.17-62
|
||||
- Bump release for June 2024 mass rebuild
|
||||
|
||||
* Thu May 23 2024 Than Ngo <than@redhat.com> - 2.17-61
|
||||
- Related: RHEL-35869, rpminspect pathmigration
|
||||
|
||||
* Wed May 08 2024 Than Ngo <than@redhat.com> - 2.17-60
|
||||
- Resolves: RHEL-35869, Migrate to SPDX license
|
||||
|
||||
* Sat Jan 27 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.17-59
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.17-58
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Thu Apr 13 2023 Florian Weimer <fweimer@redhat.com> - 2.17-57
|
||||
- Port to C99
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.17-56
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.17-55
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Sat Jan 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.17-54
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.17-53
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.17-52
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.17-51
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.17-50
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.17-49
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.17-48
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Mon Jul 23 2018 Tim Waugh <twaugh@redhat.com> - 2.17-47
|
||||
- Build requires gcc (bug #1606335).
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.17-46
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Thu Jul 05 2018 Than Ngo <than@redhat.com> - 2.17-45
|
||||
- fixed typo
|
||||
|
||||
* Thu Jul 05 2018 Than Ngo <than@redhat.com> - 2.17-44
|
||||
- fixed source url
|
||||
|
||||
* Sun Feb 25 2018 Florian Weimer <fweimer@redhat.com> - 2.17-43
|
||||
- Use LDFLAGS from redhat-rpm-config
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.17-42
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.17-41
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.17-40
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.17-39
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.17-38
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.17-37
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.17-36
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.17-35
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.17-34
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Mon Apr 29 2013 Tim Waugh <twaugh@redhat.com> 2.17-33
|
||||
- Support aarch64 (bug #926522).
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.17-32
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Fri Sep 21 2012 Tim Waugh <twaugh@redhat.com> 2.17-31
|
||||
- Fixed source URL.
|
||||
|
||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.17-29
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.17-28
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.17-27
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Wed Mar 3 2010 Tim Waugh <twaugh@redhat.com> 2.17-26
|
||||
- Added comments for all patches.
|
||||
|
||||
* Mon Feb 15 2010 Tim Waugh <twaugh@redhat.com> 2.17-25
|
||||
- Don't require hayesesp.h (bug #564947).
|
||||
|
||||
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.17-24
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.17-23
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Mon Feb 11 2008 Tim Waugh <twaugh@redhat.com> 2.17-22
|
||||
- Rebuild for GCC 4.3.
|
||||
|
||||
* Wed Aug 29 2007 Tim Waugh <twaugh@redhat.com> 2.17-21
|
||||
- More specific license tag.
|
||||
|
||||
* Wed Feb 7 2007 Tim Waugh <twaugh@redhat.com> 2.17-20
|
||||
- Fixed mandir in fhs patch (bug #226411).
|
||||
- Don't run strip (bug #226411).
|
||||
- Fixed readme patch to talk about Fedora not Red Hat Linux (bug #226411).
|
||||
- Fixed build root tag (bug #226411).
|
||||
- Use SMP make flags (bug #226411).
|
||||
- Avoid %%makeinstall (bug #226411).
|
||||
- Fixed summary (bug #226411).
|
||||
|
||||
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.17-19.2.2
|
||||
- rebuild
|
||||
|
||||
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.17-19.2.1
|
||||
- bump again for double-long bug on ppc(64)
|
||||
|
||||
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.17-19.2
|
||||
- rebuilt for new gcc4.1 snapshot and glibc changes
|
||||
|
||||
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Wed Mar 2 2005 Tim Waugh <twaugh@redhat.com> 2.17-19
|
||||
- Rebuild for new GCC.
|
||||
|
||||
* Wed Feb 9 2005 Tim Waugh <twaugh@redhat.com> 2.17-18
|
||||
- Rebuilt.
|
||||
|
||||
* Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com> 2.17-17
|
||||
- Spec file tidying by Robert Scheck (bug #135182).
|
||||
|
||||
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Thu Nov 27 2003 Tim Waugh <twaugh@redhat.com> 2.17-14
|
||||
- Build requires groff (bug #111088).
|
||||
|
||||
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Fri Jan 10 2003 Tim Waugh <twaugh@redhat.com> 2.17-11
|
||||
- Fix spelling mistake (bug #80896).
|
||||
|
||||
* Wed Nov 20 2002 Tim Powers <timp@redhat.com> 2.17-10
|
||||
- rebuild in current collinst
|
||||
|
||||
* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
|
||||
- automated rebuild
|
||||
|
||||
* Thu May 23 2002 Tim Powers <timp@redhat.com>
|
||||
- automated rebuild
|
||||
|
||||
* Mon Apr 22 2002 Tim Waugh <twaugh@redhat.com> 2.17-7
|
||||
- Don't strip binaries explicitly (bug #62566).
|
||||
|
||||
* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
|
||||
- automated rebuild
|
||||
|
||||
* Tue Sep 11 2001 Tim Waugh <twaugh@redhat.com> 2.17-5
|
||||
- Fix init script (bug #52862).
|
||||
- Avoid temporary file vulnerability in init script.
|
||||
- Update README: it's --add, not -add.
|
||||
|
||||
* Tue Jun 19 2001 Florian La Roche <Florian.LaRoche@redhat.de> 2.17-4
|
||||
- add ExcludeArch: s390 s390x
|
||||
|
||||
* Wed May 30 2001 Tim Waugh <twaugh@redhat.com> 2.17-3
|
||||
- Sync description with specspo.
|
||||
|
||||
* Wed Jul 12 2000 Prospector <bugzilla@redhat.com> 2.17-2
|
||||
- automatic rebuild
|
||||
|
||||
* Wed Jun 14 2000 Jeff Johnson <jbj@redhat.com>
|
||||
- update to 2.17.
|
||||
- FHS packaging.
|
||||
|
||||
* Mon Feb 7 2000 Jeff Johnson <jbj@redhat.com>
|
||||
- compress man pages.
|
||||
|
||||
* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
|
||||
- auto rebuild in the new build environment (release 2)
|
||||
|
||||
* Thu Feb 11 1999 Michael Maher <mike@redhat.com>
|
||||
- fixed bug #363
|
||||
|
||||
* Thu Dec 17 1998 Michael Maher <mike@redhat.com>
|
||||
- built package for 6.0
|
||||
|
||||
* Sat Jun 20 1998 Jeff Johnson <jbj@redhat.com>
|
||||
- upgraded to 2.1.14
|
||||
|
||||
* Thu May 07 1998 Prospector System <bugs@redhat.com>
|
||||
- translations modified for de, fr, tr
|
||||
|
||||
* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
|
||||
- pulled into distribution
|
||||
- used setserial-2.12_CTI.tgz instead of setserial-2.12.tar.gz (former is
|
||||
all that sunsite has) - not sure what the difference is.
|
||||
|
||||
* Thu Sep 25 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
|
||||
- added %%attr's
|
||||
- added sanity check for RPM_BUILD_ROOT
|
||||
- setserial is now installed into /bin, where util-linux puts it and all
|
||||
startup scripts expect it.
|
Loading…
Reference in new issue