You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
32 lines
1.0 KiB
32 lines
1.0 KiB
From 7efe53000c49fb6ce808286b15283d2da05b0c52 Mon Sep 17 00:00:00 2001
|
|
From: Jerome Leclanche <jerome@leclan.ch>
|
|
Date: Thu, 5 Nov 2015 18:55:02 +0200
|
|
Subject: [PATCH 03/34] Generate and install the default sddm.conf after sddm
|
|
is built
|
|
|
|
Fixes #463
|
|
---
|
|
src/daemon/CMakeLists.txt | 9 +++++++++
|
|
1 file changed, 9 insertions(+)
|
|
|
|
diff --git a/src/daemon/CMakeLists.txt b/src/daemon/CMakeLists.txt
|
|
index 07a0a3d..1ae70e1 100644
|
|
--- a/src/daemon/CMakeLists.txt
|
|
+++ b/src/daemon/CMakeLists.txt
|
|
@@ -45,3 +45,12 @@ if(JOURNALD_FOUND)
|
|
endif()
|
|
|
|
install(TARGETS sddm DESTINATION "${CMAKE_INSTALL_BINDIR}")
|
|
+
|
|
+# Generate and install the default config file
|
|
+add_custom_command(COMMAND sddm --example-config > "${CMAKE_BINARY_DIR}/sddm.conf"
|
|
+ OUTPUT "${CMAKE_BINARY_DIR}/sddm.conf"
|
|
+ COMMENT "Generate default sddm.conf file"
|
|
+ DEPENDS sddm
|
|
+)
|
|
+add_custom_target(generate_config_file ALL DEPENDS "${CMAKE_BINARY_DIR}/sddm.conf")
|
|
+install(FILES "${CMAKE_BINARY_DIR}/sddm.conf" DESTINATION "${CMAKE_INSTALL_FULL_SYSCONFDIR}")
|
|
--
|
|
2.5.0
|
|
|