You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
45 lines
1.4 KiB
45 lines
1.4 KiB
From 207d03e309ef8a4a94754d2d9d76c72b7ca503bd Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
|
|
Date: Sat, 21 Feb 2015 19:57:41 +0100
|
|
Subject: [PATCH 19/70] handle merge of libsystemd-journal -> libsystemd for
|
|
systemd >= 209
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
see [1]:
|
|
|
|
'The APIs "sd-journal.h", "sd-login.h", "sd-id128.h", "sd-daemon.h" are no
|
|
longer found in individual libraries libsystemd-journal.so, , libsystemd-login.so,
|
|
libsystemd-id128.so, libsystemd-daemon.so. Instead, we have merged them into
|
|
a single library, libsystemd.so, which provides all symbols.
|
|
|
|
[1] http://cgit.freedesktop.org/systemd/systemd/tree/NEWS
|
|
|
|
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
|
|
---
|
|
CMakeLists.txt | 7 ++++++-
|
|
1 file changed, 6 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 61230a4..3a34ba6 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -98,7 +98,12 @@ if(SYSTEMD_FOUND)
|
|
add_definitions(-DHAVE_SYSTEMD)
|
|
set(CMAKE_AUTOMOC_MOC_OPTIONS -DHAVE_SYSTEMD)
|
|
|
|
- pkg_check_modules(JOURNALD "libsystemd-journal")
|
|
+ # libsystemd-journal was merged into libsystemd in 209
|
|
+ if(${SYSTEMD_VERSION} VERSION_LESS 209)
|
|
+ pkg_check_modules(JOURNALD "libsystemd-journal")
|
|
+ else()
|
|
+ pkg_check_modules(JOURNALD "libsystemd")
|
|
+ endif()
|
|
|
|
if(ENABLE_JOURNALD)
|
|
if(JOURNALD_FOUND)
|
|
--
|
|
2.4.3
|
|
|