New upstream release 4.8.0

Resolves: #1798742
epel9
Vaclav Dolezal 5 years ago
parent 8d62df0456
commit 17f00db3dc

1
.gitignore vendored

@ -13,3 +13,4 @@ screen-4.0.3.tar.gz
/screen-4.6.1.tar.gz
/screen-4.6.2.tar.gz
/screen-4.7.0.tar.gz
/screen-4.8.0.tar.gz

@ -1,10 +1,10 @@
check crypt output (rhbz#815605)
diff --git a/misc.c b/misc.c
index 43e93a2..178fda9 100644
index 2022a06..235c82f 100644
--- a/misc.c
+++ b/misc.c
@@ -56,6 +56,8 @@ register const char *str;
@@ -57,6 +57,8 @@ register const char *str;
{
register char *cp;

@ -1,5 +1,5 @@
diff --git a/configure.ac b/configure.ac
index ab799d2..6b8b03f 100644
index c0f02df..b76c8f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -188,7 +188,8 @@ AC_EGREP_CPP(yes,
@ -12,7 +12,7 @@ index ab799d2..6b8b03f 100644
AC_CHECKING(SVR4)
AC_TRY_LINK([#include <utmpx.h>
],,
@@ -623,14 +624,10 @@ dnl
@@ -626,14 +627,10 @@ dnl
AC_CHECKING(for tgetent)
AC_TRY_LINK(,tgetent((char *)0, (char *)0);,,
olibs="$LIBS"
@ -29,7 +29,7 @@ index ab799d2..6b8b03f 100644
],,
LIBS="-ltermcap $olibs"
AC_CHECKING(libtermcap)
@@ -655,7 +652,7 @@ AC_MSG_ERROR(!!! no tgetent - no screen)))))))))
@@ -658,7 +655,7 @@ AC_MSG_ERROR(!!! no tgetent - no screen)))))))))
AC_TRY_RUN([
main()
{
@ -38,7 +38,7 @@ index ab799d2..6b8b03f 100644
}], AC_NOTE(- you use the termcap database),
AC_NOTE(- you use the terminfo database) AC_DEFINE(TERMINFO),
AC_NOTE(- skipping check because we are cross compiling; assuming terminfo database is used) AC_DEFINE(TERMINFO))
@@ -861,11 +858,6 @@ fi
@@ -864,11 +861,6 @@ fi
dnl
dnl **** loadav ****
dnl

@ -4,10 +4,10 @@ Description: Unbreak several useful keybindings.
fix for nonworking ^a backspace (rhbz#708698)
diff --git a/termcap.c b/termcap.c
index 1d4724d..3270250 100644
index 26cba62..ed9e838 100644
--- a/termcap.c
+++ b/termcap.c
@@ -554,8 +554,6 @@ int map;
@@ -553,8 +553,6 @@ int map;
else
break;
}

@ -6,7 +6,7 @@ extended capability E3. This is useful to prevent an attacker to read
content of a locked terminal via Shift-PgUp key.
diff --git a/display.c b/display.c
index a4d953a..9ce34dd 100644
index d0ed6a4..7b534c0 100644
--- a/display.c
+++ b/display.c
@@ -4079,4 +4079,10 @@ char **cmdv;
@ -21,10 +21,10 @@ index a4d953a..9ce34dd 100644
+}
diff --git a/extern.h b/extern.h
index bb7d3fb..a2678e3 100644
index d4e57df..4564581 100644
--- a/extern.h
+++ b/extern.h
@@ -319,6 +319,7 @@ extern int color256to88 __P((int));
@@ -320,6 +320,7 @@ extern int color256to88 __P((int));
extern void ResetIdle __P((void));
extern void KillBlanker __P((void));
extern void DisplaySleep1000 __P((int, int));
@ -33,10 +33,10 @@ index bb7d3fb..a2678e3 100644
/* resize.c */
extern int ChangeWindowSize __P((struct win *, int, int, int));
diff --git a/screen.c b/screen.c
index c50952b..2fee7fa 100644
index 7dcb9af..c934d75 100644
--- a/screen.c
+++ b/screen.c
@@ -1950,6 +1950,7 @@ void Detach(int mode)
@@ -1952,6 +1952,7 @@ void Detach(int mode)
case D_LOCK:
ClearAll();
@ -45,7 +45,7 @@ index c50952b..2fee7fa 100644
/* tell attacher to lock terminal with a lockprg. */
break;
diff --git a/term.c b/term.c
index c92d85a..a6e9200 100644
index c7a13c9..f49b3a7 100644
--- a/term.c
+++ b/term.c
@@ -83,6 +83,7 @@ struct term term[T_N] =

@ -3,8 +3,8 @@
Summary: A screen manager that supports multiple logins on one terminal
Name: screen
Version: 4.7.0
Release: 2%{?dist}
Version: 4.8.0
Release: 1%{?dist}
License: GPLv3+
URL: http://www.gnu.org/software/screen
Requires(pre): /usr/sbin/groupadd
@ -114,6 +114,9 @@ rm -f $RPM_BUILD_ROOT%{_infodir}/dir
%endif
%changelog
* Fri Feb 07 2020 Vaclav Dolezal <vdolezal@redhat.com> - 4.8.0-1
- New upstream release 4.8.0
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 4.7.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

@ -1 +1 @@
SHA512 (screen-4.7.0.tar.gz) = 44c7a33e2ed772ce91998cdc07556ef7b972e5b100335e14702b273a234e437fe6415de459e7b6d34c6086282a432778629047424ef9159ac6fcf26d22b45745
SHA512 (screen-4.8.0.tar.gz) = 770ebaf6ee9be711bcb8a6104b3294f2bf4523dae6683fdc5eac4b3aff7e511be2d922b6b2ad28ec241113c2e4fe0d80f9a482ae1658adc19c8c3a3680caa25c

Loading…
Cancel
Save