- Remove obsoleted gst plugin

epel8
Nicolas Chauvet 15 years ago
parent 44465f6562
commit f1e0e3ba40

File diff suppressed because it is too large Load Diff

@ -1,74 +0,0 @@
--- schroedinger-1.0.8.orig/configure.ac 2009-09-29 07:23:37.000000000 +0200
+++ schroedinger-1.0.8/configure.ac 2009-04-23 05:20:57.000000000 +0200
@@ -150,6 +150,47 @@
SCHRO_CFLAGS="$SCHRO_CFLAGS -I\$(top_srcdir)"
AC_SUBST(SCHRO_CFLAGS)
+########################
+# GStreamer stuff
+########################
+
+GST_MAJORMINOR=0.10
+AC_SUBST(GST_MAJORMINOR)
+dnl *** check for arguments to configure ***
+
+if test "x$with_opengl" = xyes; then
+ GST_GL_DEP="gst-plugins-gl-0.10"
+fi
+
+AC_ARG_ENABLE(gstreamer, AC_HELP_STRING([--disable-gstreamer],
+ [disable gstreamer support (default=enabled)]))
+if test "x$enable_gstreamer" != xno
+then
+ PKG_CHECK_MODULES(GST, gstreamer-0.10 >= 0.10.19 gstreamer-base-0.10 >= 0.10.19 gstreamer-video-0.10 >= 0.10.19 ${GST_GL_DEP},
+ HAVE_GST=yes, HAVE_GST=no)
+else
+ HAVE_GST=no
+fi
+
+AM_CONDITIONAL(HAVE_GST, test "x$HAVE_GST" = "xyes")
+AC_SUBST(GST_CFLAGS)
+AC_SUBST(GST_LIBS)
+
+plugindir="\$(libdir)/gstreamer-$GST_MAJORMINOR"
+AC_SUBST(plugindir)
+
+GST_ALL_LDFLAGS="-no-undefined"
+AC_SUBST(GST_ALL_LDFLAGS)
+
+GST_PLUGIN_LDFLAGS="-module -avoid-version -export-symbols-regex '^[_]*gst_plugin_desc\$\$' $GST_ALL_LDFLAGS"
+AC_SUBST(GST_PLUGIN_LDFLAGS)
+
+AC_DEFINE(GST_PACKAGE_ORIGIN, "unknown", [Package origin in GStreamer plugin])
+
+AC_ARG_ENABLE(video-compat, AC_HELP_STRING([--disable-video-compat],
+ [disable gstvideo compatibility (default=enabled)]))
+AM_CONDITIONAL(ENABLE_VIDEO_COMPAT, test "x$enable_video_compat" != "xno")
+
########################
# Check for CUDA
@@ -238,6 +279,8 @@
schroedinger/Makefile
schroedinger/cuda/Makefile
schroedinger/opengl/Makefile
+gst-libs/gst/video/Makefile
+gst/Makefile
testsuite/Makefile
testsuite/cache/Makefile
testsuite/cuda/Makefile
--- schroedinger-1.0.8.orig/Makefile.am 2009-09-29 07:08:51.000000000 +0200
+++ schroedinger-1.0.8/Makefile.am 2009-04-22 04:35:57.000000000 +0200
@@ -4,7 +4,11 @@
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
-DIST_SUBDIRS = schroedinger doc tools testsuite
+if HAVE_GST
+SUBDIRS += gst-libs/gst/video gst
+endif
+
+DIST_SUBDIRS = schroedinger doc tools gst testsuite gst-libs/gst/video
EXTRA_DIST = COPYING COPYING.GPL COPYING.LGPL COPYING.MIT COPYING.MPL \
autogen.sh schroedinger.spec TODO NEWS

@ -2,7 +2,7 @@
Name: schroedinger
Version: 1.0.8
Release: 3%{?dist}
Release: 4%{?dist}
Summary: Portable libraries for the high quality Dirac video codec
Group: System Environment/Libraries
@ -10,17 +10,11 @@ Group: System Environment/Libraries
License: GPL+ or LGPLv2+ or MIT or MPLv1.1
URL: http://www.diracvideo.org/
Source0: http://www.diracvideo.org/download/schroedinger/schroedinger-%{version}.tar.gz
Patch0: gst-plugins-schroedinger-1.0.8.patch
Patch1: gst-plugins-schroedinger-plug.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: libtool
BuildRequires: liboil-devel >= 0.3.16
BuildRequires: glew-devel >= 1.5.1
BuildRequires: gstreamer-devel >= 0.10
BuildRequires: gstreamer-plugins-base-devel >= 0.10
BuildRequires: gtk-doc
%description
The Schrödinger project will implement portable libraries for the high
@ -42,27 +36,14 @@ Requires: liboil-devel >= 0.3.16
%description devel
Development files for schroedinger
%package -n gstreamer-plugins-schroedinger
Group: Applications/Multimedia
Summary: GStreamer Plugins that implement Dirac video encoding and decoding
%description -n gstreamer-plugins-schroedinger
GStreamer Plugins that implement Dirac video encoding and decoding
%prep
%setup -q
%patch0 -p1
%patch1 -p1 -b .plug
autoreconf -vif
%build
%configure --disable-static --enable-gtk-doc
# hack to define the package name
echo "#define GST_PACKAGE_NAME \"gst-plugins-schroedinger fedora rpm\"" >> config.h
# remove rpath from libtool
sed -i.rpath 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
sed -i.rpath 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
@ -93,13 +74,12 @@ rm -rf %{buildroot}
%{_libdir}/*.so
%{_libdir}/pkgconfig/schroedinger-%{abi}.pc
%files -n gstreamer-plugins-schroedinger
%defattr(-,root,root,-)
%{_libdir}/gstreamer-0.10/libgstschro.so
%exclude %{_libdir}/libgstbasevideo-0.10.a
%exclude %{_includedir}/gstreamer-0.10
%changelog
* Mon Feb 1 2010 Nicolas CHauvet <kwizart@fedoraproject.org> - 1.0.8-4
- Remove gstreamer-plugins-schroedinger
Obsoleted by gst-plugins-bad-free introduction in Fedora.
* Sun Oct 25 2009 kwizart < kwizart at gmail.com > - 1.0.8-3
- Re-introduce gstreamer sub-package until seen in -good

Loading…
Cancel
Save