You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
43 lines
1.4 KiB
43 lines
1.4 KiB
--- ./rustc-beta-src/src/tools/cargo/Cargo.lock.orig 2023-11-12 12:24:35.000000000 -0800
|
|
+++ rustc-beta-src/src/tools/cargo/Cargo.lock 2023-11-14 17:01:32.010125953 -0800
|
|
@@ -2027,7 +2027,6 @@
|
|
dependencies = [
|
|
"cc",
|
|
"libc",
|
|
- "libssh2-sys",
|
|
"libz-sys",
|
|
"openssl-sys",
|
|
"pkg-config",
|
|
@@ -2060,20 +2059,6 @@
|
|
]
|
|
|
|
[[package]]
|
|
-name = "libssh2-sys"
|
|
-version = "0.3.0"
|
|
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
-checksum = "2dc8a030b787e2119a731f1951d6a773e2280c660f8ec4b0f5e1505a386e71ee"
|
|
-dependencies = [
|
|
- "cc",
|
|
- "libc",
|
|
- "libz-sys",
|
|
- "openssl-sys",
|
|
- "pkg-config",
|
|
- "vcpkg",
|
|
-]
|
|
-
|
|
-[[package]]
|
|
name = "libz-sys"
|
|
version = "1.1.9"
|
|
source = "registry+https://github.com/rust-lang/crates.io-index"
|
|
--- ./rustc-beta-src/src/tools/cargo/Cargo.toml.orig 2023-11-14 17:01:32.010125953 -0800
|
|
+++ rustc-beta-src/src/tools/cargo/Cargo.toml 2023-11-14 17:02:44.645097701 -0800
|
|
@@ -40,7 +40,7 @@
|
|
curl-sys = "0.4.68"
|
|
filetime = "0.2.22"
|
|
flate2 = { version = "1.0.28", default-features = false, features = ["zlib"] }
|
|
-git2 = "0.18.1"
|
|
+git2 = { version = "0.18.1", default-features = false, features = ["https"] }
|
|
git2-curl = "0.19.0"
|
|
gix = { version = "0.55.2", default-features = false, features = ["blocking-http-transport-curl", "progress-tree", "revision"] }
|
|
gix-features-for-configuration-only = { version = "0.35.0", package = "gix-features", features = [ "parallel" ] }
|