parent
4d21e0eecc
commit
213ee834af
@ -1,2 +1,2 @@
|
||||
SOURCES/rustc-1.75.0-src.tar.xz
|
||||
SOURCES/wasi-libc-bd950eb128bff337153de217b11270f948d04bb4.tar.gz
|
||||
SOURCES/rustc-1.79.0-src.tar.xz
|
||||
SOURCES/wasi-libc-wasi-sdk-22.tar.gz
|
||||
|
@ -1,2 +1,2 @@
|
||||
9ad7bb54dc9572c103b855cdcc823addbb34d15d SOURCES/rustc-1.75.0-src.tar.xz
|
||||
55eaa32c99cc8ec970f2db2d340a605724589f9b SOURCES/wasi-libc-bd950eb128bff337153de217b11270f948d04bb4.tar.gz
|
||||
fdd94a3bdb321d18a0021d4dce9b8546a1db2eec SOURCES/rustc-1.79.0-src.tar.xz
|
||||
13451249ddb71e69f12565ef4803b71ce4092191 SOURCES/wasi-libc-wasi-sdk-22.tar.gz
|
||||
|
@ -0,0 +1,212 @@
|
||||
From 49166c7dd925244f631277b4aa9ae4233f300884 Mon Sep 17 00:00:00 2001
|
||||
From: Nilstrieb <48135649+Nilstrieb@users.noreply.github.com>
|
||||
Date: Sat, 27 Jul 2024 15:08:11 +0200
|
||||
Subject: [PATCH] Disable jump threading of float equality
|
||||
|
||||
Jump threading stores values as `u128` (`ScalarInt`) and does its
|
||||
comparisons for equality as integer comparisons.
|
||||
This works great for integers. Sadly, not everything is an integer.
|
||||
|
||||
Floats famously have wonky equality semantcs, with `NaN!=NaN` and
|
||||
`0.0 == -0.0`. This does not match our beautiful integer bitpattern
|
||||
equality and therefore causes things to go horribly wrong.
|
||||
|
||||
While jump threading could be extended to support floats by remembering
|
||||
that they're floats in the value state and handling them properly,
|
||||
it's signficantly easier to just disable it for now.
|
||||
|
||||
(cherry picked from commit eca0a7e72346ba123ace318a0f9c28c57d990aeb)
|
||||
---
|
||||
.../rustc_mir_transform/src/jump_threading.rs | 7 +++
|
||||
...ding.floats.JumpThreading.panic-abort.diff | 59 +++++++++++++++++++
|
||||
...ing.floats.JumpThreading.panic-unwind.diff | 59 +++++++++++++++++++
|
||||
tests/mir-opt/jump_threading.rs | 12 ++++
|
||||
4 files changed, 137 insertions(+)
|
||||
create mode 100644 tests/mir-opt/jump_threading.floats.JumpThreading.panic-abort.diff
|
||||
create mode 100644 tests/mir-opt/jump_threading.floats.JumpThreading.panic-unwind.diff
|
||||
|
||||
diff --git a/compiler/rustc_mir_transform/src/jump_threading.rs b/compiler/rustc_mir_transform/src/jump_threading.rs
|
||||
index a458297210db..e2d2864ad2a0 100644
|
||||
--- a/compiler/rustc_mir_transform/src/jump_threading.rs
|
||||
+++ b/compiler/rustc_mir_transform/src/jump_threading.rs
|
||||
@@ -493,6 +493,13 @@ fn process_assign(
|
||||
BinOp::Ne => ScalarInt::FALSE,
|
||||
_ => return None,
|
||||
};
|
||||
+ if value.const_.ty().is_floating_point() {
|
||||
+ // Floating point equality does not follow bit-patterns.
|
||||
+ // -0.0 and NaN both have special rules for equality,
|
||||
+ // and therefore we cannot use integer comparisons for them.
|
||||
+ // Avoid handling them, though this could be extended in the future.
|
||||
+ return None;
|
||||
+ }
|
||||
let value = value.const_.normalize(self.tcx, self.param_env).try_to_scalar_int()?;
|
||||
let conds = conditions.map(self.arena, |c| Condition {
|
||||
value,
|
||||
diff --git a/tests/mir-opt/jump_threading.floats.JumpThreading.panic-abort.diff b/tests/mir-opt/jump_threading.floats.JumpThreading.panic-abort.diff
|
||||
new file mode 100644
|
||||
index 000000000000..6ca37e96d297
|
||||
--- /dev/null
|
||||
+++ b/tests/mir-opt/jump_threading.floats.JumpThreading.panic-abort.diff
|
||||
@@ -0,0 +1,59 @@
|
||||
+- // MIR for `floats` before JumpThreading
|
||||
++ // MIR for `floats` after JumpThreading
|
||||
+
|
||||
+ fn floats() -> u32 {
|
||||
+ let mut _0: u32;
|
||||
+ let _1: f64;
|
||||
+ let mut _2: bool;
|
||||
+ let mut _3: bool;
|
||||
+ let mut _4: f64;
|
||||
+ scope 1 {
|
||||
+ debug x => _1;
|
||||
+ }
|
||||
+
|
||||
+ bb0: {
|
||||
+ StorageLive(_1);
|
||||
+ StorageLive(_2);
|
||||
+ _2 = const true;
|
||||
+- switchInt(move _2) -> [0: bb2, otherwise: bb1];
|
||||
++ goto -> bb1;
|
||||
+ }
|
||||
+
|
||||
+ bb1: {
|
||||
+ _1 = const -0f64;
|
||||
+ goto -> bb3;
|
||||
+ }
|
||||
+
|
||||
+ bb2: {
|
||||
+ _1 = const 1f64;
|
||||
+ goto -> bb3;
|
||||
+ }
|
||||
+
|
||||
+ bb3: {
|
||||
+ StorageDead(_2);
|
||||
+ StorageLive(_3);
|
||||
+ StorageLive(_4);
|
||||
+ _4 = _1;
|
||||
+ _3 = Eq(move _4, const 0f64);
|
||||
+ switchInt(move _3) -> [0: bb5, otherwise: bb4];
|
||||
+ }
|
||||
+
|
||||
+ bb4: {
|
||||
+ StorageDead(_4);
|
||||
+ _0 = const 0_u32;
|
||||
+ goto -> bb6;
|
||||
+ }
|
||||
+
|
||||
+ bb5: {
|
||||
+ StorageDead(_4);
|
||||
+ _0 = const 1_u32;
|
||||
+ goto -> bb6;
|
||||
+ }
|
||||
+
|
||||
+ bb6: {
|
||||
+ StorageDead(_3);
|
||||
+ StorageDead(_1);
|
||||
+ return;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
diff --git a/tests/mir-opt/jump_threading.floats.JumpThreading.panic-unwind.diff b/tests/mir-opt/jump_threading.floats.JumpThreading.panic-unwind.diff
|
||||
new file mode 100644
|
||||
index 000000000000..6ca37e96d297
|
||||
--- /dev/null
|
||||
+++ b/tests/mir-opt/jump_threading.floats.JumpThreading.panic-unwind.diff
|
||||
@@ -0,0 +1,59 @@
|
||||
+- // MIR for `floats` before JumpThreading
|
||||
++ // MIR for `floats` after JumpThreading
|
||||
+
|
||||
+ fn floats() -> u32 {
|
||||
+ let mut _0: u32;
|
||||
+ let _1: f64;
|
||||
+ let mut _2: bool;
|
||||
+ let mut _3: bool;
|
||||
+ let mut _4: f64;
|
||||
+ scope 1 {
|
||||
+ debug x => _1;
|
||||
+ }
|
||||
+
|
||||
+ bb0: {
|
||||
+ StorageLive(_1);
|
||||
+ StorageLive(_2);
|
||||
+ _2 = const true;
|
||||
+- switchInt(move _2) -> [0: bb2, otherwise: bb1];
|
||||
++ goto -> bb1;
|
||||
+ }
|
||||
+
|
||||
+ bb1: {
|
||||
+ _1 = const -0f64;
|
||||
+ goto -> bb3;
|
||||
+ }
|
||||
+
|
||||
+ bb2: {
|
||||
+ _1 = const 1f64;
|
||||
+ goto -> bb3;
|
||||
+ }
|
||||
+
|
||||
+ bb3: {
|
||||
+ StorageDead(_2);
|
||||
+ StorageLive(_3);
|
||||
+ StorageLive(_4);
|
||||
+ _4 = _1;
|
||||
+ _3 = Eq(move _4, const 0f64);
|
||||
+ switchInt(move _3) -> [0: bb5, otherwise: bb4];
|
||||
+ }
|
||||
+
|
||||
+ bb4: {
|
||||
+ StorageDead(_4);
|
||||
+ _0 = const 0_u32;
|
||||
+ goto -> bb6;
|
||||
+ }
|
||||
+
|
||||
+ bb5: {
|
||||
+ StorageDead(_4);
|
||||
+ _0 = const 1_u32;
|
||||
+ goto -> bb6;
|
||||
+ }
|
||||
+
|
||||
+ bb6: {
|
||||
+ StorageDead(_3);
|
||||
+ StorageDead(_1);
|
||||
+ return;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
diff --git a/tests/mir-opt/jump_threading.rs b/tests/mir-opt/jump_threading.rs
|
||||
index 57f4e4a2654f..3e7e8995f1a3 100644
|
||||
--- a/tests/mir-opt/jump_threading.rs
|
||||
+++ b/tests/mir-opt/jump_threading.rs
|
||||
@@ -514,6 +514,16 @@ fn assume(a: u8, b: bool) -> u8 {
|
||||
)
|
||||
}
|
||||
|
||||
+fn floats() -> u32 {
|
||||
+ // CHECK-LABEL: fn floats(
|
||||
+ // CHECK: switchInt(
|
||||
+
|
||||
+ // Test for issue #128243, where float equality was assumed to be bitwise.
|
||||
+ // When adding float support, it must be ensured that this continues working properly.
|
||||
+ let x = if true { -0.0 } else { 1.0 };
|
||||
+ if x == 0.0 { 0 } else { 1 }
|
||||
+}
|
||||
+
|
||||
fn main() {
|
||||
// CHECK-LABEL: fn main(
|
||||
too_complex(Ok(0));
|
||||
@@ -528,6 +538,7 @@ fn main() {
|
||||
disappearing_bb(7);
|
||||
aggregate(7);
|
||||
assume(7, false);
|
||||
+ floats();
|
||||
}
|
||||
|
||||
// EMIT_MIR jump_threading.too_complex.JumpThreading.diff
|
||||
@@ -542,3 +553,4 @@ fn main() {
|
||||
// EMIT_MIR jump_threading.disappearing_bb.JumpThreading.diff
|
||||
// EMIT_MIR jump_threading.aggregate.JumpThreading.diff
|
||||
// EMIT_MIR jump_threading.assume.JumpThreading.diff
|
||||
+// EMIT_MIR jump_threading.floats.JumpThreading.diff
|
||||
--
|
||||
2.46.0
|
||||
|
@ -0,0 +1,49 @@
|
||||
From 26fa5c2c300f3c3a3ee3109c009bd4a6803a2a4c Mon Sep 17 00:00:00 2001
|
||||
From: Nikita Popov <npopov@redhat.com>
|
||||
Date: Tue, 11 Jun 2024 10:13:07 +0200
|
||||
Subject: [PATCH] Make issue-122805.rs big endian compatible
|
||||
|
||||
Instead of not generating the function at all on big endian (which
|
||||
makes the CHECK lines fail), instead use to_le() on big endian,
|
||||
so that we essentially perform a bswap for both endiannesses.
|
||||
---
|
||||
tests/codegen/issues/issue-122805.rs | 21 ++++++++++++---------
|
||||
1 file changed, 12 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/tests/codegen/issues/issue-122805.rs b/tests/codegen/issues/issue-122805.rs
|
||||
index 6d108ada6dd..8e03c6c8884 100644
|
||||
--- a/tests/codegen/issues/issue-122805.rs
|
||||
+++ b/tests/codegen/issues/issue-122805.rs
|
||||
@@ -39,17 +39,20 @@
|
||||
// OPT3WINX64-NEXT: store <8 x i16>
|
||||
// CHECK-NEXT: ret void
|
||||
#[no_mangle]
|
||||
-#[cfg(target_endian = "little")]
|
||||
pub fn convert(value: [u16; 8]) -> [u8; 16] {
|
||||
+ #[cfg(target_endian = "little")]
|
||||
+ let bswap = u16::to_be;
|
||||
+ #[cfg(target_endian = "big")]
|
||||
+ let bswap = u16::to_le;
|
||||
let addr16 = [
|
||||
- value[0].to_be(),
|
||||
- value[1].to_be(),
|
||||
- value[2].to_be(),
|
||||
- value[3].to_be(),
|
||||
- value[4].to_be(),
|
||||
- value[5].to_be(),
|
||||
- value[6].to_be(),
|
||||
- value[7].to_be(),
|
||||
+ bswap(value[0]),
|
||||
+ bswap(value[1]),
|
||||
+ bswap(value[2]),
|
||||
+ bswap(value[3]),
|
||||
+ bswap(value[4]),
|
||||
+ bswap(value[5]),
|
||||
+ bswap(value[6]),
|
||||
+ bswap(value[7]),
|
||||
];
|
||||
unsafe { core::mem::transmute::<_, [u8; 16]>(addr16) }
|
||||
}
|
||||
--
|
||||
2.45.1
|
||||
|
@ -0,0 +1,264 @@
|
||||
From 706f06c39a9e08a4708a53722429d13ae4069c2f Mon Sep 17 00:00:00 2001
|
||||
From: Josh Stone <jistone@redhat.com>
|
||||
Date: Wed, 1 May 2024 15:25:26 -0700
|
||||
Subject: [PATCH] Use an explicit x86-64 cpu in tests that are sensitive to it
|
||||
|
||||
There are a few tests that depend on some target features **not** being
|
||||
enabled by default, and usually they are correct with the default x86-64
|
||||
target CPU. However, in downstream builds we have modified the default
|
||||
to fit our distros -- `x86-64-v2` in RHEL 9 and `x86-64-v3` in RHEL 10
|
||||
-- and the latter especially trips tests that expect not to have AVX.
|
||||
|
||||
These cases are few enough that we can just set them back explicitly.
|
||||
---
|
||||
tests/assembly/simd-intrinsic-mask-reduce.rs | 1 +
|
||||
tests/assembly/x86_64-floating-point-clamp.rs | 2 +-
|
||||
.../codegen/target-feature-inline-closure.rs | 2 +-
|
||||
tests/ui/asm/x86_64/target-feature-attr.rs | 1 +
|
||||
.../ui/asm/x86_64/target-feature-attr.stderr | 8 +++---
|
||||
.../const-eval/const_fn_target_feature.rs | 2 +-
|
||||
.../rfc-2396-target_feature-11/safe-calls.rs | 1 +
|
||||
.../safe-calls.stderr | 28 +++++++++----------
|
||||
tests/ui/sse2.rs | 4 +--
|
||||
9 files changed, 26 insertions(+), 23 deletions(-)
|
||||
|
||||
diff --git a/tests/assembly/simd-intrinsic-mask-reduce.rs b/tests/assembly/simd-intrinsic-mask-reduce.rs
|
||||
index 763401755fad..0d77fc410511 100644
|
||||
--- a/tests/assembly/simd-intrinsic-mask-reduce.rs
|
||||
+++ b/tests/assembly/simd-intrinsic-mask-reduce.rs
|
||||
@@ -1,6 +1,7 @@
|
||||
// verify that simd mask reductions do not introduce additional bit shift operations
|
||||
//@ revisions: x86 aarch64
|
||||
//@ [x86] compile-flags: --target=x86_64-unknown-linux-gnu -C llvm-args=-x86-asm-syntax=intel
|
||||
+//@ [x86] compile-flags: -C target-cpu=x86-64
|
||||
//@ [x86] needs-llvm-components: x86
|
||||
//@ [aarch64] compile-flags: --target=aarch64-unknown-linux-gnu
|
||||
//@ [aarch64] needs-llvm-components: aarch64
|
||||
diff --git a/tests/assembly/x86_64-floating-point-clamp.rs b/tests/assembly/x86_64-floating-point-clamp.rs
|
||||
index 4a72a7f44fa0..b963aee35590 100644
|
||||
--- a/tests/assembly/x86_64-floating-point-clamp.rs
|
||||
+++ b/tests/assembly/x86_64-floating-point-clamp.rs
|
||||
@@ -2,7 +2,7 @@
|
||||
// so check to make sure that's what it's actually emitting.
|
||||
|
||||
//@ assembly-output: emit-asm
|
||||
-//@ compile-flags: --crate-type=lib -O -C llvm-args=-x86-asm-syntax=intel
|
||||
+//@ compile-flags: --crate-type=lib -O -C llvm-args=-x86-asm-syntax=intel -C target-cpu=x86-64
|
||||
//@ only-x86_64
|
||||
//@ ignore-sgx
|
||||
|
||||
diff --git a/tests/codegen/target-feature-inline-closure.rs b/tests/codegen/target-feature-inline-closure.rs
|
||||
index 88bd413a8707..20bb4e66ff21 100644
|
||||
--- a/tests/codegen/target-feature-inline-closure.rs
|
||||
+++ b/tests/codegen/target-feature-inline-closure.rs
|
||||
@@ -1,5 +1,5 @@
|
||||
//@ only-x86_64
|
||||
-//@ compile-flags: -Copt-level=3
|
||||
+//@ compile-flags: -Copt-level=3 -Ctarget-cpu=x86-64
|
||||
|
||||
#![crate_type = "lib"]
|
||||
#![feature(target_feature_11)]
|
||||
diff --git a/tests/ui/asm/x86_64/target-feature-attr.rs b/tests/ui/asm/x86_64/target-feature-attr.rs
|
||||
index 820be132ef79..51829be15065 100644
|
||||
--- a/tests/ui/asm/x86_64/target-feature-attr.rs
|
||||
+++ b/tests/ui/asm/x86_64/target-feature-attr.rs
|
||||
@@ -1,4 +1,5 @@
|
||||
//@ only-x86_64
|
||||
+//@ compile-flags: -C target-cpu=x86-64
|
||||
|
||||
#![feature(avx512_target_feature)]
|
||||
|
||||
diff --git a/tests/ui/asm/x86_64/target-feature-attr.stderr b/tests/ui/asm/x86_64/target-feature-attr.stderr
|
||||
index c852726ee7ff..1a9962732cfb 100644
|
||||
--- a/tests/ui/asm/x86_64/target-feature-attr.stderr
|
||||
+++ b/tests/ui/asm/x86_64/target-feature-attr.stderr
|
||||
@@ -1,23 +1,23 @@
|
||||
error: register class `ymm_reg` requires the `avx` target feature
|
||||
- --> $DIR/target-feature-attr.rs:18:40
|
||||
+ --> $DIR/target-feature-attr.rs:19:40
|
||||
|
|
||||
LL | asm!("vaddps {2:y}, {0:y}, {1:y}", in(ymm_reg) x, in(ymm_reg) y, lateout(ymm_reg) x);
|
||||
| ^^^^^^^^^^^^^
|
||||
|
||||
error: register class `ymm_reg` requires the `avx` target feature
|
||||
- --> $DIR/target-feature-attr.rs:18:55
|
||||
+ --> $DIR/target-feature-attr.rs:19:55
|
||||
|
|
||||
LL | asm!("vaddps {2:y}, {0:y}, {1:y}", in(ymm_reg) x, in(ymm_reg) y, lateout(ymm_reg) x);
|
||||
| ^^^^^^^^^^^^^
|
||||
|
||||
error: register class `ymm_reg` requires the `avx` target feature
|
||||
- --> $DIR/target-feature-attr.rs:18:70
|
||||
+ --> $DIR/target-feature-attr.rs:19:70
|
||||
|
|
||||
LL | asm!("vaddps {2:y}, {0:y}, {1:y}", in(ymm_reg) x, in(ymm_reg) y, lateout(ymm_reg) x);
|
||||
| ^^^^^^^^^^^^^^^^^^
|
||||
|
||||
error: register class `kreg` requires at least one of the following target features: avx512bw, avx512f
|
||||
- --> $DIR/target-feature-attr.rs:33:23
|
||||
+ --> $DIR/target-feature-attr.rs:34:23
|
||||
|
|
||||
LL | asm!("/* {0} */", in(kreg) x);
|
||||
| ^^^^^^^^^^
|
||||
diff --git a/tests/ui/consts/const-eval/const_fn_target_feature.rs b/tests/ui/consts/const-eval/const_fn_target_feature.rs
|
||||
index b56b68a57958..d0de9d8d7a34 100644
|
||||
--- a/tests/ui/consts/const-eval/const_fn_target_feature.rs
|
||||
+++ b/tests/ui/consts/const-eval/const_fn_target_feature.rs
|
||||
@@ -1,5 +1,5 @@
|
||||
//@ only-x86_64
|
||||
-//@ compile-flags:-C target-feature=+ssse3
|
||||
+//@ compile-flags: -C target-cpu=x86-64 -C target-feature=+ssse3
|
||||
|
||||
#![crate_type = "lib"]
|
||||
|
||||
diff --git a/tests/ui/rfcs/rfc-2396-target_feature-11/safe-calls.rs b/tests/ui/rfcs/rfc-2396-target_feature-11/safe-calls.rs
|
||||
index c73b8d7e4d29..6fb0688008e6 100644
|
||||
--- a/tests/ui/rfcs/rfc-2396-target_feature-11/safe-calls.rs
|
||||
+++ b/tests/ui/rfcs/rfc-2396-target_feature-11/safe-calls.rs
|
||||
@@ -1,4 +1,5 @@
|
||||
//@ only-x86_64
|
||||
+//@ compile-flags: -C target-cpu=x86-64
|
||||
|
||||
#![feature(target_feature_11)]
|
||||
|
||||
diff --git a/tests/ui/rfcs/rfc-2396-target_feature-11/safe-calls.stderr b/tests/ui/rfcs/rfc-2396-target_feature-11/safe-calls.stderr
|
||||
index d9d7e297f8e9..fed3da6594cb 100644
|
||||
--- a/tests/ui/rfcs/rfc-2396-target_feature-11/safe-calls.stderr
|
||||
+++ b/tests/ui/rfcs/rfc-2396-target_feature-11/safe-calls.stderr
|
||||
@@ -1,5 +1,5 @@
|
||||
error[E0133]: call to function `sse2` with `#[target_feature]` is unsafe and requires unsafe function or block
|
||||
- --> $DIR/safe-calls.rs:25:5
|
||||
+ --> $DIR/safe-calls.rs:26:5
|
||||
|
|
||||
LL | sse2();
|
||||
| ^^^^^^ call to function with `#[target_feature]`
|
||||
@@ -8,7 +8,7 @@ LL | sse2();
|
||||
= note: the sse2 target feature being enabled in the build configuration does not remove the requirement to list it in `#[target_feature]`
|
||||
|
||||
error[E0133]: call to function `avx_bmi2` with `#[target_feature]` is unsafe and requires unsafe function or block
|
||||
- --> $DIR/safe-calls.rs:27:5
|
||||
+ --> $DIR/safe-calls.rs:28:5
|
||||
|
|
||||
LL | avx_bmi2();
|
||||
| ^^^^^^^^^^ call to function with `#[target_feature]`
|
||||
@@ -16,7 +16,7 @@ LL | avx_bmi2();
|
||||
= help: in order for the call to be safe, the context requires the following additional target features: avx and bmi2
|
||||
|
||||
error[E0133]: call to function `Quux::avx_bmi2` with `#[target_feature]` is unsafe and requires unsafe function or block
|
||||
- --> $DIR/safe-calls.rs:29:5
|
||||
+ --> $DIR/safe-calls.rs:30:5
|
||||
|
|
||||
LL | Quux.avx_bmi2();
|
||||
| ^^^^^^^^^^^^^^^ call to function with `#[target_feature]`
|
||||
@@ -24,7 +24,7 @@ LL | Quux.avx_bmi2();
|
||||
= help: in order for the call to be safe, the context requires the following additional target features: avx and bmi2
|
||||
|
||||
error[E0133]: call to function `avx_bmi2` with `#[target_feature]` is unsafe and requires unsafe function or block
|
||||
- --> $DIR/safe-calls.rs:35:5
|
||||
+ --> $DIR/safe-calls.rs:36:5
|
||||
|
|
||||
LL | avx_bmi2();
|
||||
| ^^^^^^^^^^ call to function with `#[target_feature]`
|
||||
@@ -32,7 +32,7 @@ LL | avx_bmi2();
|
||||
= help: in order for the call to be safe, the context requires the following additional target features: avx and bmi2
|
||||
|
||||
error[E0133]: call to function `Quux::avx_bmi2` with `#[target_feature]` is unsafe and requires unsafe function or block
|
||||
- --> $DIR/safe-calls.rs:37:5
|
||||
+ --> $DIR/safe-calls.rs:38:5
|
||||
|
|
||||
LL | Quux.avx_bmi2();
|
||||
| ^^^^^^^^^^^^^^^ call to function with `#[target_feature]`
|
||||
@@ -40,7 +40,7 @@ LL | Quux.avx_bmi2();
|
||||
= help: in order for the call to be safe, the context requires the following additional target features: avx and bmi2
|
||||
|
||||
error[E0133]: call to function `sse2` with `#[target_feature]` is unsafe and requires unsafe function or block
|
||||
- --> $DIR/safe-calls.rs:43:5
|
||||
+ --> $DIR/safe-calls.rs:44:5
|
||||
|
|
||||
LL | sse2();
|
||||
| ^^^^^^ call to function with `#[target_feature]`
|
||||
@@ -49,7 +49,7 @@ LL | sse2();
|
||||
= note: the sse2 target feature being enabled in the build configuration does not remove the requirement to list it in `#[target_feature]`
|
||||
|
||||
error[E0133]: call to function `avx_bmi2` with `#[target_feature]` is unsafe and requires unsafe function or block
|
||||
- --> $DIR/safe-calls.rs:45:5
|
||||
+ --> $DIR/safe-calls.rs:46:5
|
||||
|
|
||||
LL | avx_bmi2();
|
||||
| ^^^^^^^^^^ call to function with `#[target_feature]`
|
||||
@@ -57,7 +57,7 @@ LL | avx_bmi2();
|
||||
= help: in order for the call to be safe, the context requires the following additional target feature: bmi2
|
||||
|
||||
error[E0133]: call to function `Quux::avx_bmi2` with `#[target_feature]` is unsafe and requires unsafe function or block
|
||||
- --> $DIR/safe-calls.rs:47:5
|
||||
+ --> $DIR/safe-calls.rs:48:5
|
||||
|
|
||||
LL | Quux.avx_bmi2();
|
||||
| ^^^^^^^^^^^^^^^ call to function with `#[target_feature]`
|
||||
@@ -65,7 +65,7 @@ LL | Quux.avx_bmi2();
|
||||
= help: in order for the call to be safe, the context requires the following additional target feature: bmi2
|
||||
|
||||
error[E0133]: call to function `sse2` with `#[target_feature]` is unsafe and requires unsafe function or block
|
||||
- --> $DIR/safe-calls.rs:54:5
|
||||
+ --> $DIR/safe-calls.rs:55:5
|
||||
|
|
||||
LL | sse2();
|
||||
| ^^^^^^ call to function with `#[target_feature]`
|
||||
@@ -74,7 +74,7 @@ LL | sse2();
|
||||
= note: the sse2 target feature being enabled in the build configuration does not remove the requirement to list it in `#[target_feature]`
|
||||
|
||||
error[E0133]: call to function `sse2` with `#[target_feature]` is unsafe and requires unsafe function or block
|
||||
- --> $DIR/safe-calls.rs:58:15
|
||||
+ --> $DIR/safe-calls.rs:59:15
|
||||
|
|
||||
LL | const _: () = sse2();
|
||||
| ^^^^^^ call to function with `#[target_feature]`
|
||||
@@ -83,7 +83,7 @@ LL | const _: () = sse2();
|
||||
= note: the sse2 target feature being enabled in the build configuration does not remove the requirement to list it in `#[target_feature]`
|
||||
|
||||
error[E0133]: call to function `sse2_and_fxsr` with `#[target_feature]` is unsafe and requires unsafe function or block
|
||||
- --> $DIR/safe-calls.rs:61:15
|
||||
+ --> $DIR/safe-calls.rs:62:15
|
||||
|
|
||||
LL | const _: () = sse2_and_fxsr();
|
||||
| ^^^^^^^^^^^^^^^ call to function with `#[target_feature]`
|
||||
@@ -92,7 +92,7 @@ LL | const _: () = sse2_and_fxsr();
|
||||
= note: the fxsr and sse2 target features being enabled in the build configuration does not remove the requirement to list them in `#[target_feature]`
|
||||
|
||||
error: call to function `sse2` with `#[target_feature]` is unsafe and requires unsafe block (error E0133)
|
||||
- --> $DIR/safe-calls.rs:68:5
|
||||
+ --> $DIR/safe-calls.rs:69:5
|
||||
|
|
||||
LL | sse2();
|
||||
| ^^^^^^ call to function with `#[target_feature]`
|
||||
@@ -101,12 +101,12 @@ LL | sse2();
|
||||
= help: in order for the call to be safe, the context requires the following additional target feature: sse2
|
||||
= note: the sse2 target feature being enabled in the build configuration does not remove the requirement to list it in `#[target_feature]`
|
||||
note: an unsafe function restricts its caller, but its body is safe by default
|
||||
- --> $DIR/safe-calls.rs:67:1
|
||||
+ --> $DIR/safe-calls.rs:68:1
|
||||
|
|
||||
LL | unsafe fn needs_unsafe_block() {
|
||||
| ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
|
||||
note: the lint level is defined here
|
||||
- --> $DIR/safe-calls.rs:64:8
|
||||
+ --> $DIR/safe-calls.rs:65:8
|
||||
|
|
||||
LL | #[deny(unsafe_op_in_unsafe_fn)]
|
||||
| ^^^^^^^^^^^^^^^^^^^^^^
|
||||
diff --git a/tests/ui/sse2.rs b/tests/ui/sse2.rs
|
||||
index fa6d79713b4b..c203ca2716ff 100644
|
||||
--- a/tests/ui/sse2.rs
|
||||
+++ b/tests/ui/sse2.rs
|
||||
@@ -20,6 +20,6 @@ fn main() {
|
||||
"SSE2 was not detected as available on an x86 platform");
|
||||
}
|
||||
// check a negative case too -- allowed on x86, but not enabled by default
|
||||
- assert!(cfg!(not(target_feature = "avx2")),
|
||||
- "AVX2 shouldn't be detected as available by default on any platform");
|
||||
+ assert!(cfg!(not(target_feature = "avx512f")),
|
||||
+ "AVX512 shouldn't be detected as available by default on any platform");
|
||||
}
|
||||
--
|
||||
2.44.0
|
||||
|
@ -1,33 +0,0 @@
|
||||
From 776146e9ebb6bbe17a37bfad955f3dac95317275 Mon Sep 17 00:00:00 2001
|
||||
From: Josh Stone <jistone@redhat.com>
|
||||
Date: Thu, 16 Nov 2023 10:42:23 -0800
|
||||
Subject: [PATCH] bootstrap: only show PGO warnings when verbose
|
||||
|
||||
Building rustc with `--rust-profile-use` is currently dumping a lot of
|
||||
warnings of "no profile data available for function" from `rustc_smir`
|
||||
and `stable_mir`. These simply aren't exercised by the current profile-
|
||||
gathering steps, but that's to be expected for new or experimental
|
||||
functionality. I think for most people, these warnings will be just
|
||||
noise, so it makes sense to only have them in verbose builds.
|
||||
---
|
||||
src/bootstrap/src/core/build_steps/compile.rs | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/bootstrap/src/core/build_steps/compile.rs b/src/bootstrap/src/core/build_steps/compile.rs
|
||||
index af69860df1c5..51e4195827fc 100644
|
||||
--- a/src/bootstrap/src/core/build_steps/compile.rs
|
||||
+++ b/src/bootstrap/src/core/build_steps/compile.rs
|
||||
@@ -887,7 +887,9 @@ fn run(self, builder: &Builder<'_>) {
|
||||
} else if let Some(path) = &builder.config.rust_profile_use {
|
||||
if compiler.stage == 1 {
|
||||
cargo.rustflag(&format!("-Cprofile-use={path}"));
|
||||
- cargo.rustflag("-Cllvm-args=-pgo-warn-missing-function");
|
||||
+ if builder.is_verbose() {
|
||||
+ cargo.rustflag("-Cllvm-args=-pgo-warn-missing-function");
|
||||
+ }
|
||||
true
|
||||
} else {
|
||||
false
|
||||
--
|
||||
2.43.0
|
||||
|
@ -0,0 +1,2 @@
|
||||
%__cargo_vendor_path ^%{_defaultlicensedir}(/[^/]+)+/cargo-vendor.txt$
|
||||
%__cargo_vendor_provides %{_rpmconfigdir}/cargo_vendor.prov
|
@ -0,0 +1,127 @@
|
||||
#! /usr/bin/python3 -s
|
||||
# Stripped down replacement for cargo2rpm parse-vendor-manifest
|
||||
|
||||
import re
|
||||
import subprocess
|
||||
import sys
|
||||
from typing import Optional
|
||||
|
||||
|
||||
VERSION_REGEX = re.compile(
|
||||
r"""
|
||||
^
|
||||
(?P<major>0|[1-9]\d*)
|
||||
\.(?P<minor>0|[1-9]\d*)
|
||||
\.(?P<patch>0|[1-9]\d*)
|
||||
(?:-(?P<pre>(?:0|[1-9]\d*|\d*[a-zA-Z-][0-9a-zA-Z-]*)(?:\.(?:0|[1-9]\d*|\d*[a-zA-Z-][0-9a-zA-Z-]*))*))?
|
||||
(?:\+(?P<build>[0-9a-zA-Z-]+(?:\.[0-9a-zA-Z-]+)*))?$
|
||||
""",
|
||||
re.VERBOSE,
|
||||
)
|
||||
|
||||
|
||||
class Version:
|
||||
"""
|
||||
Version that adheres to the "semantic versioning" format.
|
||||
"""
|
||||
|
||||
def __init__(self, major: int, minor: int, patch: int, pre: Optional[str] = None, build: Optional[str] = None):
|
||||
self.major: int = major
|
||||
self.minor: int = minor
|
||||
self.patch: int = patch
|
||||
self.pre: Optional[str] = pre
|
||||
self.build: Optional[str] = build
|
||||
|
||||
@staticmethod
|
||||
def parse(version: str) -> "Version":
|
||||
"""
|
||||
Parses a version string and return a `Version` object.
|
||||
Raises a `ValueError` if the string does not match the expected format.
|
||||
"""
|
||||
|
||||
match = VERSION_REGEX.match(version)
|
||||
if not match:
|
||||
raise ValueError(f"Invalid version: {version!r}")
|
||||
|
||||
matches = match.groupdict()
|
||||
|
||||
major_str = matches["major"]
|
||||
minor_str = matches["minor"]
|
||||
patch_str = matches["patch"]
|
||||
pre = matches["pre"]
|
||||
build = matches["build"]
|
||||
|
||||
major = int(major_str)
|
||||
minor = int(minor_str)
|
||||
patch = int(patch_str)
|
||||
|
||||
return Version(major, minor, patch, pre, build)
|
||||
|
||||
def to_rpm(self) -> str:
|
||||
"""
|
||||
Formats the `Version` object as an equivalent RPM version string.
|
||||
Characters that are invalid in RPM versions are replaced ("-" -> "_")
|
||||
|
||||
Build metadata (the optional `Version.build` attribute) is dropped, so
|
||||
the conversion is not lossless for versions where this attribute is not
|
||||
`None`. However, build metadata is not intended to be part of the
|
||||
version (and is not even considered when doing version comparison), so
|
||||
dropping it when converting to the RPM version format is correct.
|
||||
"""
|
||||
|
||||
s = f"{self.major}.{self.minor}.{self.patch}"
|
||||
if self.pre:
|
||||
s += f"~{self.pre.replace('-', '_')}"
|
||||
return s
|
||||
|
||||
|
||||
def break_the_build(error: str):
|
||||
"""
|
||||
This function writes a string that is an invalid RPM dependency specifier,
|
||||
which causes dependency generators to fail and break the build. The
|
||||
additional error message is printed to stderr.
|
||||
"""
|
||||
|
||||
print("*** FATAL ERROR ***")
|
||||
print(error, file=sys.stderr)
|
||||
|
||||
|
||||
def get_cargo_vendor_txt_paths_from_stdin() -> set[str]: # pragma nocover
|
||||
"""
|
||||
Read lines from standard input and filter out lines that look like paths
|
||||
to `cargo-vendor.txt` files. This is how RPM generators pass lists of files.
|
||||
"""
|
||||
|
||||
lines = {line.rstrip("\n") for line in sys.stdin.readlines()}
|
||||
return {line for line in lines if line.endswith("/cargo-vendor.txt")}
|
||||
|
||||
|
||||
def action_parse_vendor_manifest():
|
||||
paths = get_cargo_vendor_txt_paths_from_stdin()
|
||||
|
||||
for path in paths:
|
||||
with open(path) as file:
|
||||
manifest = file.read()
|
||||
|
||||
for line in manifest.strip().splitlines():
|
||||
crate, version = line.split(" v")
|
||||
print(f"bundled(crate({crate})) = {Version.parse(version).to_rpm()}")
|
||||
|
||||
|
||||
def main():
|
||||
try:
|
||||
action_parse_vendor_manifest()
|
||||
exit(0)
|
||||
|
||||
# print an error message that is not a valid RPM dependency
|
||||
# to cause the generator to break the build
|
||||
except (IOError, ValueError) as exc:
|
||||
break_the_build(str(exc))
|
||||
exit(1)
|
||||
|
||||
break_the_build("Uncaught exception: This should not happen, please report a bug.")
|
||||
exit(1)
|
||||
|
||||
|
||||
if __name__ == "__main__":
|
||||
main()
|
@ -1,42 +0,0 @@
|
||||
--- ./rustc-beta-src/src/tools/cargo/Cargo.lock.orig 2023-11-12 12:24:35.000000000 -0800
|
||||
+++ rustc-beta-src/src/tools/cargo/Cargo.lock 2023-11-14 17:01:32.010125953 -0800
|
||||
@@ -2027,7 +2027,6 @@
|
||||
dependencies = [
|
||||
"cc",
|
||||
"libc",
|
||||
- "libssh2-sys",
|
||||
"libz-sys",
|
||||
"openssl-sys",
|
||||
"pkg-config",
|
||||
@@ -2060,20 +2059,6 @@
|
||||
]
|
||||
|
||||
[[package]]
|
||||
-name = "libssh2-sys"
|
||||
-version = "0.3.0"
|
||||
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-checksum = "2dc8a030b787e2119a731f1951d6a773e2280c660f8ec4b0f5e1505a386e71ee"
|
||||
-dependencies = [
|
||||
- "cc",
|
||||
- "libc",
|
||||
- "libz-sys",
|
||||
- "openssl-sys",
|
||||
- "pkg-config",
|
||||
- "vcpkg",
|
||||
-]
|
||||
-
|
||||
-[[package]]
|
||||
name = "libz-sys"
|
||||
version = "1.1.9"
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
--- ./rustc-beta-src/src/tools/cargo/Cargo.toml.orig 2023-11-14 17:01:32.010125953 -0800
|
||||
+++ rustc-beta-src/src/tools/cargo/Cargo.toml 2023-11-14 17:02:44.645097701 -0800
|
||||
@@ -40,7 +40,7 @@
|
||||
curl-sys = "0.4.68"
|
||||
filetime = "0.2.22"
|
||||
flate2 = { version = "1.0.28", default-features = false, features = ["zlib"] }
|
||||
-git2 = "0.18.1"
|
||||
+git2 = { version = "0.18.1", default-features = false, features = ["https"] }
|
||||
git2-curl = "0.19.0"
|
||||
gix = { version = "0.55.2", default-features = false, features = ["blocking-http-transport-curl", "progress-tree", "revision"] }
|
||||
gix-features-for-configuration-only = { version = "0.35.0", package = "gix-features", features = [ "parallel" ] }
|
@ -0,0 +1,44 @@
|
||||
diff -up rustc-1.79.0-src/src/tools/cargo/Cargo.lock.orig rustc-1.79.0-src/src/tools/cargo/Cargo.lock
|
||||
--- rustc-1.79.0-src/src/tools/cargo/Cargo.lock.orig 2024-06-13 16:37:16.640599290 -0700
|
||||
+++ rustc-1.79.0-src/src/tools/cargo/Cargo.lock 2024-06-13 16:37:16.646599231 -0700
|
||||
@@ -2150,7 +2150,6 @@ checksum = "ee4126d8b4ee5c9d9ea891dd875c
|
||||
dependencies = [
|
||||
"cc",
|
||||
"libc",
|
||||
- "libssh2-sys",
|
||||
"libz-sys",
|
||||
"openssl-sys",
|
||||
"pkg-config",
|
||||
@@ -2191,20 +2190,6 @@ dependencies = [
|
||||
"pkg-config",
|
||||
"vcpkg",
|
||||
]
|
||||
-
|
||||
-[[package]]
|
||||
-name = "libssh2-sys"
|
||||
-version = "0.3.0"
|
||||
-source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
-checksum = "2dc8a030b787e2119a731f1951d6a773e2280c660f8ec4b0f5e1505a386e71ee"
|
||||
-dependencies = [
|
||||
- "cc",
|
||||
- "libc",
|
||||
- "libz-sys",
|
||||
- "openssl-sys",
|
||||
- "pkg-config",
|
||||
- "vcpkg",
|
||||
-]
|
||||
|
||||
[[package]]
|
||||
name = "libz-sys"
|
||||
diff -up rustc-1.79.0-src/src/tools/cargo/Cargo.toml.orig rustc-1.79.0-src/src/tools/cargo/Cargo.toml
|
||||
--- rustc-1.79.0-src/src/tools/cargo/Cargo.toml.orig 2024-06-13 16:37:16.646599231 -0700
|
||||
+++ rustc-1.79.0-src/src/tools/cargo/Cargo.toml 2024-06-13 16:39:06.040526596 -0700
|
||||
@@ -44,7 +44,7 @@ curl = "0.4.46"
|
||||
curl-sys = "0.4.72"
|
||||
filetime = "0.2.23"
|
||||
flate2 = { version = "1.0.28", default-features = false, features = ["zlib"] }
|
||||
-git2 = "0.18.3"
|
||||
+git2 = { version = "0.18.3", default-features = false, features = ["https"] }
|
||||
git2-curl = "0.19.0"
|
||||
gix = { version = "0.63.0", default-features = false, features = ["blocking-http-transport-curl", "progress-tree", "revision", "parallel", "dirwalk"] }
|
||||
glob = "0.3.1"
|
@ -0,0 +1,23 @@
|
||||
diff -up rustc-beta-src/src/tools/cargo/Cargo.lock.orig rustc-beta-src/src/tools/cargo/Cargo.lock
|
||||
--- rustc-beta-src/src/tools/cargo/Cargo.lock.orig 2006-07-24 10:21:28.000000000 +0900
|
||||
+++ rustc-beta-src/src/tools/cargo/Cargo.lock 2024-05-06 14:13:00.172595245 +0900
|
||||
@@ -2191,7 +2191,6 @@ version = "0.28.0"
|
||||
source = "registry+https://github.com/rust-lang/crates.io-index"
|
||||
checksum = "0c10584274047cb335c23d3e61bcef8e323adae7c5c8c760540f73610177fc3f"
|
||||
dependencies = [
|
||||
- "cc",
|
||||
"pkg-config",
|
||||
"vcpkg",
|
||||
]
|
||||
diff -up rustc-beta-src/src/tools/cargo/Cargo.toml.orig rustc-beta-src/src/tools/cargo/Cargo.toml
|
||||
--- rustc-beta-src/src/tools/cargo/Cargo.toml.orig 2024-05-06 14:13:00.173595257 +0900
|
||||
+++ rustc-beta-src/src/tools/cargo/Cargo.toml 2024-05-06 14:13:54.089275003 +0900
|
||||
@@ -77,7 +77,7 @@ proptest = "1.4.0"
|
||||
pulldown-cmark = { version = "0.10.2", default-features = false, features = ["html"] }
|
||||
rand = "0.8.5"
|
||||
regex = "1.10.4"
|
||||
-rusqlite = { version = "0.31.0", features = ["bundled"] }
|
||||
+rusqlite = { version = "0.31.0", features = [] }
|
||||
rustfix = { version = "0.8.2", path = "crates/rustfix" }
|
||||
same-file = "1.0.6"
|
||||
security-framework = "2.10.0"
|
Loading…
Reference in new issue