You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-zune-jpeg/rust-zune-jpeg.spec

129 lines
3.3 KiB

# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate zune-jpeg
Name: rust-zune-jpeg
Version: 0.4.13
Release: %autorelease
Summary: Fast, correct and safe jpeg decoder
License: MIT OR Apache-2.0 OR Zlib
URL: https://crates.io/crates/zune-jpeg
Source: %{crates_source}
# https://github.com/etemesi254/zune-image/pull/206 (merged)
Source7: https://github.com/etemesi254/zune-image/raw/24603fe/LICENSE-APACHE
Source8: https://github.com/etemesi254/zune-image/raw/24603fe/LICENSE-MIT
Source9: https://github.com/etemesi254/zune-image/raw/24603fe/LICENSE-ZLIB
# Manually created patch for downstream crate metadata changes
# * drop build target for C-ABI shared object
Patch: zune-jpeg-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A fast, correct and safe jpeg decoder.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%license %{crate_instdir}/LICENSE-ZLIB
%doc %{crate_instdir}/Benches.md
%doc %{crate_instdir}/Changelog.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+log-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+log-devel %{_description}
This package contains library source intended for building other packages which
use the "log" feature of the "%{crate}" crate.
%files -n %{name}+log-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+neon-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+neon-devel %{_description}
This package contains library source intended for building other packages which
use the "neon" feature of the "%{crate}" crate.
%files -n %{name}+neon-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+x86-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+x86-devel %{_description}
This package contains library source intended for building other packages which
use the "x86" feature of the "%{crate}" crate.
%files -n %{name}+x86-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
cp -pav %{SOURCE7} %{SOURCE8} %{SOURCE9} .
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog