You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-zune-inflate/rust-zune-inflate.spec

125 lines
3.2 KiB

# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate zune-inflate
Name: rust-zune-inflate
Version: 0.2.54
Release: %autorelease
Summary: Heavily optimized deflate decompressor in Pure Rust
License: MIT OR Apache-2.0 OR Zlib
URL: https://crates.io/crates/zune-inflate
Source: %{crates_source}
# https://github.com/etemesi254/zune-image/pull/206 (merged)
Source7: https://github.com/etemesi254/zune-image/raw/24603fe/LICENSE-APACHE
Source8: https://github.com/etemesi254/zune-image/raw/24603fe/LICENSE-MIT
Source9: https://github.com/etemesi254/zune-image/raw/24603fe/LICENSE-ZLIB
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A heavily optimized deflate decompressor in Pure Rust.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%license %{crate_instdir}/LICENSE-ZLIB
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+gzip-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+gzip-devel %{_description}
This package contains library source intended for building other packages which
use the "gzip" feature of the "%{crate}" crate.
%files -n %{name}+gzip-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+simd-adler32-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+simd-adler32-devel %{_description}
This package contains library source intended for building other packages which
use the "simd-adler32" feature of the "%{crate}" crate.
%files -n %{name}+simd-adler32-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zlib-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+zlib-devel %{_description}
This package contains library source intended for building other packages which
use the "zlib" feature of the "%{crate}" crate.
%files -n %{name}+zlib-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
cp -pav %{SOURCE7} %{SOURCE8} %{SOURCE9} .
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog