Update to version 0.12.3+zstd.1.5.2; Fixes RHBZ#2145248

epel9
Fabio Valentini 2 years ago
parent 46e16b357c
commit 96d1db5d09
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -7,3 +7,4 @@
/zstd-0.9.2+zstd.1.5.1.crate
/zstd-0.10.0+zstd.1.5.2.crate
/zstd-0.11.2+zstd.1.5.2.crate
/zstd-0.12.3+zstd.1.5.2.crate

@ -1,3 +0,0 @@
# rust-zstd
The rust-zstd package

@ -1,13 +1,13 @@
# Generated by rust2rpm 22
# Generated by rust2rpm 24
# * tests require files that are not included in published crates
%bcond_with check
%global debug_package %{nil}
%global crate zstd
%global upstream_version 0.11.2+zstd.1.5.2
%global upstream_version 0.12.3+zstd.1.5.2
Name: rust-zstd
Version: 0.11.2
Version: 0.12.3
Release: %autorelease
Summary: Binding for the zstd compression library
@ -19,8 +19,6 @@ Source: %{crates_source %{crate} %{upstream_version}}
# * exclude development-only files
Patch: zstd-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
@ -114,6 +112,18 @@ use the "experimental" feature of the "%{crate}" crate.
%files -n %{name}+experimental-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fat-lto-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+fat-lto-devel %{_description}
This package contains library source intended for building other packages which
use the "fat-lto" feature of the "%{crate}" crate.
%files -n %{name}+fat-lto-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+legacy-devel
Summary: %{summary}
BuildArch: noarch
@ -162,6 +172,18 @@ use the "thin" feature of the "%{crate}" crate.
%files -n %{name}+thin-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+thin-lto-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+thin-lto-devel %{_description}
This package contains library source intended for building other packages which
use the "thin-lto" feature of the "%{crate}" crate.
%files -n %{name}+thin-lto-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+wasm-devel
Summary: %{summary}
BuildArch: noarch

@ -1 +1 @@
SHA512 (zstd-0.11.2+zstd.1.5.2.crate) = d3f053c4acbdb45f3dadc9590db56095c761f0ff8899d22461f664701de766dde2fac2960a4477cd05d0a9c7ec200caa02ff891eb1f04630734996e0c38d10dd
SHA512 (zstd-0.12.3+zstd.1.5.2.crate) = 1ee79370e2a7517638e51ea3c5c2f7f9d3f42364eefc5b10e909f52e50bffd141ecf2ac4d3701bd7655c965dd03a608ca5b69743fc2ed877f4dbfcb79715b70f

@ -1,11 +1,11 @@
--- zstd-0.11.2+zstd.1.5.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zstd-0.11.2+zstd.1.5.2/Cargo.toml 2022-08-06T16:34:42.406161+00:00
@@ -12,9 +12,9 @@
[package]
--- zstd-0.12.3+zstd.1.5.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zstd-0.12.3+zstd.1.5.2/Cargo.toml 2023-02-23T18:01:54.411512+00:00
@@ -13,9 +13,9 @@
edition = "2018"
rust-version = "1.43"
name = "zstd"
-version = "0.11.2+zstd.1.5.2"
+version = "0.11.2"
-version = "0.12.3+zstd.1.5.2"
+version = "0.12.3"
authors = ["Alexandre Bury <alexandre.bury@gmail.com>"]
-exclude = ["assets/*.zst"]
+exclude = ["/assets/", "/appveyor.yml", "/rustfmt.toml"]

Loading…
Cancel
Save