Update to version 0.11.2+zstd.1.5.2; Fixes RHBZ#2043686

epel9
Fabio Valentini 2 years ago
parent 899eb5c4c4
commit 1e48515133
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -6,3 +6,4 @@
/zstd-0.9.0+zstd.1.5.0.crate
/zstd-0.9.2+zstd.1.5.1.crate
/zstd-0.10.0+zstd.1.5.2.crate
/zstd-0.11.2+zstd.1.5.2.crate

@ -1,25 +1,23 @@
# Generated by rust2rpm 21
# Generated by rust2rpm 22
# * tests require files that are not included in published crates
%bcond_with check
%global debug_package %{nil}
%global crate zstd
%global upstream_version 0.10.0+zstd.1.5.2
%global upstream_version 0.11.2+zstd.1.5.2
Name: rust-%{crate}
Version: 0.10.0
Name: rust-zstd
Version: 0.11.2
Release: %autorelease
Summary: Binding for the zstd compression library
# Upstream license specification: MIT
License: MIT
URL: https://crates.io/crates/zstd
Source: %{crates_source %{crate} %{upstream_version}}
# Initial patched metadata
# * Remove zstd version from version field
# * Build zstd-sys with bindgen and pkg-config
# * Exclude development-only files
Patch0: zstd-fix-metadata.diff
# Manually created patch for downstream crate metadata changes
# * remove zstd version from version field
# * exclude development-only files
Patch: zstd-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -176,6 +174,18 @@ use the "wasm" feature of the "%{crate}" crate.
%files -n %{name}+wasm-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zdict_builder-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+zdict_builder-devel %{_description}
This package contains library source intended for building other packages which
use the "zdict_builder" feature of the "%{crate}" crate.
%files -n %{name}+zdict_builder-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zstdmt-devel
Summary: %{summary}
BuildArch: noarch

@ -1 +1 @@
SHA512 (zstd-0.10.0+zstd.1.5.2.crate) = b6559710b10da68fd0cb242029145c2176d9bcbf5aa04c0d035341a27a6cc10038c0872d0df3a8fb94f0be573dfec65015032f583a93408da20377cef037746c
SHA512 (zstd-0.11.2+zstd.1.5.2.crate) = d3f053c4acbdb45f3dadc9590db56095c761f0ff8899d22461f664701de766dde2fac2960a4477cd05d0a9c7ec200caa02ff891eb1f04630734996e0c38d10dd

@ -1,23 +1,14 @@
--- zstd-0.10.0+zstd.1.5.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zstd-0.10.0+zstd.1.5.2/Cargo.toml 2022-04-12T10:15:44.434153+00:00
--- zstd-0.11.2+zstd.1.5.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zstd-0.11.2+zstd.1.5.2/Cargo.toml 2022-08-06T16:34:42.406161+00:00
@@ -12,9 +12,9 @@
[package]
edition = "2018"
name = "zstd"
-version = "0.10.0+zstd.1.5.2"
+version = "0.10.0"
-version = "0.11.2+zstd.1.5.2"
+version = "0.11.2"
authors = ["Alexandre Bury <alexandre.bury@gmail.com>"]
-exclude = ["assets/*.zst"]
+exclude = ["/assets/", "/appveyor.yml", "/rustfmt.toml"]
description = "Binding for the zstd compression library."
documentation = "https://docs.rs/zstd"
readme = "Readme.md"
@@ -44,7 +44,7 @@
arrays = ["zstd-safe/arrays"]
bindgen = ["zstd-safe/bindgen"]
debug = ["zstd-safe/debug"]
-default = ["legacy", "arrays"]
+default = ["legacy", "arrays", "bindgen", "pkg-config"]
doc-cfg = []
experimental = ["zstd-safe/experimental"]
legacy = ["zstd-safe/legacy"]

Loading…
Cancel
Save