You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-zstd-sys/zstd-sys-fix-metadata.diff

46 lines
997 B

--- zstd-sys-2.0.7+zstd.1.5.4/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zstd-sys-2.0.7+zstd.1.5.4/Cargo.toml 2023-02-23T17:56:59.578432+00:00
@@ -13,20 +13,15 @@
edition = "2018"
rust-version = "1.43"
name = "zstd-sys"
-version = "2.0.7+zstd.1.5.4"
+version = "2.0.7"
authors = ["Alexandre Bury <alexandre.bury@gmail.com>"]
build = "build.rs"
links = "zstd"
-include = [
- "/LICENSE",
- "/*.*",
- "/src/",
- "/wasm-shim/**/*.h",
- "/zstd/LICENSE",
- "/zstd/COPYING",
- "/zstd/lib/**/*.c",
- "/zstd/lib/**/*.h",
- "/zstd/lib/**/*.S",
+exclude = [
+ "/test_it.sh",
+ "/update_bindings.sh",
+ "/update_zstd.sh",
+ "/wasm-shim/",
]
description = "Low-level bindings for the zstd compression library."
readme = "Readme.md"
@@ -57,7 +52,6 @@
"runtime",
"which-rustfmt",
]
-optional = true
default-features = false
[build-dependencies.cc]
@@ -68,6 +62,7 @@
version = "0.3"
[features]
+bindgen = []
debug = []
default = [
"legacy",