Update to version 2.0.13+zstd.1.5.6; Fixes RHBZ#2302536

epel10 imports/epel10/rust-zstd-sys-2.0.13-1.el10
Fabio Valentini 4 months ago
parent 53244f5703
commit c24a87efd3
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -12,3 +12,4 @@
/zstd-sys-2.0.9+zstd.1.5.5.crate
/zstd-sys-2.0.10+zstd.1.5.6.crate
/zstd-sys-2.0.12+zstd.1.5.6.crate
/zstd-sys-2.0.13+zstd.1.5.6.crate

@ -1,6 +1,6 @@
From 68404dcb073c4d9f5e7a515dcda38554dcc1b011 Mon Sep 17 00:00:00 2001
From 2fff0a56e8508e5c024bd2b0312cedae7da324f4 Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Sun, 7 Jul 2024 15:18:13 +0200
Date: Mon, 7 Oct 2024 18:22:28 +0200
Subject: [PATCH] unconditionally use bindgen and pkg-config to link against
system libzstd
@ -9,7 +9,7 @@ Subject: [PATCH] unconditionally use bindgen and pkg-config to link against
1 file changed, 3 insertions(+), 207 deletions(-)
diff --git a/build.rs b/build.rs
index e03f354..2274c45 100644
index e578f60..2274c45 100644
--- a/build.rs
+++ b/build.rs
@@ -1,8 +1,6 @@
@ -118,7 +118,7 @@ index e03f354..2274c45 100644
- // See: https://github.com/gyscos/zstd-rs/pull/209
- let need_wasm_shim = !cfg!(feature = "no_wasm_shim")
- && env::var("TARGET").map_or(false, |target| {
- target == "wasm32-unknown-unknown" || target == "wasm32-wasi"
- target == "wasm32-unknown-unknown" || target.starts_with("wasm32-wasi")
- });
-
- if need_wasm_shim {
@ -257,5 +257,5 @@ index e03f354..2274c45 100644
let includes: Vec<_> = headerpaths
.iter()
--
2.45.2
2.46.2

@ -3,10 +3,10 @@
%global debug_package %{nil}
%global crate zstd-sys
%global upstream_version 2.0.12+zstd.1.5.6
%global upstream_version 2.0.13+zstd.1.5.6
Name: rust-zstd-sys
Version: 2.0.12
Version: 2.0.13
Release: %autorelease
Summary: Low-level bindings for the zstd compression library
@ -22,7 +22,7 @@ Patch: zstd-sys-fix-metadata-auto.diff
# * exclude files that are only useful for upstream development
Patch: zstd-sys-fix-metadata.diff
# * unconditionally use bindgen and pkg-config to link against system libzstd
Patch: 0001-unconditionally-use-bindgen-and-pkg-config-to-link-a.patch
Patch10: 0001-unconditionally-use-bindgen-and-pkg-config-to-link-a.patch
BuildRequires: cargo-rpm-macros >= 24
BuildRequires: pkgconfig(libzstd)

@ -1 +1 @@
SHA512 (zstd-sys-2.0.12+zstd.1.5.6.crate) = 6bd8baf5777a766d7e9f730af1a4dec1ad34a90ddfe52398faf7d8d7928aa4461cd659c9cb535fdef5ef7cbc9b4474673c36f5b6a156aa095d34364867728229
SHA512 (zstd-sys-2.0.13+zstd.1.5.6.crate) = c1f0176ebd0914879d0060796776c7fe376293ce9bc9f8f07ee3b809932a75aa033881d59a1bc99b6cd9af85b8e225fc09bcfc96013e556d7c11f155b759ecbf

@ -1,11 +1,11 @@
--- zstd-sys-2.0.12+zstd.1.5.6/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zstd-sys-2.0.12+zstd.1.5.6/Cargo.toml 2024-07-07T13:15:56.483587+00:00
--- zstd-sys-2.0.13+zstd.1.5.6/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zstd-sys-2.0.13+zstd.1.5.6/Cargo.toml 2024-10-07T16:19:06.513584+00:00
@@ -13,7 +13,7 @@
edition = "2018"
rust-version = "1.64"
name = "zstd-sys"
-version = "2.0.12+zstd.1.5.6"
+version = "2.0.12"
-version = "2.0.13+zstd.1.5.6"
+version = "2.0.13"
authors = ["Alexandre Bury <alexandre.bury@gmail.com>"]
build = "build.rs"
links = "zstd"

@ -1,5 +1,5 @@
--- zstd-sys-2.0.12+zstd.1.5.6/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zstd-sys-2.0.12+zstd.1.5.6/Cargo.toml 2024-07-07T13:16:28.935725+00:00
--- zstd-sys-2.0.13+zstd.1.5.6/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zstd-sys-2.0.13+zstd.1.5.6/Cargo.toml 2024-10-07T16:19:32.884735+00:00
@@ -17,18 +17,11 @@
authors = ["Alexandre Bury <alexandre.bury@gmail.com>"]
build = "build.rs"

Loading…
Cancel
Save