commit
784be663be
@ -0,0 +1 @@
|
||||
SOURCES/zstd-sys-2.0.13+zstd.1.5.6.crate
|
@ -0,0 +1 @@
|
||||
cc314995634c855abadb6b3f0cd3bba8598e76cc SOURCES/zstd-sys-2.0.13+zstd.1.5.6.crate
|
@ -0,0 +1,261 @@
|
||||
From 2fff0a56e8508e5c024bd2b0312cedae7da324f4 Mon Sep 17 00:00:00 2001
|
||||
From: Fabio Valentini <decathorpe@gmail.com>
|
||||
Date: Mon, 7 Oct 2024 18:22:28 +0200
|
||||
Subject: [PATCH] unconditionally use bindgen and pkg-config to link against
|
||||
system libzstd
|
||||
|
||||
---
|
||||
build.rs | 210 +------------------------------------------------------
|
||||
1 file changed, 3 insertions(+), 207 deletions(-)
|
||||
|
||||
diff --git a/build.rs b/build.rs
|
||||
index e578f60..2274c45 100644
|
||||
--- a/build.rs
|
||||
+++ b/build.rs
|
||||
@@ -1,8 +1,6 @@
|
||||
-use std::ffi::OsStr;
|
||||
-use std::path::{Path, PathBuf};
|
||||
-use std::{env, fmt, fs};
|
||||
+use std::path::PathBuf;
|
||||
+use std::{env, fmt};
|
||||
|
||||
-#[cfg(feature = "bindgen")]
|
||||
fn generate_bindings(defs: Vec<&str>, headerpaths: Vec<PathBuf>) {
|
||||
let bindings = bindgen::Builder::default().header("zstd.h");
|
||||
#[cfg(feature = "zdict_builder")]
|
||||
@@ -36,9 +34,6 @@ fn generate_bindings(defs: Vec<&str>, headerpaths: Vec<PathBuf>) {
|
||||
.expect("Could not write bindings");
|
||||
}
|
||||
|
||||
-#[cfg(not(feature = "bindgen"))]
|
||||
-fn generate_bindings(_: Vec<&str>, _: Vec<PathBuf>) {}
|
||||
-
|
||||
fn pkg_config() -> (Vec<&'static str>, Vec<PathBuf>) {
|
||||
let library = pkg_config::Config::new()
|
||||
.statik(true)
|
||||
@@ -48,31 +43,6 @@ fn pkg_config() -> (Vec<&'static str>, Vec<PathBuf>) {
|
||||
(vec!["PKG_CONFIG"], library.include_paths)
|
||||
}
|
||||
|
||||
-#[cfg(not(feature = "legacy"))]
|
||||
-fn set_legacy(_config: &mut cc::Build) {}
|
||||
-
|
||||
-#[cfg(feature = "legacy")]
|
||||
-fn set_legacy(config: &mut cc::Build) {
|
||||
- config.define("ZSTD_LEGACY_SUPPORT", Some("1"));
|
||||
- config.include("zstd/lib/legacy");
|
||||
-}
|
||||
-
|
||||
-#[cfg(feature = "zstdmt")]
|
||||
-fn set_pthread(config: &mut cc::Build) {
|
||||
- config.flag("-pthread");
|
||||
-}
|
||||
-
|
||||
-#[cfg(not(feature = "zstdmt"))]
|
||||
-fn set_pthread(_config: &mut cc::Build) {}
|
||||
-
|
||||
-#[cfg(feature = "zstdmt")]
|
||||
-fn enable_threading(config: &mut cc::Build) {
|
||||
- config.define("ZSTD_MULTITHREAD", Some(""));
|
||||
-}
|
||||
-
|
||||
-#[cfg(not(feature = "zstdmt"))]
|
||||
-fn enable_threading(_config: &mut cc::Build) {}
|
||||
-
|
||||
/// This function would find the first flag in `flags` that is supported
|
||||
/// and add that to `config`.
|
||||
#[allow(dead_code)]
|
||||
@@ -86,156 +56,6 @@ fn flag_if_supported_with_fallbacks(config: &mut cc::Build, flags: &[&str]) {
|
||||
}
|
||||
}
|
||||
|
||||
-fn compile_zstd() {
|
||||
- let mut config = cc::Build::new();
|
||||
-
|
||||
- // Search the following directories for C files to add to the compilation.
|
||||
- for dir in &[
|
||||
- "zstd/lib/common",
|
||||
- "zstd/lib/compress",
|
||||
- "zstd/lib/decompress",
|
||||
- #[cfg(feature = "zdict_builder")]
|
||||
- "zstd/lib/dictBuilder",
|
||||
- #[cfg(feature = "legacy")]
|
||||
- "zstd/lib/legacy",
|
||||
- ] {
|
||||
- let mut entries: Vec<_> = fs::read_dir(dir)
|
||||
- .unwrap()
|
||||
- .map(Result::unwrap)
|
||||
- .filter_map(|entry| {
|
||||
- let filename = entry.file_name();
|
||||
-
|
||||
- if Path::new(&filename).extension() == Some(OsStr::new("c"))
|
||||
- // Skip xxhash*.c files: since we are using the "PRIVATE API"
|
||||
- // mode, it will be inlined in the headers.
|
||||
- && !filename.to_string_lossy().contains("xxhash")
|
||||
- {
|
||||
- Some(entry.path())
|
||||
- } else {
|
||||
- None
|
||||
- }
|
||||
- })
|
||||
- .collect();
|
||||
- entries.sort();
|
||||
-
|
||||
- config.files(entries);
|
||||
- }
|
||||
-
|
||||
- // Either include ASM files, or disable ASM entirely.
|
||||
- // Also disable it on windows, apparently it doesn't do well with these .S files at the moment.
|
||||
- if cfg!(feature = "no_asm") || std::env::var("CARGO_CFG_WINDOWS").is_ok() {
|
||||
- config.define("ZSTD_DISABLE_ASM", Some(""));
|
||||
- } else {
|
||||
- config.file("zstd/lib/decompress/huf_decompress_amd64.S");
|
||||
- }
|
||||
-
|
||||
- // List out the WASM targets that need wasm-shim.
|
||||
- // Note that Emscripten already provides its own C standard library so
|
||||
- // wasm32-unknown-emscripten should not be included here.
|
||||
- // See: https://github.com/gyscos/zstd-rs/pull/209
|
||||
- let need_wasm_shim = !cfg!(feature = "no_wasm_shim")
|
||||
- && env::var("TARGET").map_or(false, |target| {
|
||||
- target == "wasm32-unknown-unknown" || target.starts_with("wasm32-wasi")
|
||||
- });
|
||||
-
|
||||
- if need_wasm_shim {
|
||||
- cargo_print(&"rerun-if-changed=wasm-shim/stdlib.h");
|
||||
- cargo_print(&"rerun-if-changed=wasm-shim/string.h");
|
||||
-
|
||||
- config.include("wasm-shim/");
|
||||
- }
|
||||
-
|
||||
- // Some extra parameters
|
||||
- config.include("zstd/lib/");
|
||||
- config.include("zstd/lib/common");
|
||||
- config.warnings(false);
|
||||
-
|
||||
- config.define("ZSTD_LIB_DEPRECATED", Some("0"));
|
||||
-
|
||||
- config
|
||||
- .flag_if_supported("-ffunction-sections")
|
||||
- .flag_if_supported("-fdata-sections")
|
||||
- .flag_if_supported("-fmerge-all-constants");
|
||||
-
|
||||
- if cfg!(feature = "fat-lto") {
|
||||
- config.flag_if_supported("-flto");
|
||||
- } else if cfg!(feature = "thin-lto") {
|
||||
- flag_if_supported_with_fallbacks(
|
||||
- &mut config,
|
||||
- &["-flto=thin", "-flto"],
|
||||
- );
|
||||
- }
|
||||
-
|
||||
- #[cfg(feature = "thin")]
|
||||
- {
|
||||
- // Here we try to build a lib as thin/small as possible.
|
||||
- // We cannot use ZSTD_LIB_MINIFY since it is only
|
||||
- // used in Makefile to define other options.
|
||||
-
|
||||
- config
|
||||
- .define("HUF_FORCE_DECOMPRESS_X1", Some("1"))
|
||||
- .define("ZSTD_FORCE_DECOMPRESS_SEQUENCES_SHORT", Some("1"))
|
||||
- .define("ZSTD_NO_INLINE", Some("1"))
|
||||
- // removes the error messages that are
|
||||
- // otherwise returned by ZSTD_getErrorName
|
||||
- .define("ZSTD_STRIP_ERROR_STRINGS", Some("1"));
|
||||
-
|
||||
- // Disable use of BMI2 instructions since it involves runtime checking
|
||||
- // of the feature and fallback if no BMI2 instruction is detected.
|
||||
- config.define("DYNAMIC_BMI2", Some("0"));
|
||||
-
|
||||
- // Disable support for all legacy formats
|
||||
- #[cfg(not(feature = "legacy"))]
|
||||
- config.define("ZSTD_LEGACY_SUPPORT", Some("0"));
|
||||
-
|
||||
- config.opt_level_str("z");
|
||||
- }
|
||||
-
|
||||
- // Hide symbols from resulting library,
|
||||
- // so we can be used with another zstd-linking lib.
|
||||
- // See https://github.com/gyscos/zstd-rs/issues/58
|
||||
- config.flag("-fvisibility=hidden");
|
||||
- config.define("XXH_PRIVATE_API", Some(""));
|
||||
- config.define("ZSTDLIB_VISIBILITY", Some(""));
|
||||
- #[cfg(feature = "zdict_builder")]
|
||||
- config.define("ZDICTLIB_VISIBILITY", Some(""));
|
||||
- config.define("ZSTDERRORLIB_VISIBILITY", Some(""));
|
||||
-
|
||||
- // https://github.com/facebook/zstd/blob/d69d08ed6c83563b57d98132e1e3f2487880781e/lib/common/debug.h#L60
|
||||
- /* recommended values for DEBUGLEVEL :
|
||||
- * 0 : release mode, no debug, all run-time checks disabled
|
||||
- * 1 : enables assert() only, no display
|
||||
- * 2 : reserved, for currently active debug path
|
||||
- * 3 : events once per object lifetime (CCtx, CDict, etc.)
|
||||
- * 4 : events once per frame
|
||||
- * 5 : events once per block
|
||||
- * 6 : events once per sequence (verbose)
|
||||
- * 7+: events at every position (*very* verbose)
|
||||
- */
|
||||
- #[cfg(feature = "debug")]
|
||||
- if !is_wasm {
|
||||
- config.define("DEBUGLEVEL", Some("5"));
|
||||
- }
|
||||
-
|
||||
- set_pthread(&mut config);
|
||||
- set_legacy(&mut config);
|
||||
- enable_threading(&mut config);
|
||||
-
|
||||
- // Compile!
|
||||
- config.compile("libzstd.a");
|
||||
-
|
||||
- let src = env::current_dir().unwrap().join("zstd").join("lib");
|
||||
- let dst = PathBuf::from(env::var_os("OUT_DIR").unwrap());
|
||||
- let include = dst.join("include");
|
||||
- fs::create_dir_all(&include).unwrap();
|
||||
- fs::copy(src.join("zstd.h"), include.join("zstd.h")).unwrap();
|
||||
- fs::copy(src.join("zstd_errors.h"), include.join("zstd_errors.h"))
|
||||
- .unwrap();
|
||||
- #[cfg(feature = "zdict_builder")]
|
||||
- fs::copy(src.join("zdict.h"), include.join("zdict.h")).unwrap();
|
||||
- cargo_print(&format_args!("root={}", dst.display()));
|
||||
-}
|
||||
-
|
||||
/// Print a line for cargo.
|
||||
///
|
||||
/// If non-cargo is set, do not print anything.
|
||||
@@ -248,32 +68,8 @@ fn cargo_print(content: &dyn fmt::Display) {
|
||||
fn main() {
|
||||
cargo_print(&"rerun-if-env-changed=ZSTD_SYS_USE_PKG_CONFIG");
|
||||
|
||||
- let target_arch =
|
||||
- std::env::var("CARGO_CFG_TARGET_ARCH").unwrap_or_default();
|
||||
- let target_os = std::env::var("CARGO_CFG_TARGET_OS").unwrap_or_default();
|
||||
-
|
||||
- if target_arch == "wasm32" || target_os == "hermit" {
|
||||
- cargo_print(&"rustc-cfg=feature=\"std\"");
|
||||
- }
|
||||
-
|
||||
// println!("cargo:rustc-link-lib=zstd");
|
||||
- let (defs, headerpaths) = if cfg!(feature = "pkg-config")
|
||||
- || env::var_os("ZSTD_SYS_USE_PKG_CONFIG").is_some()
|
||||
- {
|
||||
- pkg_config()
|
||||
- } else {
|
||||
- if !Path::new("zstd/lib").exists() {
|
||||
- panic!("Folder 'zstd/lib' does not exists. Maybe you forgot to clone the 'zstd' submodule?");
|
||||
- }
|
||||
-
|
||||
- let manifest_dir = PathBuf::from(
|
||||
- env::var_os("CARGO_MANIFEST_DIR")
|
||||
- .expect("Manifest dir is always set by cargo"),
|
||||
- );
|
||||
-
|
||||
- compile_zstd();
|
||||
- (vec![], vec![manifest_dir.join("zstd/lib")])
|
||||
- };
|
||||
+ let (defs, headerpaths) = pkg_config();
|
||||
|
||||
let includes: Vec<_> = headerpaths
|
||||
.iter()
|
||||
--
|
||||
2.46.2
|
||||
|
@ -0,0 +1,29 @@
|
||||
[package]
|
||||
cargo-toml-patch-comments = [
|
||||
"make bindgen build-dependency non-optional",
|
||||
"fix logic for included / excluded files",
|
||||
"exclude files that are only useful for upstream development",
|
||||
]
|
||||
|
||||
[[package.extra-patches]]
|
||||
number = 10
|
||||
file = "0001-unconditionally-use-bindgen-and-pkg-config-to-link-a.patch"
|
||||
comments = [
|
||||
"unconditionally use bindgen and pkg-config to link against system libzstd",
|
||||
]
|
||||
|
||||
[features]
|
||||
hide = [
|
||||
"no_wasm_shim",
|
||||
]
|
||||
|
||||
[requires]
|
||||
build = ["pkgconfig(libzstd)"]
|
||||
lib = ["pkgconfig(libzstd)"]
|
||||
|
||||
[scripts]
|
||||
prep.post = [
|
||||
"# * remove bundled zstd sources",
|
||||
"rm -vr zstd/",
|
||||
]
|
||||
|
@ -0,0 +1,16 @@
|
||||
--- zstd-sys-2.0.13+zstd.1.5.6/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ zstd-sys-2.0.13+zstd.1.5.6/Cargo.toml 2024-10-07T16:19:06.513584+00:00
|
||||
@@ -13,7 +13,7 @@
|
||||
edition = "2018"
|
||||
rust-version = "1.64"
|
||||
name = "zstd-sys"
|
||||
-version = "2.0.13+zstd.1.5.6"
|
||||
+version = "2.0.13"
|
||||
authors = ["Alexandre Bury <alexandre.bury@gmail.com>"]
|
||||
build = "build.rs"
|
||||
links = "zstd"
|
||||
@@ -84,3 +84,4 @@
|
||||
thin-lto = []
|
||||
zdict_builder = []
|
||||
zstdmt = []
|
||||
+
|
@ -0,0 +1,42 @@
|
||||
--- zstd-sys-2.0.13+zstd.1.5.6/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ zstd-sys-2.0.13+zstd.1.5.6/Cargo.toml 2024-10-07T16:19:32.884735+00:00
|
||||
@@ -17,18 +17,11 @@
|
||||
authors = ["Alexandre Bury <alexandre.bury@gmail.com>"]
|
||||
build = "build.rs"
|
||||
links = "zstd"
|
||||
-include = [
|
||||
- "/LICENSE*",
|
||||
- "!/*.sh",
|
||||
- "/build.rs",
|
||||
- "/*.h",
|
||||
- "/src/",
|
||||
- "/wasm-shim/**/*.h",
|
||||
- "/zstd/LICENSE",
|
||||
- "/zstd/COPYING",
|
||||
- "/zstd/lib/**/*.c",
|
||||
- "/zstd/lib/**/*.h",
|
||||
- "/zstd/lib/**/*.S",
|
||||
+exclude = [
|
||||
+ "/test_it.sh",
|
||||
+ "/update_bindings.sh",
|
||||
+ "/update_zstd.sh",
|
||||
+ "/wasm-shim/",
|
||||
]
|
||||
description = "Low-level bindings for the zstd compression library."
|
||||
readme = "Readme.md"
|
||||
@@ -56,7 +49,6 @@
|
||||
"runtime",
|
||||
"which-rustfmt",
|
||||
]
|
||||
-optional = true
|
||||
default-features = false
|
||||
|
||||
[build-dependencies.cc]
|
||||
@@ -67,6 +59,7 @@
|
||||
version = "0.3"
|
||||
|
||||
[features]
|
||||
+bindgen = []
|
||||
debug = []
|
||||
default = [
|
||||
"legacy",
|
@ -0,0 +1,339 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.7.2)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 26
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate zstd-sys
|
||||
%global upstream_version 2.0.13+zstd.1.5.6
|
||||
|
||||
Name: rust-zstd-sys
|
||||
Version: 2.0.13
|
||||
Release: %autorelease
|
||||
Summary: Low-level bindings for the zstd compression library
|
||||
|
||||
# Upstream license specification: MIT/Apache-2.0
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/zstd-sys
|
||||
Source: %{crates_source %{crate} %{upstream_version}}
|
||||
# Automatically generated patch to strip dependencies and normalize metadata
|
||||
Patch: zstd-sys-fix-metadata-auto.diff
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * make bindgen build-dependency non-optional
|
||||
# * fix logic for included / excluded files
|
||||
# * exclude files that are only useful for upstream development
|
||||
Patch: zstd-sys-fix-metadata.diff
|
||||
# * unconditionally use bindgen and pkg-config to link against system libzstd
|
||||
Patch10: 0001-unconditionally-use-bindgen-and-pkg-config-to-link-a.patch
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
BuildRequires: pkgconfig(libzstd)
|
||||
|
||||
%global _description %{expand:
|
||||
Low-level bindings for the zstd compression library.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
Requires: pkgconfig(libzstd)
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%license %{crate_instdir}/LICENSE.Apache-2.0
|
||||
%license %{crate_instdir}/LICENSE.Mit
|
||||
%doc %{crate_instdir}/Readme.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+bindgen-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+bindgen-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "bindgen" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+bindgen-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+debug-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+debug-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "debug" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+debug-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+experimental-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+experimental-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "experimental" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+experimental-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+fat-lto-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+fat-lto-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "fat-lto" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+fat-lto-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+legacy-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+legacy-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "legacy" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+legacy-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+no_asm-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+no_asm-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "no_asm" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+no_asm-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+non-cargo-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+non-cargo-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "non-cargo" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+non-cargo-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+pkg-config-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+pkg-config-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "pkg-config" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+pkg-config-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+thin-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+thin-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "thin" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+thin-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+thin-lto-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+thin-lto-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "thin-lto" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+thin-lto-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+zdict_builder-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+zdict_builder-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "zdict_builder" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+zdict_builder-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+zstdmt-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+zstdmt-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "zstdmt" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+zstdmt-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{upstream_version} -p1
|
||||
%cargo_prep
|
||||
# * remove bundled zstd sources
|
||||
rm -vr zstd/
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 2.0.13-1
|
||||
- Rebuilt for MSVSphere 10
|
||||
|
||||
## START: Generated by rpmautospec
|
||||
* Mon Oct 07 2024 Fabio Valentini <decathorpe@gmail.com> - 2.0.13-1
|
||||
- Update to version 2.0.13+zstd.1.5.6; Fixes RHBZ#2302536
|
||||
|
||||
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.12-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||
|
||||
* Sun Jul 07 2024 Fabio Valentini <decathorpe@gmail.com> - 2.0.12-1
|
||||
- Update to version 2.0.12+zstd.1.5.6; Fixes RHBZ#2292666
|
||||
|
||||
* Thu May 16 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 2.0.10-1
|
||||
- Update to version 2.0.10; Fixes RHBZ#2271895
|
||||
|
||||
* Sat Jan 27 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.9-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Mon Jan 15 2024 Fabio Valentini <decathorpe@gmail.com> - 2.0.9-1
|
||||
- Update to version 2.0.9+zstd.1.5.5; Fixes RHBZ#2243313
|
||||
|
||||
* Tue Aug 01 2023 Fabio Valentini <decathorpe@gmail.com> - 2.0.8-1
|
||||
- Update to version 2.0.8+zstd.1.5.5; Fixes RHBZ#2184801
|
||||
|
||||
* Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.7-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Thu Feb 23 2023 Fabio Valentini <decathorpe@gmail.com> - 2.0.7-1
|
||||
- Update to version 2.0.7+zstd.1.5.4; Fixes RHBZ#2145250
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Sat Aug 06 2022 Fabio Valentini <decathorpe@gmail.com> - 2.0.1-1
|
||||
- Update to version 2.0.1+zstd.1.5.2; Fixes RHBZ#2043687
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Tue Apr 12 2022 Fabio Valentini <decathorpe@gmail.com> - 1.6.3-1
|
||||
- Update to version 1.6.3+zstd.1.5.2
|
||||
|
||||
* Sat Jan 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Fri Jan 07 2022 Fabio Valentini <decathorpe@gmail.com> - 1.6.2-1
|
||||
- Update to version 1.6.2+zstd.1.5.1; Fixes RHBZ#2035404
|
||||
|
||||
* Sat Nov 13 2021 Robert-André Mauchin <zebob.m@gmail.com> - 1.6.1-1
|
||||
- Update to 1.6.1 Close: rhbz#1960714
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Mon May 10 2021 Fabio Valentini <decathorpe@gmail.com> - 1.5.0-1
|
||||
- Update to version 1.5.0+zstd.1.4.9.
|
||||
|
||||
* Wed Mar 31 21:35:34 CEST 2021 Robert-André Mauchin <zebob.m@gmail.com> - 1.4.20-2
|
||||
- Remove downgrade of bindgen to 0.56
|
||||
|
||||
* Sat Mar 06 2021 Fabio Valentini <decathorpe@gmail.com> - 1.4.20-1
|
||||
- Update to version 1.4.20+zstd.1.4.9.
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.17-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Fri Nov 27 2020 Fabio Valentini <decathorpe@gmail.com> - 1.4.17-3
|
||||
- Bump to bindgen 0.56.
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.17-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Fri Jun 19 2020 Josh Stone <jistone@redhat.com> - 1.4.17-1
|
||||
- Update to 1.4.17+zstd.1.4.5
|
||||
|
||||
* Sat May 30 2020 Josh Stone <jistone@redhat.com> - 1.4.16-1
|
||||
- Update to 1.4.16+zstd.1.4.5
|
||||
|
||||
* Thu Feb 27 2020 Josh Stone <jistone@redhat.com> - 1.4.15-3
|
||||
- Bump to bindgen 0.53.1
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.15-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Sun Dec 15 23:59:34 CET 2019 Robert-André Mauchin <zebob.m@gmail.com> - 1.4.15-1
|
||||
- Initial package
|
||||
|
||||
## END: Generated by rpmautospec
|
Loading…
Reference in new issue