Update to version 2.0.9+zstd.1.5.5; Fixes RHBZ#2243313

epel9 imports/e9/rust-zstd-sys-2.0.9-1.el9
Fabio Valentini 1 year ago
parent ddda346ab3
commit 46efc234c3
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -9,3 +9,4 @@
/zstd-sys-2.0.1+zstd.1.5.2.crate
/zstd-sys-2.0.7+zstd.1.5.4.crate
/zstd-sys-2.0.8+zstd.1.5.5.crate
/zstd-sys-2.0.9+zstd.1.5.5.crate

@ -1,12 +1,12 @@
# Generated by rust2rpm 24
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate zstd-sys
%global upstream_version 2.0.8+zstd.1.5.5
%global upstream_version 2.0.9+zstd.1.5.5
Name: rust-zstd-sys
Version: 2.0.8
Version: 2.0.9
Release: %autorelease
Summary: Low-level bindings for the zstd compression library
@ -14,8 +14,9 @@ Summary: Low-level bindings for the zstd compression library
License: MIT OR Apache-2.0
URL: https://crates.io/crates/zstd-sys
Source: %{crates_source %{crate} %{upstream_version}}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: zstd-sys-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * remove zstd version from version field
# * make bindgen build-dependency non-optional
# * temporarily downgrade bindgen build-dependency from 0.64 to 0.63
# * fix logic for included / excluded files
@ -24,7 +25,7 @@ Patch: zstd-sys-fix-metadata.diff
# * unconditionally use bindgen and pkg-config to link against system libzstd
Patch: 0001-unconditionally-use-bindgen-and-pkg-config-to-link-a.patch
BuildRequires: rust-packaging >= 21
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Low-level bindings for the zstd compression library.}
@ -218,9 +219,9 @@ use the "zstdmt" feature of the "%{crate}" crate.
%prep
%autosetup -n %{crate}-%{upstream_version} -p1
%cargo_prep
# * remove bundled zstd sources
rm -vr zstd/
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires

@ -1,5 +0,0 @@
[DEFAULT]
buildrequires =
pkgconfig(libzstd)
lib.requires =
pkgconfig(libzstd)

@ -0,0 +1,4 @@
[requires]
build = ["pkgconfig(libzstd)"]
lib = ["pkgconfig(libzstd)"]

@ -1 +1 @@
SHA512 (zstd-sys-2.0.8+zstd.1.5.5.crate) = acfbf6c464678438bcab289c8be2e67a2bdfb910143d77363bf1ad5227dffc4b60e224388b7e59186fd4d1e017b63fef49734e99e383cbda19b82b4ed382fcd8
SHA512 (zstd-sys-2.0.9+zstd.1.5.5.crate) = 604c01eae4975745aca1dc1d351db98fec34f7036143e59dfeb4d36e6ee18ac9f3871a288557c8ebdc9e816967a008da43154dc9a0eb3cac85071ccb05bf58aa

@ -0,0 +1,16 @@
--- zstd-sys-2.0.9+zstd.1.5.5/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zstd-sys-2.0.9+zstd.1.5.5/Cargo.toml 2024-01-15T14:42:57.236818+00:00
@@ -13,7 +13,7 @@
edition = "2018"
rust-version = "1.64"
name = "zstd-sys"
-version = "2.0.9+zstd.1.5.5"
+version = "2.0.9"
authors = ["Alexandre Bury <alexandre.bury@gmail.com>"]
build = "build.rs"
links = "zstd"
@@ -83,3 +83,4 @@
thin-lto = []
zdict_builder = []
zstdmt = []
+

@ -1,17 +1,14 @@
--- zstd-sys-2.0.8+zstd.1.5.5/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zstd-sys-2.0.8+zstd.1.5.5/Cargo.toml 2023-08-01T13:04:14.123960+00:00
@@ -13,20 +13,15 @@
edition = "2018"
rust-version = "1.43"
name = "zstd-sys"
-version = "2.0.8+zstd.1.5.5"
+version = "2.0.8"
--- zstd-sys-2.0.9+zstd.1.5.5/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zstd-sys-2.0.9+zstd.1.5.5/Cargo.toml 2024-01-15T14:43:55.623033+00:00
@@ -17,18 +17,11 @@
authors = ["Alexandre Bury <alexandre.bury@gmail.com>"]
build = "build.rs"
links = "zstd"
-include = [
- "/LICENSE",
- "/*.*",
- "/LICENSE*",
- "!/*.sh",
- "/build.rs",
- "/*.h",
- "/src/",
- "/wasm-shim/**/*.h",
- "/zstd/LICENSE",
@ -27,13 +24,7 @@
]
description = "Low-level bindings for the zstd compression library."
readme = "Readme.md"
@@ -52,12 +47,11 @@
version = "0.2.45"
[build-dependencies.bindgen]
-version = "0.64"
+version = "0.63"
features = [
@@ -56,7 +49,6 @@
"runtime",
"which-rustfmt",
]
@ -41,7 +32,7 @@
default-features = false
[build-dependencies.cc]
@@ -68,6 +62,7 @@
@@ -67,6 +59,7 @@
version = "0.3"
[features]

Loading…
Cancel
Save