Update to version 2.0.12+zstd.1.5.6; Fixes RHBZ#2292666

epel10
Fabio Valentini 8 months ago
parent 0b2d1e91bc
commit 0b2d02346a
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -11,3 +11,4 @@
/zstd-sys-2.0.8+zstd.1.5.5.crate
/zstd-sys-2.0.9+zstd.1.5.5.crate
/zstd-sys-2.0.10+zstd.1.5.6.crate
/zstd-sys-2.0.12+zstd.1.5.6.crate

@ -1,15 +1,15 @@
From 2c6e27c3723ccb3c83e28a0b6c2033564f9f515e Mon Sep 17 00:00:00 2001
From 68404dcb073c4d9f5e7a515dcda38554dcc1b011 Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Tue, 1 Aug 2023 15:13:34 +0200
Date: Sun, 7 Jul 2024 15:18:13 +0200
Subject: [PATCH] unconditionally use bindgen and pkg-config to link against
system libzstd
---
build.rs | 211 +------------------------------------------------------
1 file changed, 3 insertions(+), 208 deletions(-)
build.rs | 210 +------------------------------------------------------
1 file changed, 3 insertions(+), 207 deletions(-)
diff --git a/build.rs b/build.rs
index c7b52f5..2274c45 100644
index e03f354..2274c45 100644
--- a/build.rs
+++ b/build.rs
@@ -1,8 +1,6 @@
@ -65,7 +65,7 @@ index c7b52f5..2274c45 100644
/// This function would find the first flag in `flags` that is supported
/// and add that to `config`.
#[allow(dead_code)]
@@ -86,157 +56,6 @@ fn flag_if_supported_with_fallbacks(config: &mut cc::Build, flags: &[&str]) {
@@ -86,156 +56,6 @@ fn flag_if_supported_with_fallbacks(config: &mut cc::Build, flags: &[&str]) {
}
}
@ -126,7 +126,6 @@ index c7b52f5..2274c45 100644
- cargo_print(&"rerun-if-changed=wasm-shim/string.h");
-
- config.include("wasm-shim/");
- config.define("XXH_STATIC_ASSERT", Some("0"));
- }
-
- // Some extra parameters
@ -223,7 +222,7 @@ index c7b52f5..2274c45 100644
/// Print a line for cargo.
///
/// If non-cargo is set, do not print anything.
@@ -249,32 +68,8 @@ fn cargo_print(content: &dyn fmt::Display) {
@@ -248,32 +68,8 @@ fn cargo_print(content: &dyn fmt::Display) {
fn main() {
cargo_print(&"rerun-if-env-changed=ZSTD_SYS_USE_PKG_CONFIG");
@ -258,5 +257,5 @@ index c7b52f5..2274c45 100644
let includes: Vec<_> = headerpaths
.iter()
--
2.44.0
2.45.2

@ -3,10 +3,10 @@
%global debug_package %{nil}
%global crate zstd-sys
%global upstream_version 2.0.10+zstd.1.5.6
%global upstream_version 2.0.12+zstd.1.5.6
Name: rust-zstd-sys
Version: 2.0.10
Version: 2.0.12
Release: %autorelease
Summary: Low-level bindings for the zstd compression library

@ -5,6 +5,13 @@ cargo-toml-patch-comments = [
"exclude files that are only useful for upstream development",
]
[[package.extra-patches]]
number = 10
file = "0001-unconditionally-use-bindgen-and-pkg-config-to-link-a.patch"
comments = [
"unconditionally use bindgen and pkg-config to link against system libzstd",
]
[features]
hide = [
"no_wasm_shim",

@ -1 +1 @@
SHA512 (zstd-sys-2.0.10+zstd.1.5.6.crate) = 588008a436a9c7751fa7c088620bf04434751e508c9a729e6840e42a14a2cc26c8ee252e8f129a5ae00eb1f76ae6ecfffaac043d854b61381d386f71d80993f9
SHA512 (zstd-sys-2.0.12+zstd.1.5.6.crate) = 6bd8baf5777a766d7e9f730af1a4dec1ad34a90ddfe52398faf7d8d7928aa4461cd659c9cb535fdef5ef7cbc9b4474673c36f5b6a156aa095d34364867728229

@ -1,11 +1,11 @@
--- zstd-sys-2.0.10+zstd.1.5.6/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zstd-sys-2.0.10+zstd.1.5.6/Cargo.toml 2024-05-06T19:33:10.568159+00:00
--- zstd-sys-2.0.12+zstd.1.5.6/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zstd-sys-2.0.12+zstd.1.5.6/Cargo.toml 2024-07-07T13:15:56.483587+00:00
@@ -13,7 +13,7 @@
edition = "2018"
rust-version = "1.64"
name = "zstd-sys"
-version = "2.0.10+zstd.1.5.6"
+version = "2.0.10"
-version = "2.0.12+zstd.1.5.6"
+version = "2.0.12"
authors = ["Alexandre Bury <alexandre.bury@gmail.com>"]
build = "build.rs"
links = "zstd"

@ -1,5 +1,5 @@
--- zstd-sys-2.0.10+zstd.1.5.6/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zstd-sys-2.0.10+zstd.1.5.6/Cargo.toml 2024-05-06T19:33:42.572623+00:00
--- zstd-sys-2.0.12+zstd.1.5.6/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zstd-sys-2.0.12+zstd.1.5.6/Cargo.toml 2024-07-07T13:16:28.935725+00:00
@@ -17,18 +17,11 @@
authors = ["Alexandre Bury <alexandre.bury@gmail.com>"]
build = "build.rs"

Loading…
Cancel
Save