update to version 4.0.0+zstd.1.4.9

epel9
Fabio Valentini 4 years ago
parent 75394715c1
commit cfa1599f16
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -2,3 +2,4 @@
/zstd-safe-2.0.4+zstd.1.4.5.crate
/zstd-safe-2.0.5+zstd.1.4.5.crate
/zstd-safe-3.0.1+zstd.1.4.9.crate
/zstd-safe-4.0.0+zstd.1.4.9.crate

@ -1,12 +1,12 @@
# Generated by rust2rpm 16
# Generated by rust2rpm 17
%bcond_without check
%global debug_package %{nil}
%global crate zstd-safe
%global upstream_version 3.0.1+zstd.1.4.9
%global upstream_version 4.0.0+zstd.1.4.9
Name: rust-%{crate}
Version: 3.0.1
Version: 4.0.0
Release: 1%{?dist}
Summary: Safe low-level bindings for the zstd compression library
@ -16,8 +16,7 @@ URL: https://crates.io/crates/zstd-safe
Source: %{crates_source %{crate} %{upstream_version}}
# Initial patched metadata
# * Remove zstd version from version field
# * Add pkg-config feature to build zstd-sys
# * Remove bindgen feature which is the default now
# * Use pkg-config and bindgen features of zstd-sys unconditionally
Patch0: zstd-safe-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -58,6 +57,18 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+bindgen-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bindgen-devel %{_description}
This package contains library source intended for building other packages
which use "bindgen" feature of "%{crate}" crate.
%files -n %{name}+bindgen-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+debug-devel
Summary: %{summary}
BuildArch: noarch
@ -118,6 +129,18 @@ which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+thin-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+thin-devel %{_description}
This package contains library source intended for building other packages
which use "thin" feature of "%{crate}" crate.
%files -n %{name}+thin-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+zstdmt-devel
Summary: %{summary}
BuildArch: noarch
@ -149,6 +172,9 @@ which use "zstdmt" feature of "%{crate}" crate.
%endif
%changelog
* Mon May 10 2021 Fabio Valentini <decathorpe@gmail.com> - 4.0.0-1
- Update to version 4.0.0+zstd.1.4.9.
* Sat Mar 06 2021 Fabio Valentini <decathorpe@gmail.com> - 3.0.1-1
- Update to version 3.0.1+zstd.1.4.9.

@ -1 +1 @@
SHA512 (zstd-safe-3.0.1+zstd.1.4.9.crate) = 9ca714ae45adb4421a29ccf8dbc0752d3c2b69e72b15cf6533064a5b1f016250b745fa469b9e7c5d0b24c50a0c46f1d6dd2683917b33cd80ebe80223eead0227
SHA512 (zstd-safe-4.0.0+zstd.1.4.9.crate) = 9135d5de9b04eb5e4881150dd0e58258a373c3d4b5d7e681eb0980a93e1f42657e6478c81950582afdc617aaf119e4277c3381cd531548e99b02a03eb9772002

@ -1,22 +1,19 @@
--- zstd-safe-3.0.1+zstd.1.4.9/Cargo.toml 1970-01-01T00:00:00+00:00
+++ zstd-safe-3.0.1+zstd.1.4.9/Cargo.toml 2021-03-06T23:17:57.614492+00:00
--- zstd-safe-4.0.0+zstd.1.4.9/Cargo.toml 1970-01-01T00:00:00+00:00
+++ zstd-safe-4.0.0+zstd.1.4.9/Cargo.toml 2021-05-10T14:29:28.805307+00:00
@@ -12,7 +12,7 @@
[package]
name = "zstd-safe"
-version = "3.0.1+zstd.1.4.9"
+version = "3.0.1"
-version = "4.0.0+zstd.1.4.9"
+version = "4.0.0"
authors = ["Alexandre Bury <alexandre.bury@gmail.com>"]
build = "build.rs"
description = "Safe low-level bindings for the zstd compression library."
@@ -29,9 +29,9 @@
@@ -29,6 +29,7 @@
[dependencies.zstd-sys]
version = "=1.4.20"
version = "=1.5.0"
default-features = false
+features = ["pkg-config", "bindgen"]
[features]
-bindgen = ["zstd-sys/bindgen"]
debug = ["zstd-sys/debug"]
default = ["legacy"]
experimental = ["zstd-sys/experimental"]
bindgen = ["zstd-sys/bindgen"]

Loading…
Cancel
Save