Update to version 5.0.2+zstd.1.5.2; Fixes RHBZ#2043688

epel9
Fabio Valentini 2 years ago
parent b4e37f6f91
commit 3437a9b41d
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -6,3 +6,4 @@
/zstd-safe-4.1.1+zstd.1.5.0.crate
/zstd-safe-4.1.3+zstd.1.5.1.crate
/zstd-safe-4.1.4+zstd.1.5.2.crate
/zstd-safe-5.0.2+zstd.1.5.2.crate

@ -1,24 +1,23 @@
# Generated by rust2rpm 21
# Generated by rust2rpm 22
%bcond_without check
%global debug_package %{nil}
%global crate zstd-safe
%global upstream_version 4.1.4+zstd.1.5.2
%global upstream_version 5.0.2+zstd.1.5.2
Name: rust-%{crate}
Version: 4.1.4
Name: rust-zstd-safe
Version: 5.0.2
Release: %autorelease
Summary: Safe low-level bindings for the zstd compression library
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/zstd-safe
Source: %{crates_source %{crate} %{upstream_version}}
# Initial patched metadata
# * Remove zstd version from version field
# * Use pkg-config and bindgen features of zstd-sys unconditionally
# * Exclude a development-only shell script
Patch0: zstd-safe-fix-metadata.diff
# Manually created patch for downstream crate metadata changes
# * remove zstd version from version field
# * exclude a development-only shell script
Patch: zstd-safe-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -177,6 +176,18 @@ use the "thin" feature of the "%{crate}" crate.
%files -n %{name}+thin-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zdict_builder-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+zdict_builder-devel %{_description}
This package contains library source intended for building other packages which
use the "zdict_builder" feature of the "%{crate}" crate.
%files -n %{name}+zdict_builder-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zstdmt-devel
Summary: %{summary}
BuildArch: noarch

@ -1 +1 @@
SHA512 (zstd-safe-4.1.4+zstd.1.5.2.crate) = 0b9ad154307954b977a990273b11dba3349fffa1a2b3cb89dc233cc20deb6dc0a10bd97d06c3fc5304124320ee8ff607b6d8859ebdaa562365d4baf490fdbcd8
SHA512 (zstd-safe-5.0.2+zstd.1.5.2.crate) = 03a6f07ada211fd6c364f03d06acff705fa5b08129aa09c29ad310f05b233553f8ea697e504470d4c104bd947f5d4102328c4df0df5e1da6d8e537f51451a014

@ -1,27 +1,19 @@
--- zstd-safe-4.1.4+zstd.1.5.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zstd-safe-4.1.4+zstd.1.5.2/Cargo.toml 2022-04-12T10:19:58.834888+00:00
--- zstd-safe-5.0.2+zstd.1.5.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zstd-safe-5.0.2+zstd.1.5.2/Cargo.toml 2022-08-06T16:38:17.903057+00:00
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "zstd-safe"
-version = "4.1.4+zstd.1.5.2"
+version = "4.1.4"
-version = "5.0.2+zstd.1.5.2"
+version = "5.0.2"
authors = ["Alexandre Bury <alexandre.bury@gmail.com>"]
build = "build.rs"
description = "Safe low-level bindings for the zstd compression library."
@@ -21,6 +21,7 @@
categories = ["api-bindings", "compression"]
@@ -28,6 +28,7 @@
]
license = "MIT/Apache-2.0"
repository = "https://github.com/gyscos/zstd-rs"
+exclude = ["/update_consts.sh"]
[package.metadata.docs.rs]
features = ["experimental", "arrays", "std", "doc-cfg"]
[dependencies.libc]
@@ -29,6 +30,7 @@
[dependencies.zstd-sys]
version = "=1.6.3"
default-features = false
+features = ["pkg-config", "bindgen"]
[features]
arrays = []
[package.metadata.docs.rs]
features = [

Loading…
Cancel
Save