You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-zopfli/zopfli-fix-metadata.diff

39 lines
810 B

--- zopfli-0.8.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zopfli-0.8.0/Cargo.toml 2024-02-08T17:20:25.311181+00:00
@@ -14,7 +14,12 @@
rust-version = "1.66"
name = "zopfli"
version = "0.8.0"
-exclude = ["test/*"]
+exclude = [
+ "Makefile",
+ "benchmark-builds/*",
+ "rustfmt.toml",
+ "test/*",
+]
description = "A Rust implementation of the Zopfli compression algorithm."
homepage = "https://github.com/zopfli-rs/zopfli"
readme = "README.md"
@@ -25,20 +30,13 @@
]
license = "Apache-2.0"
repository = "https://github.com/zopfli-rs/zopfli"
+autobins = false
[package.metadata.docs.rs]
cargo-args = ["--all-features"]
[profile.release]
debug = 2
-
-[[bin]]
-name = "zopfli"
-required-features = [
- "std",
- "gzip",
- "zlib",
-]
[dependencies.crc32fast]
version = "1.3.2"