Update to 0.8.1 (close RHBZ#2281428)

epel10
Benjamin A. Beasley 9 months ago
parent b207e90249
commit afbcc91a7e

1
.gitignore vendored

@ -1,3 +1,4 @@
/zopfli-0.4.0.crate
/zopfli-0.5.0.crate
/zopfli-0.8.0.crate
/zopfli-0.8.1.crate

@ -8,17 +8,13 @@
%global crate zopfli
Name: rust-zopfli
Version: 0.8.0
Version: 0.8.1
Release: %autorelease
Summary: Rust implementation of the Zopfli compression algorithm
License: Apache-2.0
URL: https://crates.io/crates/zopfli
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * Exclude more files from the published crate:
# https://github.com/zopfli-rs/zopfli/pull/37
Patch: zopfli-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 26
@ -38,7 +34,6 @@ use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/COPYING
%doc %{crate_instdir}/CONTRIBUTING.md
%doc %{crate_instdir}/CONTRIBUTORS
%doc %{crate_instdir}/README.md
%{crate_instdir}/

@ -2,9 +2,6 @@
# Dont build the “zopfli” executable, which would conflict with the more
# widely used one provided by https://src.fedoraproject.org/rpms/zopfli.
cargo-install-bin = false
cargo-toml-patch-comments = [
"Exclude more files from the published crate: https://github.com/zopfli-rs/zopfli/pull/37",
]
[features]
hide = [

@ -1 +1 @@
SHA512 (zopfli-0.8.0.crate) = 3b788f0ca94a106ce690764d081bf277eddb364b07287c33be3855fdc63bd583b5e8aac95b709833b4ec4a8f153e7e1ea822b09da23d5db777137bc1dd49e17c
SHA512 (zopfli-0.8.1.crate) = 799e25c0cc9f0bf2119a7c03225b11ed94e7c3ac83f872a27da8ae15c90206245121c38f5e2b78fece131f5bb428f01fabbfd1b1e18ea456957940042d38f38d

@ -1,16 +0,0 @@
--- zopfli-0.8.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ zopfli-0.8.0/Cargo.toml 2024-03-14T15:41:14.859061+00:00
@@ -14,7 +14,12 @@
rust-version = "1.66"
name = "zopfli"
version = "0.8.0"
-exclude = ["test/*"]
+exclude = [
+ "Makefile",
+ "benchmark-builds/*",
+ "rustfmt.toml",
+ "test/*",
+]
description = "A Rust implementation of the Zopfli compression algorithm."
homepage = "https://github.com/zopfli-rs/zopfli"
readme = "README.md"
Loading…
Cancel
Save