You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-zip/rust-zip.spec

243 lines
6.5 KiB

# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate zip
Name: rust-zip
Version: 0.6.6
Release: %autorelease
Summary: Library to support the reading and writing of zip files
License: MIT
URL: https://crates.io/crates/zip
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * bump constant_time_eq dependency from 0.1 to 0.2
# * bump zstd dependency from 0.11 to 0.12
Patch: zip-fix-metadata.diff
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Library to support the reading and writing of zip files.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/CODE_OF_CONDUCT.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+aes-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+aes-devel %{_description}
This package contains library source intended for building other packages which
use the "aes" feature of the "%{crate}" crate.
%files -n %{name}+aes-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+aes-crypto-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+aes-crypto-devel %{_description}
This package contains library source intended for building other packages which
use the "aes-crypto" feature of the "%{crate}" crate.
%files -n %{name}+aes-crypto-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bzip2-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bzip2-devel %{_description}
This package contains library source intended for building other packages which
use the "bzip2" feature of the "%{crate}" crate.
%files -n %{name}+bzip2-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+constant_time_eq-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+constant_time_eq-devel %{_description}
This package contains library source intended for building other packages which
use the "constant_time_eq" feature of the "%{crate}" crate.
%files -n %{name}+constant_time_eq-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+deflate-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+deflate-devel %{_description}
This package contains library source intended for building other packages which
use the "deflate" feature of the "%{crate}" crate.
%files -n %{name}+deflate-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+deflate-miniz-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+deflate-miniz-devel %{_description}
This package contains library source intended for building other packages which
use the "deflate-miniz" feature of the "%{crate}" crate.
%files -n %{name}+deflate-miniz-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+deflate-zlib-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+deflate-zlib-devel %{_description}
This package contains library source intended for building other packages which
use the "deflate-zlib" feature of the "%{crate}" crate.
%files -n %{name}+deflate-zlib-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+flate2-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+flate2-devel %{_description}
This package contains library source intended for building other packages which
use the "flate2" feature of the "%{crate}" crate.
%files -n %{name}+flate2-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hmac-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+hmac-devel %{_description}
This package contains library source intended for building other packages which
use the "hmac" feature of the "%{crate}" crate.
%files -n %{name}+hmac-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pbkdf2-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+pbkdf2-devel %{_description}
This package contains library source intended for building other packages which
use the "pbkdf2" feature of the "%{crate}" crate.
%files -n %{name}+pbkdf2-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sha1-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sha1-devel %{_description}
This package contains library source intended for building other packages which
use the "sha1" feature of the "%{crate}" crate.
%files -n %{name}+sha1-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+time-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+time-devel %{_description}
This package contains library source intended for building other packages which
use the "time" feature of the "%{crate}" crate.
%files -n %{name}+time-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unreserved-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unreserved-devel %{_description}
This package contains library source intended for building other packages which
use the "unreserved" feature of the "%{crate}" crate.
%files -n %{name}+unreserved-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zstd-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+zstd-devel %{_description}
This package contains library source intended for building other packages which
use the "zstd" feature of the "%{crate}" crate.
%files -n %{name}+zstd-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires -a
%build
%cargo_build -a
%install
%cargo_install -a
%if %{with check}
%check
%cargo_test -a
%endif
%changelog
%autochangelog