update to version 0.5.13

epel9
Fabio Valentini 4 years ago
parent cb64dd7bc2
commit f8c4054b86
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -3,3 +3,4 @@
/zip-0.5.9.crate
/zip-0.5.11.crate
/zip-0.5.12.crate
/zip-0.5.13.crate

@ -1,13 +0,0 @@
diff --git a/src/write.rs b/src/write.rs
index bc68817..4099599 100644
--- a/src/write.rs
+++ b/src/write.rs
@@ -553,7 +553,7 @@ impl<W: Write + io::Seek> GenericZipWriter<W> {
)),
#[cfg(feature = "bzip2")]
CompressionMethod::Bzip2 => {
- GenericZipWriter::Bzip2(BzEncoder::new(bare, bzip2::Compression::Default))
+ GenericZipWriter::Bzip2(BzEncoder::new(bare, bzip2::Compression::default()))
}
CompressionMethod::Unsupported(..) => {
return Err(ZipError::UnsupportedArchive("Unsupported compression"))

@ -5,7 +5,7 @@
%global crate zip
Name: rust-%{crate}
Version: 0.5.12
Version: 0.5.13
Release: 1%{?dist}
Summary: Library to support the reading and writing of zip files
@ -13,10 +13,6 @@ Summary: Library to support the reading and writing of zip files
License: MIT
URL: https://crates.io/crates/zip
Source: %{crates_source}
# Initial patched metadata
# * bump bzip2 from 0.3 to 0.4: https://github.com/zip-rs/zip/pull/202
Patch0: zip-fix-metadata.diff
Patch1: port-to-bzip2-0.4.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -128,6 +124,18 @@ which use "time" feature of "%{crate}" crate.
%files -n %{name}+time-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+unreserved-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unreserved-devel %{_description}
This package contains library source intended for building other packages
which use "unreserved" feature of "%{crate}" crate.
%files -n %{name}+unreserved-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
@ -147,6 +155,10 @@ which use "time" feature of "%{crate}" crate.
%endif
%changelog
* Sat Jun 05 2021 Fabio Valentini <decathorpe@gmail.com> - 0.5.13-1
- Update to version 0.5.13.
- Fixes RHBZ#1968045
* Wed Apr 21 2021 Fabio Valentini <decathorpe@gmail.com> - 0.5.12-1
- Update to version 0.5.12.
- Fixes RHBZ#1950461

@ -1 +1 @@
SHA512 (zip-0.5.12.crate) = 8ead1f24eb7c8c7624c80f8fdc17d85c397686b2cb45174bdc8cfab44417738e1d1a49ae3f776dc0fbb698b20b7de71e94afe1526f8814061289f229891d95f0
SHA512 (zip-0.5.13.crate) = b30950ede91cdb1d4ef4f9d6aee8f62a3aa5a1a6422bd10507dfd76edc02c1bd24d41c7bf2ac416a5ee045562cacda0d17cd04938ec02b8be0a0d64acbaf7e01

@ -1,11 +0,0 @@
--- zip-0.5.12/Cargo.toml 1970-01-01T00:00:00+00:00
+++ zip-0.5.12/Cargo.toml 2021-04-21T20:14:59.180939+00:00
@@ -27,7 +27,7 @@
version = "1.3"
[dependencies.bzip2]
-version = "0.3"
+version = "0.4"
optional = true
[dependencies.crc32fast]
Loading…
Cancel
Save